Macro keyboard shortcuts not working

%3CLINGO-SUB%20id%3D%22lingo-sub-1773583%22%20slang%3D%22en-US%22%3EMacro%20keyboard%20shortcuts%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1773583%22%20slang%3D%22en-US%22%3E%3CP%3EI%20recently%20observed%20some%20difficulty%20with%20assigning%20keys%20to%20macros%20in%20Microsoft%20Word%20that%20I%20still%20don't%20completely%20understand.%20Here%20is%20what%20I%20saw%3A%20I%20created%20-%20in%20Normal.dotm%20-%207%20macros%20for%20various%20simple%20tasks.%20I%20would%20go%20into%20Customize%20Ribbon%20under%20File-%26gt%3BOptions%2C%20Keyboard%20Shortcuts%3A%20Customize%2C%20down%20to%20Macros%20and%20then%20assign%20each%20of%20my%20macros%20a%20keyboard%20shortcut.%20I%20found%20if%20I%20did%20this%20in%20any%20one%20of%20my%20Sharepoint%20Word%20documents%20it%20would%20rarely%20seem%20to%20%22stick%22%20-%20I%20would%20assign%20the%20keys%20but%20go%20back%20into%20the%20document%20and%20they%20wouldn't%20work.%20I%20did%20have%20one%20of%20my%20Word%20documents%20where%20it%20DID%20work%2C%20but%20several%20others%20where%20no%20matter%20how%20many%20times%20I%20assigned%20the%20keyboard%20shortcuts%20they%20just%20wouldn't%20work.%20Reading%20support%20articles%20I%20saw%20something%20that%20said%20macros%20need%20to%20be%20%22Public%22%20for%20keyboard%20shortcuts%20to%20work.%20At%20that%20point%20I%20went%20into%20my%20Normal.dotm%2C%20declared%20all%207%20of%20my%20macros%20%22Public%22%20in%20Visual%20Basic%2C%20deleted%20all%20the%20keyboard%20shortcuts%20and%20re-assigned%20them.%20At%20that%20point%206%20of%20the%207%20worked.%20I%20had%20to%20remove%20and%20then%20re-assign%20the%207th%20item%202%20times%20before%20it%20too%20finally%20%22stuck%22.%20I%20don't%20know%20if%20it%20was%20the%20%22Public%22%20or%20the%20re-assigning%20(I%20suspect%20the%20latter)%20that%20did%20the%20trick%2C%20but%20even%20that%201%20of%20the%207%20didn't%20take%20until%20after%20several%20tries%20tells%20me%20I%20still%20don't%20understand%20the%20root%20cause.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20else%20seen%20behavior%20like%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Regular Visitor

I recently observed some difficulty with assigning keys to macros in Microsoft Word that I still don't completely understand. Here is what I saw: I created - in Normal.dotm - 7 macros for various simple tasks. I would go into Customize Ribbon under File->Options, Keyboard Shortcuts: Customize, down to Macros and then assign each of my macros a keyboard shortcut. I found if I did this in any one of my Sharepoint Word documents it would rarely seem to "stick" - I would assign the keys but go back into the document and they wouldn't work. I did have one of my Word documents where it DID work, but several others where no matter how many times I assigned the keyboard shortcuts they just wouldn't work. Reading support articles I saw something that said macros need to be "Public" for keyboard shortcuts to work. At that point I went into my Normal.dotm, declared all 7 of my macros "Public" in Visual Basic, deleted all the keyboard shortcuts and re-assigned them. At that point 6 of the 7 worked. I had to remove and then re-assign the 7th item 2 times before it too finally "stuck". I don't know if it was the "Public" or the re-assigning (I suspect the latter) that did the trick, but even that 1 of the 7 didn't take until after several tries tells me I still don't understand the root cause.

 

Has anyone else seen behavior like this?

1 Reply

@randyspaulding12 

 

Are you able to run macros locally on your computer? 

 

Where are the macros stored?