Excel object in Word template

Brass Contributor

Does anyone have the same problem? For a very long time now we have Word templates with an excel object embedded. We use them in our order forms. Since a few weeks my object does no longer react the way it did. I enclose one of our templates (converted to a word for this purpose) as an example.


Problem (very difficult to explain but I give it a try):

The object opens in an excel workbook but it reacts differently compared to before.

It used to open "acting as an excel workbook" but still in Word. Clicking outside the object closed the Excel worksheet.

Now, it seems to open as a genuine worksheet/workbook and it does no longer stay active in Word. I have to close the Excell with the x to return to my Word documenten.

When I add lines in the excel worksheet and then I return to my object in Word, the object size cannot be adapted to show all the lines, which I could do before (you had to know how, but it was possible)

I used to be able to modify the size of the object by clicking on the edge markers (before closing the excell object). Now this last action is no longer possible.


I hope this makes sense to somebody.


10 Replies

No one with this same problem? 

Hi Petra


I understand your issue but I am not experiencing it when I open your file (see image).


What version & build of Office are you using? Eg I am on Office 365 and build 1803.






Thank you for responding.


As far as I can see:

Office 365 Built 1805 (9330.2124 Kik-en-klaar).

As you are in 1803 this could be the difference. I noticed the problem only after the latest update from Microsoft.



Hi Petra


It is possible that the recent 1805 update you have might have broken your doc as there were some critical Excel exploits that were addressed which may have caused unintended side effects.


Unfortunately I don't have the latest version to be able to further test this for you.


Maybe if one of our fellow community goers has the right version to test then that might give us a better idea on the issue?


If there's anything else I can assist with, please let me know.


Best of luck!!!




Thank you

This is getting really annoying. Do I need to open a ticket with Microsoft to get this solved? I tried inserting the excell object from scratch but the problem remains the same. Anyone?

Yeah log a ticket. See what Microsoft support says and maybe let us know so others can learn from the answer?

Good luck!


I think Microsoft solved my problem. Today I could use my template the way it should be used.

@Petra Van Horen 

Hi Petra, I've the same problem with an user here in Milan.

May I ask in which way the issue had been fixed from MS Expert ?


Thanks a lot in advance !



Hello Alberto, I am afraid that I no longer use this option in documents. Unfortunately I do not recall what happened or changed exactly. I seem to remember that, although I mentioned that the problem was solved, it reappeared after a while. But as we changed to another programme for our order forms I no longer needed the solution and dit not explore it any further. Sorry I cannot be of more help.