SOLVED

XP Mode on Win7 in WVD

%3CLINGO-SUB%20id%3D%22lingo-sub-1092571%22%20slang%3D%22en-US%22%3EXP%20Mode%20on%20Win7%20in%20WVD%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1092571%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20just%20deployed%20Windows%207%20Enterprise%20for%20our%20WVD%20environment%20per%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fdeploy-windows-7-virtual-machine%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fdeploy-windows-7-virtual-machine%3C%2FA%3E.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe've%20been%20having%20issues%20getting%20XP%20Mode%20to%20work%20despite%20redeploying%20the%20VM%20from%20scratch%20and%20doing%20a%20ton%20of%20troubleshooting%20based%20on%20various%20technet%20articles%20and%20microsoft%20forum%20posts.%20I%20know%20that%20this%20type%20of%20question%20is%20not%20normally%20suited%20for%20the%20WVD%20community%2C%20but%20I%20wanted%20to%20check%20if%20there%20is%20anything%20about%20this%20particular%20Windows%207%20image%20that%20is%20preventing%20XP%20mode%20from%20installing.%20I%20am%20running%20on%20a%20v3%20VM%20which%20should%20support%20nested%20virtualization%20(%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Fnested-virtualization%23create-a-nesting-capable-azure-vm%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Fnested-virtualization%23create-a-nesting-capable-azure-vm%3C%2FA%3E)%20and%20can%20confirm%20that%20hardware%20acceleration%20is%20available.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMore%20specific%20details%3A%20I%20am%20able%20to%20install%20XP%20Mode%20but%20the%20installation%20of%20Virtual%20PC%20(KB958559)%20fails.%20The%20Setup%20event%20log%20says%20%22error%202147943850%20'Insufficient%20system%20resources%20exist%20to%20complete%20the%20requested%20service.'%22%2C%20and%20the%20System%20event%20log%20says%20%22Installation%20Failure%3A%20Windows%20failed%20to%20install%20the%20following%20update%20with%20error%200x800705aa%3A%20Update%20for%20Windows%20(KB958559).%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1136296%22%20slang%3D%22en-US%22%3ERe%3A%20XP%20Mode%20on%20Win7%20in%20WVD%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1136296%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F344062%22%20target%3D%22_blank%22%3E%40dbriles%3C%2FA%3E%26nbsp%3B%3CSPAN%3EWindows%20XP%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3BMode%20follows%20the%20same%20support%20life-cycle%26nbsp%3Bas%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3EWindows%20XP%20-%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3Eextended%20support%20has%20ended%20on%20April%208%2C%202014.%20However%20-%26nbsp%3B%3C%2FSPAN%3Ethe%20Windows%207%20image%20in%20the%20gallery%20doesn't%20have%20anything%20configured%20to%20block%20XP%20mode%20-%20it's%20a%20pretty%20standard%20Windows%207%20image%20with%20some%20optimizations%20for%20Azure.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

We just deployed Windows 7 Enterprise for our WVD environment per https://docs.microsoft.com/en-us/azure/virtual-desktop/deploy-windows-7-virtual-machine.

 

We've been having issues getting XP Mode to work despite redeploying the VM from scratch and doing a ton of troubleshooting based on various technet articles and microsoft forum posts. I know that this type of question is not normally suited for the WVD community, but I wanted to check if there is anything about this particular Windows 7 image that is preventing XP mode from installing. I am running on a v3 VM which should support nested virtualization (https://docs.microsoft.com/en-us/azure/virtual-machines/windows/nested-virtualization#create-a-nesti...) and can confirm that hardware acceleration is available.

 

More specific details: I am able to install XP Mode but the installation of Virtual PC (KB958559) fails. The Setup event log says "error 2147943850 'Insufficient system resources exist to complete the requested service.'", and the System event log says "Installation Failure: Windows failed to install the following update with error 0x800705aa: Update for Windows (KB958559)."

 

 

1 Reply
Highlighted
Best Response confirmed by Eva Seydl (Microsoft)
Solution

@dbriles Windows XP Mode follows the same support life-cycle as Windows XP - extended support has ended on April 8, 2014. However - the Windows 7 image in the gallery doesn't have anything configured to block XP mode - it's a pretty standard Windows 7 image with some optimizations for Azure.