SOLVED

WVD - Visual Studio 2019 on Windows 10 - Image not available.

%3CLINGO-SUB%20id%3D%22lingo-sub-1388261%22%20slang%3D%22en-US%22%3EWVD%20-%20Visual%20Studio%202019%20on%20Windows%2010%20-%20Image%20not%20available.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1388261%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20trying%20to%20create%20a%20host%20pool%20(in%20Southeast%20Asia)%20and%20add%20VMs%20to%20it%20using%20portal.%20I%20have%20selected%20the%20VM%20Image%20of%20Visual%20Studio%202019%20(Tried%20with%20Community%20and%20Enterprise)%20on%20Windows%2010.%20This%20image%20is%20standard%20available%20from%20marketplace.%20I%20tried%20it%203%20times%20and%20all%20the%20times%20it%20failed%20to%20find%20the%20image.%20The%20error%20is%3A%3C%2FP%3E%3CP%3E%3CSPAN%3E%7B%22code%22%3A%22DeploymentFailed%22%2C%22message%22%3A%22At%20least%20one%20resource%20deployment%20operation%20failed.%20Please%20list%20deployment%20operations%20for%20details.%20Please%20see%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FDeployOperations%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FDeployOperations%3C%2FA%3E%20for%20usage%20details.%22%2C%22details%22%3A%5B%7B%22code%22%3A%22BadRequest%22%2C%22message%22%3A%22%7B%5Cr%5Cn%20%5C%22error%5C%22%3A%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22InvalidTemplateDeployment%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22The%20template%20deployment%20'vmCreation-linkedTemplate-39e2c88a-3587-47e4-ad37-47cde9049023'%20is%20not%20valid%20according%20to%20the%20validation%20procedure.%20The%20tracking%20id%20is%20'1d310798-53ed-44a1-9463-25b420dd80d1'.%20See%20inner%20errors%20for%20details.%5C%22%2C%5Cr%5Cn%20%5C%22details%5C%22%3A%20%5B%5Cr%5Cn%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22InvalidParameter%5C%22%2C%5Cr%5Cn%20%5C%22target%5C%22%3A%20%5C%22imageReference%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22%3CFONT%20color%3D%22%23FF0000%22%3E%3CU%3E%3CEM%3EThe%20following%20list%20of%20images%20referenced%20from%20the%20deployment%20template%20are%20not%20found%3A%20Publisher%3A%20microsoftvisualstudio%2C%20Offer%3A%20visualstudio2019%2C%20Sku%3A%20vs-2019-ent-win10-n%2C%20Version%3A%20latest%3C%2FEM%3E%3C%2FU%3E%3C%2FFONT%3E.%20Please%20refer%20to%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Fcli-ps-findimage%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Fcli-ps-findimage%3C%2FA%3E%20for%20instructions%20on%20finding%20available%20images.%5C%22%5Cr%5Cn%20%7D%5Cr%5Cn%20%5D%5Cr%5Cn%20%7D%5Cr%5Cn%7D%22%7D%5D%7D%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EPlease%20guide%20me%20to%20create%20this%20Host%20Pool.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1434188%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20-%20Visual%20Studio%202019%20on%20Windows%2010%20-%20Image%20not%20available.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1434188%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F667275%22%20target%3D%22_blank%22%3E%40Subodh_Sohoni%3C%2FA%3E%26nbsp%3Bif%20you%20run%26nbsp%3B%3C%2FP%3E%0A%3CDIV%3E%0A%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%0A%3CDIV%3E%3CSPAN%3E%24locName%3C%2FSPAN%3E%3CSPAN%3E%3D%3C%2FSPAN%3E%3CSPAN%3E%22southeastasia%22%3C%2FSPAN%3E%3C%2FDIV%3E%0A%3C%2FDIV%3E%0A%3CDIV%3E%0A%3CDIV%3E%3CSPAN%3EGet-AzVMImagePublisher%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B-Location%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%24locName%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%7C%26nbsp%3BSelect%26nbsp%3Bmicrosoftvisualstudio%3C%2FSPAN%3E%3C%2FDIV%3E%0A%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%0A%3CDIV%3E%3CSPAN%3Eyou%20will%20see%20that%20there%20are%20no%20images%20from%20that%20publisher%20in%20Southeastasia%20region.%20I%20would%20advise%20to%20escalate%20to%20Azure%20support%20and%20file%20a%20bug%20on%20the%20images%20not%20being%20available%20outside.%20Alternatively%20deploy%20a%20windows%2010%20enterprise%20and%20manually%20install%20VS.%3C%2FSPAN%3E%3C%2FDIV%3E%0A%3C%2FDIV%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I am trying to create a host pool (in Southeast Asia) and add VMs to it using portal. I have selected the VM Image of Visual Studio 2019 (Tried with Community and Enterprise) on Windows 10. This image is standard available from marketplace. I tried it 3 times and all the times it failed to find the image. The error is:

{"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details.","details":[{"code":"BadRequest","message":"{\r\n \"error\": {\r\n \"code\": \"InvalidTemplateDeployment\",\r\n \"message\": \"The template deployment 'vmCreation-linkedTemplate-39e2c88a-3587-47e4-ad37-47cde9049023' is not valid according to the validation procedure. The tracking id is '1d310798-53ed-44a1-9463-25b420dd80d1'. See inner errors for details.\",\r\n \"details\": [\r\n {\r\n \"code\": \"InvalidParameter\",\r\n \"target\": \"imageReference\",\r\n \"message\": \"The following list of images referenced from the deployment template are not found: Publisher: microsoftvisualstudio, Offer: visualstudio2019, Sku: vs-2019-ent-win10-n, Version: latest. Please refer to https://docs.microsoft.com/en-us/azure/virtual-machines/windows/cli-ps-findimage for instructions on finding available images.\"\r\n }\r\n ]\r\n }\r\n}"}]}

Please guide me to create this Host Pool.

1 Reply
Highlighted
Best Response confirmed by Eva Seydl (Microsoft)
Solution

@Subodh_Sohoni if you run 

 
$locName="southeastasia"
Get-AzVMImagePublisher -Location $locName | Select microsoftvisualstudio
 
you will see that there are no images from that publisher in Southeastasia region. I would advise to escalate to Azure support and file a bug on the images not being available outside. Alternatively deploy a windows 10 enterprise and manually install VS.