WVD Session Host is unavailable

%3CLINGO-SUB%20id%3D%22lingo-sub-1508606%22%20slang%3D%22en-US%22%3EWVD%20Session%20Host%20is%20unavailable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1508606%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20I%20have%20WVD%20Personal%20machines%20for%204%20users%20using%20Fall%202019%20deployment.%3C%2FP%3E%3CP%3EThe%20four%20users%20were%20able%20to%20log%20in%20and%20access%20their%20machines.%20One%20of%20the%20user%20is%20facing%20an%20issue%2C%20this%20user%20is%20not%20able%20to%20login%20to%20the%20WVD.%20I%20have%20attached%20the%20error%20screenshot%20and%20also%20I%20have%20checked%20the%20session%20host%20it%20is%20showing%20unavailable%20for%20this%20particular%20user%20and%20available%20for%20others.%20I%20have%20no%20idea%20how%20this%20is%20happening.%20The%20user%20was%20able%20to%20log%20in%204%20days%20ago%20and%20today%20not%20able%20to.%20Any%20help%20will%20be%20much%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1509663%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20Session%20Host%20is%20unavailable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1509663%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F557804%22%20target%3D%22_blank%22%3E%40gadmin285%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20sounds%20like%20my%20issue%20where%20the%20WVD%20agents%20were%20failing%20to%20update%20the%20desktops.%26nbsp%3B%20you%20may%20need%20to%20remove%20the%20agents%20and%20reinstall%20and%20rejoin%20it%20to%20the%20pool.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20thread%20about%20the%20automatic%20updates%20here%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fwindows-virtual-desktop%2Fhas-anyone-found-a-way-to-disable-the-wvd-agent-automatic%2Fm-p%2F1506305%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fwindows-virtual-desktop%2Fhas-anyone-found-a-way-to-disable-the-wvd-agent-automatic%2Fm-p%2F1506305%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1510617%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20Session%20Host%20is%20unavailable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1510617%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20the%20reply%2C%26nbsp%3Bremove%20the%20agents%2C%20and%20reinstall%20and%20rejoin%20it%20to%20the%20pool%3F%20Do%20you%20have%20any%20documentation%20for%20this%3F%20I%20will%20check%20the%20link%20which%20you%20have%20provided.%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F458155%22%20target%3D%22_blank%22%3E%40AndrewPhebus%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1512020%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20Session%20Host%20is%20unavailable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1512020%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%2C%26nbsp%3Beveryone%20the%20issue%20is%20resolved.%20I%20have%20raised%20a%20support%20ticket%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F557804%22%20target%3D%22_blank%22%3E%40gadmin285%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1512945%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20Session%20Host%20is%20unavailable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1512945%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F557804%22%20target%3D%22_blank%22%3E%40gadmin285%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20did%20you%20have%20to%20do%20to%20resolve%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1513233%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20Session%20Host%20is%20unavailable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1513233%22%20slang%3D%22en-US%22%3Ethanks%20for%20raising%20the%20support%20tickets.%20Our%20support%20service%20will%20follow%20up.%3CBR%20%2F%3EI%20quickly%20looked%20at%20your%20sessionhost%2C%20it%20never%20able%20to%20contact%20WVD%20successfully%2C%20and%20the%20assigned%20user%20has%20not%20been%20able%20to%20create%20a%20successful%20connection.%20One%20thing%20you%20can%20check%20is%20WVD%20agent%20log%20in%20event%20log%20Application%20Source%20%3D%20WvdAgent%20to%20see%20if%20there%20is%20any%20abnormal%20activity.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1520197%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20Session%20Host%20is%20unavailable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1520197%22%20slang%3D%22en-US%22%3E%3CP%3EThe%26nbsp%3Bproblem%20is%203%20machines%20are%20running%20with%20a%20new%20version%20of%20RD%20Agent%2C%20the%20one%20machine%20is%20troubling%20is%20running%20with%20an%20older%20version%20of%20RD%20Agent.%20So%2C%20I%20logged%20into%20the%20machine%20by%20private%20IP%2C%20removed%20the%20existing%20agent%2C%20and%20generated%20a%20token%20for%20the%20new%20agent%2C%20installed%20the%20latest%20version%20and%20restarted.%20This%20will%20solve%20the%20issue.%20I%20am%20not%20sure%20if%20its%20RD%20agent%20or%20some%20VM%20agent%26nbsp%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F458155%22%20target%3D%22_blank%22%3E%40AndrewPhebus%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Hi, I have WVD Personal machines for 4 users using Fall 2019 deployment.

The four users were able to log in and access their machines. One of the user is facing an issue, this user is not able to login to the WVD. I have attached the error screenshot and also I have checked the session host it is showing unavailable for this particular user and available for others. I have no idea how this is happening. The user was able to log in 4 days ago and today not able to. Any help will be much appreciated.

6 Replies
Highlighted

@gadmin285 

This sounds like my issue where the WVD agents were failing to update the desktops.  you may need to remove the agents and reinstall and rejoin it to the pool.

 

I have a thread about the automatic updates here:

https://techcommunity.microsoft.com/t5/windows-virtual-desktop/has-anyone-found-a-way-to-disable-the...

 

 

Highlighted

Thanks for the reply, remove the agents, and reinstall and rejoin it to the pool? Do you have any documentation for this? I will check the link which you have provided. @AndrewPhebus 

Highlighted

Thanks, everyone the issue is resolved. I have raised a support ticket@gadmin285 

Highlighted

@gadmin285 

What did you have to do to resolve?

 

 

Highlighted
thanks for raising the support tickets. Our support service will follow up.
I quickly looked at your sessionhost, it never able to contact WVD successfully, and the assigned user has not been able to create a successful connection. One thing you can check is WVD agent log in event log Application Source = WvdAgent to see if there is any abnormal activity.
Highlighted

The problem is 3 machines are running with a new version of RD Agent, the one machine is troubling is running with an older version of RD Agent. So, I logged into the machine by private IP, removed the existing agent, and generated a token for the new agent, installed the latest version and restarted. This will solve the issue. I am not sure if its RD agent or some VM agent  @AndrewPhebus