WVD Agent 1.0.2839.400 Causing Hosts to go into an Unavailable state

%3CLINGO-SUB%20id%3D%22lingo-sub-2146305%22%20slang%3D%22en-US%22%3EWVD%20Agent%201.0.2839.400%20Causing%20Hosts%20to%20go%20into%20an%20Unavailable%20state%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2146305%22%20slang%3D%22en-US%22%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EI've%20been%20testing%20out%20WVD%20and%20hadn't%20had%20this%20issue%20come%20up.%20Now%20It's%20happening%20as%20soon%20as%20the%20hosts%20move%20to%20WVD%20agent%201.0.2839.400%20from%20the%20previous%201.0.2548.6500.%20We%20can%20still%20connect%20to%20the%20SessionHosts%20just%20fine.%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EWe%20built%20a%20new%20Sessionhost%20and%20it%20was%20fine%2C%20until%20it%20updates%20to%20that%20version...%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3ERemoving%20the%20WVD%20Agent%2C%20the%20Bootloader%20Agent%2C%20Geneva%20Agent%2C%20and%20SxS%20program%2C%20removing%20it%20from%20the%20hostpool%20and%20then%20reinstalling%20the%20WVD%20agent%20with%20the%20current%20reg%20key%20and%20then%20the%20bootloader%20agent%20fixes%20the%20issue%20for...%20a%20little%20bit.%20Soon%20as%20it%20updates%20to%20this%20new%20WVD%20agent%20version%20it%20bombs%20out%20again.%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3ENow%20after%20working%20with%20MSIX%20App%20Attach%20my%20SessionsHosts%20appear%20to%20be%20unusable%20due%20to%20this%20Unavailable%20issue.%20I%20get%20errors%20such%20as%20Start%20Menu%20is%20unavailable%20and%20I%20can%20do%20nothing%20on%20my%20machines%20except%20log%20out.%20This%20was%20100%25%20not%20an%20issue%20before%20this%20new%20agent%20rolled%20out%20and%20there%20is%200%20information%20on%20how%20to%20fix%20this%20anywhere.%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EAnyone%20else%20noticed%20or%20had%20this%20problem%2C%20it%20just%20started%20yesterday%20from%20what%20I%20can%20see%2C%20maybe%20before%20as%20I%20was%20away%20part%20of%20last%20week%20and%20hadn't%20been%20checking.%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%3CSPAN%3ERestarting%20the%20boot%20loader%20service%20and%20the%20rdagent%20service%20on%20each%20sessionhost%20fixed%20the%20issue%20SOMETIMES%20for%20a%20limited%20time.%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2146432%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20Agent%201.0.2839.400%20Causing%20Hosts%20to%20go%20into%20an%20Unavailable%20state%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2146432%22%20slang%3D%22en-US%22%3E%3CP%3ETry%20giving%20the%20steps%20in%20this%20article%20a%20try.%20It%20solved%20a%20similar%20issue%20for%20me%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Flevel400.org%2F2020%2F12%2F11%2Fwvd-rdagentbootloader-object-reference-not-set-to-an-instance-of-an-object%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Flevel400.org%2F2020%2F12%2F11%2Fwvd-rdagentbootloader-object-reference-not-set-to-an-instance-of-an-object%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2147133%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20Agent%201.0.2839.400%20Causing%20Hosts%20to%20go%20into%20an%20Unavailable%20state%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2147133%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F956363%22%20target%3D%22_blank%22%3E%40YannickJanssens1986%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUnfortunately%2C%20my%20registry%20is%20correctly%20set.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20not%20even%20seeing%20errors%20to%20troubleshoot%20in%20my%20application%20logs%20which%20is%20infuriating.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

I've been testing out WVD and hadn't had this issue come up. Now It's happening as soon as the hosts move to WVD agent 1.0.2839.400 from the previous 1.0.2548.6500. We can still connect to the SessionHosts just fine.

We built a new Sessionhost and it was fine, until it updates to that version...

Removing the WVD Agent, the Bootloader Agent, Geneva Agent, and SxS program, removing it from the hostpool and then reinstalling the WVD agent with the current reg key and then the bootloader agent fixes the issue for... a little bit. Soon as it updates to this new WVD agent version it bombs out again. 

 

Now after working with MSIX App Attach my SessionsHosts appear to be unusable due to this Unavailable issue. I get errors such as Start Menu is unavailable and I can do nothing on my machines except log out. This was 100% not an issue before this new agent rolled out and there is 0 information on how to fix this anywhere.

 

Anyone else noticed or had this problem, it just started yesterday from what I can see, maybe before as I was away part of last week and hadn't been checking.

 

Restarting the boot loader service and the rdagent service on each sessionhost fixed the issue SOMETIMES for a limited time. 

 

Edit: Rebooting the other session hosts at least made them usable. MSIX App Attach is still a total non-worker. Built a new session host based off an image where I ran Windows Updates that pulled .NET update. Currently its not on the newest WVD Agent so we'll see what happens once it kicks over. 

 

EDIT EDIT: Built a BRAND NEW SESSIONHOST using the Azure provided Win 10 2004 Multi-Session image and it too went unavailable after updating.............. ..... .... ... .. .

 

3 Replies

@YannickJanssens1986 

 

Unfortunately, my registry is correctly set.

 

I'm not even seeing errors to troubleshoot in my application logs which is infuriating.

Today I found that if I move my HostPool out of Validation environment and reboot the SessionHosts they eventually download a slightly lesser version of the WVD Agent and then they become available. Soon as I kick it back into Validation environment it goes back to unavailable after downloading the new version.

 

Is this intended?