Windows Remote Desktop Client bug - "failed to subscribe since there is no workspace"

Occasional Contributor

We have had a couple of users connecting to RemoteApps fine using the Windows Remote Desktop Client. It started throwing errors saying cannot refresh so we tried unsubscribing and resubscribing and this is where the fun starts:


Click subscribe > an immediate error pops up "We failed to subscribe since there is no Workspace at



Note that the url (I believe) is the non ARM classic URL. We have never deployed using this.


The problem persists even when we clear personal data (from the about tab) and uninstall and reinstall.


If we click Subscribe with url > does not recognise the email address (even though we have email discovery turned on and the user accounts are fine as they worked yesterday). Add in the ARM subscribe URL and it is not recognised, the Confirm button is not enabled so we can do nothing.


Clearly some strange bug with the client.


Any ideas how I can get round  this?

0 Replies