Windows cannot start the remote app program

%3CLINGO-SUB%20id%3D%22lingo-sub-1518617%22%20slang%3D%22en-US%22%3EWindows%20cannot%20start%20the%20remote%20app%20program%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1518617%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20user%20who%20belongs%20to%20both%20virtual%20desktop%20and%20virtual%20apps%20group.%20the%20issue%20is%20when%20the%20user%20login%20to%20Virtual%20Desktop%20and%20logout%20%2C%20and%20then%20try%20to%20use%20the%20Virtual%20apps%20he%20is%20getting%20attached%20error%20message.%20the%20only%20way%20to%20fix%20this%20is%20to%20restart%20session%20hosts(which%20is%20not%20practical%20when%20others%20are%20using).%3C%2FP%3E%3CP%3EAny%20idea%20why%20this%20is%20happening%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EPremson.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1519452%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20cannot%20start%20the%20remote%20app%20program%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1519452%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F265214%22%20target%3D%22_blank%22%3E%40premson_baby%3C%2FA%3E%26nbsp%3B%20Have%20you%20checked%20this%20registry%20setting%3F%3F%20That%20is%20the%20setting%20which%20normally%20causes%20that%20behaviour.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHKLM%5CSOFTWARE%5CMicrosoft%5CWindows%20NT%5CCurrentVersion%5CTerminal%20Server%5CTSAppAllowList%3C%2FP%3E%3CP%3EFind%20the%20key%20%E2%80%9CfDisabledAllowList%E2%80%9D%3C%2FP%3E%3CP%3EIt%20will%20be%20set%20to%20%E2%80%9C0%E2%80%9D%3C%2FP%3E%3CP%3EChange%20to%20%E2%80%9C1%E2%80%9D.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMaybe%20you%20have%20a%20policy%20setting%20which%20is%20controlling%20it%3F%3F%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1525816%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20cannot%20start%20the%20remote%20app%20program%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1525816%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F235785%22%20target%3D%22_blank%22%3E%40Neil%20McLoughlin%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks'%20for%20your%20response%2C%20I%20will%20check%20with%20client%20and%20update.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBut%20I%20wonder%20if%20the%20restart%20of%20the%20session%20VM's%20fixing%20the%20issue%20then%2C%20it's%20not%20an%20issue%20in%20the%20client%20side%2C%20it%20should%20be%20an%20issue%20in%20the%20WVD%20session%20host's%20side%2C%20like%20some%20sort%20of%20session%20locking%20for%20the%20user%3F%26nbsp%3B%3C%2FP%3E%3CP%3ESuch%20as%20only%20one%20session%20is%20allowed%20for%20a%20user%2C%20and%20the%20session%20lock%20is%20not%20releasing%20on%20time%3F%3C%2FP%3E%3CP%3EAlso%20I%20am%20using%20fslogix%2C%20and%20Azure%20storage%20file%20share%20for%20user%20session%20management.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFollowing%20are%20my%20fslogix%20registry%20settings.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%5BHKEY_LOCAL_MACHINE%5CSOFTWARE%5CFSLogix%5CProfiles%5D%3CBR%20%2F%3E%22Enabled%22%3Ddword%3A00000001%3CBR%20%2F%3E%22VHDLocations%22%3D%22Path-to-storage-fileshare%22%3CBR%20%2F%3E%22GroupPolicyState%22%3Ddword%3A00000000%3CBR%20%2F%3E%22DeleteLocalProfileWhenVHDShouldApply%22%3Ddword%3A00000001%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESession%20hosts%20OS%20is%20windows%20server%202019.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hi,

 

I have a user who belongs to both virtual desktop and virtual apps group. the issue is when the user login to Virtual Desktop and logout , and then try to use the Virtual apps he is getting attached error message. the only way to fix this is to restart session hosts(which is not practical when others are using).

Any idea why this is happening? 

 

Thanks,

Premson.

2 Replies
Highlighted

@premson_baby  Have you checked this registry setting?? That is the setting which normally causes that behaviour. 

 

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\TSAppAllowList

Find the key “fDisabledAllowList”

It will be set to “0”

Change to “1”.

 

Maybe you have a policy setting which is controlling it???

Highlighted

@Neil McLoughlin 

 

Thanks' for your response, I will check with client and update.

 

But I wonder if the restart of the session VM's fixing the issue then, it's not an issue in the client side, it should be an issue in the WVD session host's side, like some sort of session locking for the user? 

Such as only one session is allowed for a user, and the session lock is not releasing on time?

Also I am using fslogix, and Azure storage file share for user session management. 

 

Following are my fslogix registry settings.

 

[HKEY_LOCAL_MACHINE\SOFTWARE\FSLogix\Profiles]
"Enabled"=dword:00000001
"VHDLocations"="Path-to-storage-fileshare"
"GroupPolicyState"=dword:00000000
"DeleteLocalProfileWhenVHDShouldApply"=dword:00000001

 

Session hosts OS is windows server 2019.

 

Regards.