Win10 2004 not working with WVD? Unable to connect



I just updated our WVD image with the new 2004 update (ARM WVD).
If I deploy new servers in the existing hostpool, they go into "upgrading" and then "unavailable".
Restarting the VMs makes them come up as "Available" (and no issues either according to powershell).
However, I am unable to connect to any of the new VMs.

Same issue occurs if i create a new hostpool/application pool with the new 2004 image.

I have also tried re-subscribing in the Remote Desktop app (newest version).


I can RDP to the new (2004) server without any issue - just cant connect through WVD.

If i disable drain mode on the old VMs (non-2004) I am able to join the servers without any issue.


Any ideas?

3 Replies

Hi @Raaert


thanks for raising your issue! Had the same today. 

I was able to solve it like this:


1.  Navigate to your future Session Host that has been deployed and navigate to the install folder of the "Deploy Agent": C:\DeployAgent\RDInfraSxSStackInstall

2. Reinstall the SxSStackInstaller-181129002.msi

3. Restart the Session Host


That should definitely solve your issue!

If you need more help, please come back to me!






That could be the very fix I was looking for (i did notice a difference in sxs information in powershell).

However, I have just deployed my image (2004) and everything works as expected, I can only assume that Microsoft has fixed the bug in Azure.



I had this exact same issue with my 2004 image and reinstalling the SXS Installer worked. Now though any update to it fails

SxSStackVersion : rdp-sxs
Type : Microsoft.DesktopVirtualization/hostpools/sessionhosts
UpdateErrorMessage : There was an issue installing the SxsStack This action is only valid for products that are currently installed.

And manually reinstalling isn't exactly tenable when deploying 20 SessionHosts in bulk. I went ahead and opened a ticket with Microsoft on it.