validation error while create azure virtual desktop pool

%3CLINGO-SUB%20id%3D%22lingo-sub-1239229%22%20slang%3D%22en-US%22%3Evalidation%20error%20while%20create%20azure%20virtual%20desktop%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1239229%22%20slang%3D%22en-US%22%3E%3CP%3EDeployment%20template%20validation%20failed%3A%20'The%20provided%20value%20'Microsoft.WindowsAzure.ResourceStack.Frontdoor.Common.Entities.Template%20Generic%20Property%601%5BNewtonsoft.Json.Linq.JToken%5D'%20for%20the%20template%20parameter%20'newOrExistingVnet'%20at%20line%20'158'%20and%20column%20'24'%20is%20not%20valid.%20The%20parameter%20value%20is%20not%20part%20of%20the%20allowed%20value(s)%3A%20'existing'.'.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1239229%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Ew%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1243365%22%20slang%3D%22en-US%22%3ERe%3A%20validation%20error%20while%20create%20azure%20virtual%20desktop%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1243365%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F587322%22%20target%3D%22_blank%22%3E%40FarrukhAnwar%3C%2FA%3E%26nbsp%3BAny%20resolution%20or%20workaround%20for%20below.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%E2%80%9CDeployment%20template%20validation%20failed%3A%20'The%20provided%20value%20'Microsoft.WindowsAzure.ResourceStack.Frontdoor.Common.Entities.TemplateGenericProperty%601%5BNewtonsoft.Json.Linq.JToken%5D'%20for%20the%20template%20parameter%20'newOrExistingVnet'%20at%20line%20'158'%20and%20column%20'24'%20is%20not%20valid.%20The%20parameter%20value%20is%20not%20part%20of%20the%20allowed%20value(s)%3A%20'existing'.'.%E2%80%9D%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1266087%22%20slang%3D%22en-US%22%3ERe%3A%20validation%20error%20while%20create%20azure%20virtual%20desktop%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1266087%22%20slang%3D%22en-US%22%3EHey%2C%20This%20is%20pretty%20easy%20to%20resolve%20if%20you%20are%20still%20running%20into%20this%20problem.%20The%20problem%20comes%20in%20if%20you%20created%20the%20Network%20and%20Subnet%20in%20the%20same%20browser%20session%20that%20you%20plan%20to%20use%20to%20create%20the%20Windows%20Virtual%20Desktop%20pool.%20Open%20a%20browser%20Incognito%20and%20attempt%20to%20create%20the%20WVD.%20You%20should%20see%20success.%20You'll%20know%20you'll%20get%20success%20if%20you%20can%20finally%20see%20and%20select%20the%20network%20and%20subnet%20you%20was%20the%20WVD%20to%20connect%20to.%3CBR%20%2F%3E%3CBR%20%2F%3EThis%20is%20what%20solve%20my%20exact%20same%20issue.%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Deployment template validation failed: 'The provided value 'Microsoft.WindowsAzure.ResourceStack.Frontdoor.Common.Entities.Template Generic Property`1[Newtonsoft.Json.Linq.JToken]' for the template parameter 'newOrExistingVnet' at line '158' and column '24' is not valid. The parameter value is not part of the allowed value(s): 'existing'.'.

  • w
3 Replies
Highlighted

@FarrukhAnwar Any resolution or workaround for below.

 

“Deployment template validation failed: 'The provided value 'Microsoft.WindowsAzure.ResourceStack.Frontdoor.Common.Entities.TemplateGenericProperty`1[Newtonsoft.Json.Linq.JToken]' for the template parameter 'newOrExistingVnet' at line '158' and column '24' is not valid. The parameter value is not part of the allowed value(s): 'existing'.'.”

Highlighted
Hey, This is pretty easy to resolve if you are still running into this problem. The problem comes in if you created the Network and Subnet in the same browser session that you plan to use to create the Windows Virtual Desktop pool. Open a browser Incognito and attempt to create the WVD. You should see success. You'll know you'll get success if you can finally see and select the network and subnet you was the WVD to connect to.

This is what solve my exact same issue.
Highlighted

@Phoenixtekk 

Thanks so much for your explanation!! I had tried creating VM's without success until I came across your post...once I used an incognito session I was able to select my previously created VNets....