Trouble setting up Host Pool for Windows Virtual Desktop

%3CLINGO-SUB%20id%3D%22lingo-sub-1170223%22%20slang%3D%22en-US%22%3ETrouble%20setting%20up%20Host%20Pool%20for%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1170223%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20setting%20up%20Windows%20Virtual%20Desktop%20for%20the%20first%20time.%26nbsp%3B%20I%20have%20completed%20all%20the%20prerequsite%20work%20in%20Power%20Shell.%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20try%20to%20create%20host%20pool%20via%20marketplace%2Fwizard%2C%20I%26nbsp%3B%20get%20the%20following%20error%20when%20it%20tries%20to%20validate%3A%3C%2FP%3E%3CP%3E%3CEM%3EDeployment%20template%20validation%20failed%3A%20'The%20provided%20value%20'Microsoft.WindowsAzure.ResourceStack.Frontdoor.Common.Entities.TemplateGenericProperty%601%5BNewtonsoft.Json.Linq.JToken%5D'%20for%20the%20template%20parameter%20'newOrExistingVnet'%20at%20line%20'152'%20and%20column%20'24'%20is%20not%20valid.%20The%20parameter%20value%20is%20not%20part%20of%20the%20allowed%20value(s)%3A%20'existing'.'.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20see%20lots%20of%20other%20folks%20online%20w%2F%20same%20issue.%26nbsp%3B%20Supposedly%20it%20is%20a%20known%20bug%20that%20was%20very%20recently%20fixed%20(except%20it%20wasn't)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20then%20attempted%20to%20create%20host%20pool%20via%20PowerShell%20using%20these%20instructions%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fcreate-host-pools-powershell%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fcreate-host-pools-powershell%3C%2FA%3E%3C%2FP%3E%3CP%3EWhen%20I%20run%20the%20command%20to%20create%20a%20registration%20token%2C%20I%20get%20this%20error%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3ENew-RdsRegistrationInfo%20%3A%20Object%20reference%20not%20set%20to%20an%20instance%20of%20an%20object.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20would%20be%20much%20appreciated.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EMike%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

I am setting up Windows Virtual Desktop for the first time.  I have completed all the prerequsite work in Power Shell. 

When I try to create host pool via marketplace/wizard, I  get the following error when it tries to validate:

Deployment template validation failed: 'The provided value 'Microsoft.WindowsAzure.ResourceStack.Frontdoor.Common.Entities.TemplateGenericProperty`1[Newtonsoft.Json.Linq.JToken]' for the template parameter 'newOrExistingVnet' at line '152' and column '24' is not valid. The parameter value is not part of the allowed value(s): 'existing'.'.

 

I see lots of other folks online w/ same issue.  Supposedly it is a known bug that was very recently fixed (except it wasn't)

 

I then attempted to create host pool via PowerShell using these instructions:

https://docs.microsoft.com/en-us/azure/virtual-desktop/create-host-pools-powershell

When I run the command to create a registration token, I get this error:

 

New-RdsRegistrationInfo : Object reference not set to an instance of an object.

 

Any help would be much appreciated.

 

Thanks,

Mike

 

 

1 Reply
Highlighted
Hey, This is pretty easy to resolve if you are still running into this problem. The problem comes in if you created the Network and Subnet in the same browser session that you plan to use to create the Windows Virtual Desktop pool. Open a browser Incognito and attempt to create the WVD. You should see success. You'll know you'll get success if you can finally see and select the network and subnet you was the WVD to connect to.

This is what solve my exact same issue.