SOLVED

Remote App presenting the apps together as if it was in the Web client

%3CLINGO-SUB%20id%3D%22lingo-sub-2145579%22%20slang%3D%22en-US%22%3ERemote%20App%20presenting%20the%20apps%20together%20as%20if%20it%20was%20in%20the%20Web%20client%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2145579%22%20slang%3D%22en-US%22%3E%3CP%3EI%20spun%20up%20several%20WVD%20instances%20in%20the%20lab%20without%20issue%2C%20both%20desktop%20and%20remote%20app%20worked%20as%20expected.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20spun%20up%20a%20production%20instance%2C%20and%20added%20even%20one%20Remote%20App%20(notepad)%2C%20the%20apps%20do%20not%20behave%20like%20you%20would%20expect%20for%20a%20Remote%20App.%20They%20behave%20like%20you%20see%20in%20the%20HTML5%20remote%20desktop%20client%20where%20it%20shows%20a%20box%20around%20the%20app%20with%20lots%20of%20white%20space%2C%20and%20all%20the%20apps%20float%20in%20there%20and%20do%20not%20appear%20like%20a%20local%20app%20would.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EVideo%20of%20the%20issue%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fshare.getcloudapp.com%2F7KupEZL4%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3EScreen%20Recording%202021-02-18...%20(getcloudapp.com)%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20got%20ideas%20on%20what%20is%20causing%20this%20and%20how%20to%20fix%20it%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2146316%22%20slang%3D%22en-US%22%3ERe%3A%20Remote%20App%20presenting%20the%20apps%20together%20as%20if%20it%20was%20in%20the%20Web%20client%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2146316%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F225008%22%20target%3D%22_blank%22%3E%40Brian%20Martin%3C%2FA%3E%26nbsp%3B%26nbsp%3B%20Just%20a%20suggestion%2C%20try%20downloading%20the%20latest%20WVD%20client%20from%20here%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fconnect-windows-7-10%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fconnect-windows-7-10%3C%2FA%3E%26nbsp%3B%20You%20might%20be%20using%20the%20Remote%20Desktop%20client%20that%20has%20been%20downloaded%20from%20the%20MS%20store%20(the%20icons%20look%20very%20similar).%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I spun up several WVD instances in the lab without issue, both desktop and remote app worked as expected.

 

When I spun up a production instance, and added even one Remote App (notepad), the apps do not behave like you would expect for a Remote App. They behave like you see in the HTML5 remote desktop client where it shows a box around the app with lots of white space, and all the apps float in there and do not appear like a local app would.

 

Video of the issue:

 

Screen Recording 2021-02-18... (getcloudapp.com)

 

Anyone got ideas on what is causing this and how to fix it?

2 Replies
Best Response confirmed by Brian Martin (Occasional Contributor)
Solution

@Brian Martin   Just a suggestion, try downloading the latest WVD client from here: https://docs.microsoft.com/en-us/azure/virtual-desktop/connect-windows-7-10  You might be using the Remote Desktop client that has been downloaded from the MS store (the icons look very similar).

@tilikumtim 

 

Geeze, you were not kidding that they look alike. They have the exact same icon, the same Name, and even the interface looks exactly the same. No wonder I didn't catch that.

 

That was the trick, thanks.