SOLVED

RDS Web portal doesn't load until a page refresh

Highlighted
Occasional Contributor

Is anyone seeing issues when accessing the https://rdweb.wvd.microsoft.com/webclient/index.html and the portal hangs on loading and never loads? Once the user refreshes the page, the site loads fine. I have multiple users reporting this and it happens to me as well in Chrome. I am suspecting this has something to do with AAD SSO refreshing tokens. 

 

 

 

 

3 Replies
Highlighted
As I suspect, it is a token failure. Not sure how to correct this....
-------------------------------------------------
2020-04-23T14:00:06.589Z adal:acquireTokenFailure Token renewal operation failed due to timeout, Token Renewal Failed

client.60becec7.js:1
. (6) ["at Object.Logger.a.error (https://rdweb.wvd.microsoft.com/webclient/js/client.60becec7.js:1:3067)", "at https://rdweb.wvd.microsoft.com/webclient/js/client.60becec7.js:5:6071", "at n.$broadcast (https://rdweb.wvd.microsoft.com/webclient/js/components.35fcac4e.js:6:9375)", "at Array.<anonymous> (https://rdweb.wvd.microsoft.com/webclient/js/components.35fcac4e.js:20:14916)", "at Object._callBackMappedToRenewStates.<computed>.…com/webclient/js/components.35fcac4e.js:19:16284)", "at https://rdweb.wvd.microsoft.com/webclient/js/components.35fcac4e.js:19:18863"]

Highlighted

@techguy129  We've experienced the same thing.  Doesn't seem to effect functionality, just an annoyance.

Highlighted
Best Response confirmed by vabora (Microsoft)
Solution

@techguy129 

You are correct, this issue was related to token refresh. it is fixed in webclient versions > 1.0.21.2