SOLVED

Problem Provisioning WVD Host Pool - RDSAgentBootLoader

%3CLINGO-SUB%20id%3D%22lingo-sub-1072326%22%20slang%3D%22en-US%22%3EProblem%20Provisioning%20WVD%20Host%20Pool%20-%20RDSAgentBootLoader%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1072326%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20following%20the%20following%20documentation%20to%20setup%20the%20RDS%20tenant%20and%20create%20a%20Service%20Principal%20for%20the%20RDS%20Owner.%20Now%20I%20am%20stuck.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20the%20error%20I%20receive%20during%20DSC%3A%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%3E%3CDIV%3E%3CSPAN%3E%7B%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22status%22%3C%2FSPAN%3E%3CSPAN%3E%3A%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22Failed%22%3C%2FSPAN%3E%3CSPAN%3E%2C%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22error%22%3C%2FSPAN%3E%3CSPAN%3E%3A%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%7B%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22code%22%3C%2FSPAN%3E%3CSPAN%3E%3A%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22ResourceDeploymentFailure%22%3C%2FSPAN%3E%3CSPAN%3E%2C%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22message%22%3C%2FSPAN%3E%3CSPAN%3E%3A%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22The%26nbsp%3Bresource%26nbsp%3Boperation%26nbsp%3Bcompleted%26nbsp%3Bwith%26nbsp%3Bterminal%26nbsp%3Bprovisioning%26nbsp%3Bstate%26nbsp%3B'Failed'.%22%3C%2FSPAN%3E%3CSPAN%3E%2C%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22details%22%3C%2FSPAN%3E%3CSPAN%3E%3A%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%5B%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%7B%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22code%22%3C%2FSPAN%3E%3CSPAN%3E%3A%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22VMExtensionProvisioningError%22%3C%2FSPAN%3E%3CSPAN%3E%2C%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22message%22%3C%2FSPAN%3E%3CSPAN%3E%3A%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22VM%26nbsp%3Bhas%26nbsp%3Breported%26nbsp%3Ba%26nbsp%3Bfailure%26nbsp%3Bwhen%26nbsp%3Bprocessing%26nbsp%3Bextension%26nbsp%3B'dscextension'.%26nbsp%3BError%26nbsp%3Bmessage%3A%26nbsp%3B%5C%22DSC%26nbsp%3BConfiguration%26nbsp%3B'FirstSessionHost'%26nbsp%3Bcompleted%26nbsp%3Bwith%26nbsp%3Berror(s).%26nbsp%3BFollowing%26nbsp%3Bare%26nbsp%3Bthe%26nbsp%3Bfirst%26nbsp%3Bfew%3A%26nbsp%3BPowerShell%26nbsp%3BDSC%26nbsp%3Bresource%26nbsp%3BMSFT_ScriptResource%26nbsp%3B%26nbsp%3Bfailed%26nbsp%3Bto%26nbsp%3Bexecute%26nbsp%3BSet-TargetResource%26nbsp%3Bfunctionality%26nbsp%3Bwith%26nbsp%3Berror%26nbsp%3Bmessage%3A%26nbsp%3BCannot%26nbsp%3Bfind%26nbsp%3Bany%26nbsp%3Bservice%26nbsp%3Bwith%26nbsp%3Bservice%26nbsp%3Bname%26nbsp%3B'RDAgentBootLoader'.%26nbsp%3B%26nbsp%3BThe%26nbsp%3BSendConfigurationApply%26nbsp%3Bfunction%26nbsp%3Bdid%26nbsp%3Bnot%26nbsp%3Bsucceed.%5C%22%5Cr%5Cn%5Cr%5CnMore%26nbsp%3Binformation%26nbsp%3Bon%26nbsp%3Btroubleshooting%26nbsp%3Bis%26nbsp%3Bavailable%26nbsp%3Bat%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FVMExtensionDSCWindowsTroubleshoot%26nbsp%3B%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FVMExtensionDSCWindowsTroubleshoot%26nbsp%3B%3C%2FA%3E%22%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%7D%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%5D%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%7D%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%7D%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EAny%20suggestions%20on%20how%20to%20troubleshoot%20%2F%20resolve%20this%3F%26nbsp%3B%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1072559%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20Provisioning%20WVD%20Host%20Pool%20-%20RDSAgentBootLoader%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1072559%22%20slang%3D%22en-US%22%3ELooks%20like%20the%20RDS%20part%20works...%20but%20with%20that%20provisioning%20error%2C%20it%20doesn't%20create%20the%20other%20VM's%20(I%20put%20in%20for%20it%20to%20create%205%20and%20it%20only%20created%20testvm-0).%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1072933%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20Provisioning%20WVD%20Host%20Pool%20-%20RDSAgentBootLoader%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1072933%22%20slang%3D%22en-US%22%3EIs%20your%20vNet%20containing%20your%20DC%20or%20is%20it%20containing%20the%20DNS%20pointers%20to%20your%20managed%20DNS%20servers%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1073138%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20Provisioning%20WVD%20Host%20Pool%20-%20RDSAgentBootLoader%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1073138%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F492855%22%20target%3D%22_blank%22%3E%40mcarpenter%3C%2FA%3E%3A%20Unfortunately%20it%20is%20difficult%20to%20debug%20here.%20I%20suggest%20the%20following%3A%3C%2FP%3E%0A%3CP%3E%3CFONT%20style%3D%22background-color%3A%20%23ffffff%3B%22%3E-%20Go%20through%20our%20learning%20path%20to%20see%20if%20you%20have%20missed%20a%20step%3A%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FlearnWVD%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FlearnWVD%3C%2FA%3E%3C%2FFONT%3E%3C%2FP%3E%0A%3CP%3E%3CFONT%20style%3D%22background-color%3A%20%23ffffff%3B%22%3E-%20Other%20option%20when%20you%20can't%20progress%20please%20see%20here%20your%20support%20and%20additional%20troubleshooting%20information%3A%20options%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftroubleshoot-set-up-overview%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftroubleshoot-set-up-overview%3C%2FA%3E%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hello,

 

I am following the Microsoft documentation to setup the RDS tenant and create a Service Principal for the RDS Owner. Now I am stuck.

 

This is the error I receive during the DSC process: 

 

{
    "status": "Failed",
    "error": {
        "code": "ResourceDeploymentFailure",
        "message": "The resource operation completed with terminal provisioning state 'Failed'.",
        "details": [
            {
                "code": "VMExtensionProvisioningError",
                "message": "VM has reported a failure when processing extension 'dscextension'. Error message: \"DSC Configuration 'FirstSessionHost' completed with error(s). Following are the first few: PowerShell DSC resource MSFT_ScriptResource  failed to execute Set-TargetResource functionality with error message: Cannot find any service with service name 'RDAgentBootLoader'.  The SendConfigurationApply function did not succeed.\"\r\n\r\nMore information on troubleshooting is available at https://aka.ms/VMExtensionDSCWindowsTroubleshoot "
            }
        ]
    }
}
 
Any suggestions on how to troubleshoot / resolve this? 
3 Replies
Highlighted
Looks like the RDS part works... but with that provisioning error, it doesn't create the other VM's (I put in for it to create 5 and it only created testvm-0).
Highlighted
Is your vNet containing your DC or is it containing the DNS pointers to your managed DNS servers?
Highlighted
Best Response confirmed by Eva Seydl (Microsoft)
Solution

@mcarpenter: Unfortunately it is difficult to debug here. I suggest the following:

- Go through our learning path to see if you have missed a step: https://aka.ms/learnWVD

- Other option when you can't progress please see here your support and additional troubleshooting information: options: https://docs.microsoft.com/en-us/azure/virtual-desktop/troubleshoot-set-up-overview