Port redirection

%3CLINGO-SUB%20id%3D%22lingo-sub-1060569%22%20slang%3D%22en-US%22%3EPort%20redirection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1060569%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20everybody%3C%2FP%3E%3CP%3EI'm%20migrating%20some%20customer%20services%20from%20on-premise%20RDP%20session%20host%20to%20WVD.%3C%2FP%3E%3CP%3ESome%20of%20the%20customers%20are%20using%20COM-port%20redirection%20to%20manage%20local%20hardware%20devices%20from%20an%20application%20running%20on%20the%20rdp%20session%20host.%3C%2FP%3E%3CP%3EIf%20I%20run%20the%20same%20application%20on%20the%20WVD%20host%20pool%2C%20when%20trying%20to%20open%20the%20COM%20port%20I%20get%3A%3C%2FP%3E%3CP%3E%22unable%20to%20open%20com%20port%20error%202%22.%20I%20think%20it's%20an%20application%20error%20but%20I%20don't%20see%20any%20redirected%20com%20device%20in%20device%20manager.%3C%2FP%3E%3CP%3EBefore%20starting%20to%20check%20in%20domain%20gpo's%20and%20other%20settings%2C%20is%20remote%20com-port%20redirection%20supported%20using%20wvd%3F%3C%2FP%3E%3CP%3EI%20cannot%20find%20anything%20in%20the%20docs%20mentioning%20it%20so%20I'd%20like%20to%20know%20if%20it%20should%20work%20or%20if%20I%20have%20to%20avoid%20this%20solution%20for%20customers%20who%20need%20port%20redirection%20(unfortunately%20most%20of%20them).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20be%20more%20precise.%20I'm%20testing%20a%20windows%2010%20enterprise%20multi-session%20session%20host%20with%20windows%20client%20(not%20html5).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20in%20advance%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1067681%22%20slang%3D%22en-US%22%3ERe%3A%20Port%20redirection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1067681%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20found%20that%20the%20problem%20is%20only%20with%20remoteapp.%3C%2FP%3E%3CP%3EWith%20desktop%20connection%20the%20client%20is%20correctly%20forwarding%20the%20com%20ports%20and%20the%20application%20works%20correctly%20without%20any%20difference%20from%20the%20%22normal%22%20rdp%20client.%3C%2FP%3E%3CP%3ENow%20I%20have%20to%20find%20out%20how%20to%20make%20it%20work%20also%20with%20remoteapp%20(if%20possible)%20with%20windows%2010%20enterprise%20multi-session..%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1207503%22%20slang%3D%22en-US%22%3ERe%3A%20Port%20redirection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1207503%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F484045%22%20target%3D%22_blank%22%3E%40setadini2475%3C%2FA%3E%26nbsp%3B%20%26nbsp%3BAny%20luck%20in%20getting%20COM%20ports%20redirected%20I%20have%20the%20same%20issue%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi everybody

I'm migrating some customer services from on-premise RDP session host to WVD.

Some of the customers are using COM-port redirection to manage local hardware devices from an application running on the rdp session host.

If I run the same application on the WVD host pool, when trying to open the COM port I get:

"unable to open com port error 2". I think it's an application error but I don't see any redirected com device in device manager.

Before starting to check in domain gpo's and other settings, is remote com-port redirection supported using wvd?

I cannot find anything in the docs mentioning it so I'd like to know if it should work or if I have to avoid this solution for customers who need port redirection (unfortunately most of them).

 

To be more precise. I'm testing a windows 10 enterprise multi-session session host with windows client (not html5).

 

Thank you in advance

2 Replies
Highlighted

I've found that the problem is only with remoteapp.

With desktop connection the client is correctly forwarding the com ports and the application works correctly without any difference from the "normal" rdp client.

Now I have to find out how to make it work also with remoteapp (if possible) with windows 10 enterprise multi-session..

Highlighted

@setadini2475   Any luck in getting COM ports redirected I have the same issue