"">

Oops, we couldn't connect to "<host-pool-name>"

New Contributor

Try to run the Powershell commands mentioned in the troubleshooting section but it simple show me a failure with no additional details about the error.

 

ActivityId        : xxxxxx-xxxxxxxxxxxxx
ActivityType      : Connection
StartTime         : 8/14/2019 7:37:12 AM
EndTime           : 8/14/2019 7:37:18 AM
UserName          : thomas.krampe@xxxxxxx.onmicrosoft.com
RoleInstances     : rdwebclient;mrs-eus2r1c002-rdgateway-prod-staging::RD0003FF459018;mrs-eus2r1c002-rdbroker-prod-staging::RD0003FFD92503;≤wvdpool02-0.xx.xx.xx≥
Outcome           : Failure
Status            : Completed
Details           :
LastHeartbeatTime : 8/14/2019 7:38:49 AM
Checkpoints       :
Errors            :

Any hints for further troubleshooting?

 

Cheers,

Thomas

4 Replies

You can then run a query directly to the activity and print the error.

ActivityId : xxxxxxxx-xxxx-xxxx-xxxx-c109da9c0000
ActivityType : Connection
StartTime : 15/08/2019 10:29:06 AM
EndTime : 15/08/2019 10:29:19 AM
UserName : jim.solomos.broken@xx.xxx.xx.x
RoleInstances : K582630;mrs-eus2r1c001-rdgateway-prod-staging::RD0003FF866F12;mrs-eus2r1c002-rdbroker-prod-staging::RD0003FF45DF7B
Outcome : Failure
Status : Completed
Details :
LastHeartbeatTime : 15/08/2019 10:29:19 AM
Checkpoints :
Errors :

>(Get-RdsDiagnosticActivities -TenantName SecurePOC0001 -ActivityId xxxxxxxx-xxxx-xxxx-xxxx-c109da9c0000 -Detailed).Errors


ErrorSource : RDBroker
ErrorOperation : LookupSessionHostPool
ErrorCode : -2146233088
ErrorCodeSymbolic : ConnectionFailedPersonalRdshUnhealthy
ErrorMessage : SessionHost=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx is not healthy. State=Healthy LastHealthUpdateTime=8/15/2019 12:11:44 AM Name=≤≥
ErrorInternal : False
ReportedBy : RDGateway
Time : 15/08/2019 10:29:19 AM
Other option is to try this tool which is a visual representation of our PowerShell: https://docs.microsoft.com/en-us/azure/virtual-desktop/deploy-diagnostics
Yes tried this as well but without any output. The errors value is empty and that's exactly the problem I have. How to find further information if you don't have an error message for the failure.
Thanks Eva, I had this in mind but still not using it, because it's only a visual representation of the PowerShell commands. Maybe later (when WVD is GA) for the tenant administrator. But thanks for the hint.