HTML5 RDS client keeps crashing

%3CLINGO-SUB%20id%3D%22lingo-sub-1616487%22%20slang%3D%22en-US%22%3EHTML5%20RDS%20client%20keeps%20crashing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1616487%22%20slang%3D%22en-US%22%3E%3CP%3EHello!%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EI%20have%20been%20testing%20RDS%20for%20a%20potential%20VDI%20infrastructure%2C%20and%20everything%20seems%20to%20be%20working%20well%26nbsp%3B%3CSTRONG%3Eexcept%3C%2FSTRONG%3E%20the%20integration%20with%20the%20HTML5%20client.%20Currently%20I%20have%20the%20following%20setup%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBrokerSrv.contoso.com%3C%2FP%3E%3CP%3EWebGWSrv.contoso.com%3C%2FP%3E%3CP%3ERDHost1.contoso.com%20(VDI%20host)%3C%2FP%3E%3CP%3ERDHost2.contoso.com%20(VDI%20host)%3CBR%20%2F%3ERDApphost.contoso.com%20(webbapphost)%3C%2FP%3E%3CP%3EThis%20is%20configured%20with%20a%20letsencrypt%20publicly%20trusted%20cert.%20Certs%20are%20the%20same%20on%20the%20Gateway%2FIIS...I%20don't%20seem%20to%20receive%20any%20cert%20errors..%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EIt%20appears%20that%20if%20I%20am%20in%20an%20HTML5%20RDP%2FRemoteApp%20session%2C%20if%20there's%20too%20much%20being%20processed%20at%20once%2C%20it%20will%20disconnect%20the%20RDP%20session%20entirely%2C%20and%20the%20user%20will%20be%20forced%20to%20log%20back%20in%2C%20the%20only%20error%20it%20produces%20from%20the%20UI%20is%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%20class%3D%22modal-header%22%3E%3CH3%20id%3D%22toc-hId-1225801674%22%20id%3D%22toc-hId-1225801676%22%3EOops%2C%20we%20couldn't%20connect%20to%20%22Work%20Resources%22%3C%2FH3%3E%3C%2FDIV%3E%3CDIV%20class%3D%22modal-body%22%3E%3CSPAN%3EYour%20session%20ended%20because%20of%20an%20error.%20If%20this%20keeps%20happening%2C%20ask%20your%20admin%20or%20tech%20support%20for%20help.%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22modal-body%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22modal-body%22%3E%3CSPAN%3EIf%20opening%20a%20web%20developer%20console%2C%20I%20also%20get%20an%20error%2C%20which%20I%20will%20attach%20a%20screenshot.%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22modal-body%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22modal-body%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22modal-body%22%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EAny%20help%20is%20appreciated!%20Thank%20you!%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E
Highlighted
Senior Member

Hello!


I have been testing RDS for a potential VDI infrastructure, and everything seems to be working well except the integration with the HTML5 client. Currently I have the following setup:

 

BrokerSrv.contoso.com

WebGWSrv.contoso.com

RDHost1.contoso.com (VDI host)

RDHost2.contoso.com (VDI host)
RDApphost.contoso.com (webbapphost)

This is configured with a letsencrypt publicly trusted cert. Certs are the same on the Gateway/IIS...I don't seem to receive any cert errors..


It appears that if I am in an HTML5 RDP/RemoteApp session, if there's too much being processed at once, it will disconnect the RDP session entirely, and the user will be forced to log back in, the only error it produces from the UI is:

 

0 Replies