Get-AzWvdRegistrationInfo ?

%3CLINGO-SUB%20id%3D%22lingo-sub-1361508%22%20slang%3D%22en-US%22%3EGet-AzWvdRegistrationInfo%20%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1361508%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECant%20seem%20to%20get%20this%20to%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGet-AzWvdRegistrationInfo%20-ResourceGroupName%20BLABLA-HostPoolName%20Pool01%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAz.DesktopVirtualization%5CGet-AzWvdHostPool%20%3A%20Resource%20group%20'BLABLA'%20could%20not%20be%20found.%3CBR%20%2F%3EAt%20C%3A%5CProgram%20Files%5CWindowsPowerShell%5CModules%5CAz.DesktopVirtualization%5C0.1.0%5Ccustom%5CGet-AzWvdRegistrationInfo.ps1%3A70%20ch%3CBR%20%2F%3Ear%3A9%3CBR%20%2F%3E%2B%20%24hostpool%20%3D%20Az.DesktopVirtualization%5CGet-AzWvdHostPool%20%40PSBou%20...%3CBR%20%2F%3E%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%3CBR%20%2F%3E%2B%20CategoryInfo%20%3A%20InvalidOperation%3A%20(%7B%20SubscriptionI...Pool01%20%7D%3A%26lt%3B%26gt%3Bf__AnonymousType2%603)%20%5BGet-AzWvdHo%3CBR%20%2F%3EstPool_Get%5D%2C%20RestException%601%3CBR%20%2F%3E%2B%20FullyQualifiedErrorId%20%3A%20ResourceGroupNotFound%2CMicrosoft.Azure.PowerShell.Cmdlets.DesktopVirtualization.Cmdlets.G%3CBR%20%2F%3EetAzWvdHostPool_Get%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1380621%22%20slang%3D%22en-US%22%3ERe%3A%20Get-AzWvdRegistrationInfo%20%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1380621%22%20slang%3D%22en-US%22%3EI%20tried%20the%20command%2C%20I%20am%20not%20able%20to%20reproduce%20your%20issue.%20can%20you%20please%20double%20check%20if%20you're%20calling%20to%20the%20right%20subscription%3F%20also%20please%20verify%20the%20ResourceGroupName%20is%20valid%2C%20exactly%20as%20it%20shown%20in%20the%20azure%20portal.%20Your%20command%20also%20shows%20there%20is%20no%20space%20between%20%22BLABLA%22%20and%20%22-HostPoolName%22%20which%20may%20cause%20unexpected%20error.%3C%2FLINGO-BODY%3E
Contributor

Hi All,

 

Cant seem to get this to work.

 

Get-AzWvdRegistrationInfo -ResourceGroupName BLABLA-HostPoolName Pool01

 

Az.DesktopVirtualization\Get-AzWvdHostPool : Resource group 'BLABLA' could not be found.
At C:\Program Files\WindowsPowerShell\Modules\Az.DesktopVirtualization\0.1.0\custom\Get-AzWvdRegistrationInfo.ps1:70 ch
ar:9
+ $hostpool = Az.DesktopVirtualization\Get-AzWvdHostPool @PSBou ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: ({ SubscriptionI...Pool01 }:<>f__AnonymousType2`3) [Get-AzWvdHo
stPool_Get], RestException`1
+ FullyQualifiedErrorId : ResourceGroupNotFound,Microsoft.Azure.PowerShell.Cmdlets.DesktopVirtualization.Cmdlets.G
etAzWvdHostPool_Get

1 Reply
I tried the command, I am not able to reproduce your issue. can you please double check if you're calling to the right subscription? also please verify the ResourceGroupName is valid, exactly as it shown in the azure portal. Your command also shows there is no space between "BLABLA" and "-HostPoolName" which may cause unexpected error.