FSLogix - Profile Issues

%3CLINGO-SUB%20id%3D%22lingo-sub-1118303%22%20slang%3D%22en-US%22%3EFSLogix%20-%20Profile%20Issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1118303%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20experiencing%20two%20issues%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1%20-%20Some%20users%2C%20when%20logging%20in%2C%20see%20a%20black%20screen%20for%20a%20long%20time%20before%20their%20profile%20loads.%20This%20happens%20each%20time%20they%20long%20in%20after%20logging%20off%20completely%20(i.e.%20not%20just%20disconnecting%20from%20the%20the%20remote%20session).%20If%20I%20stop%20the%20%22App%20Readiness%22%20service%2C%20the%20profile%20will%20load%20instantaneously...%20it%20seems%20that%20this%20service%20is%20running%20at%20every%20log%20in%20instead%20of%20just%20when%20the%20profile%20is%20initially%20created%3F%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E2%20-%20Some%20users%20will%20be%20working%20and%20suddenly%20their%20profile%20will%20unload.%20All%20icon%20thumbnails%20will%20disappear%2C%20they%20are%20unable%20to%20use%20Outlook%2C%20Teams%2C%20and%20other%20apps%2C%20and%20their%20remote%20session%20becomes%20generally%20unusable.%20The%20only%20way%20to%20fix%20this%20is%20to%20restart%20the%20host%20VM.%20Sometimes%20this%20problem%20will%20came%20back%20fairly%20immediately%2C%20sometimes%20it%20only%20happens%20every%20few%20days.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOur%20user%20profiles%20are%20stored%20in%20an%20Azure%20Files%20share%20in%20the%20same%20region%20as%20the%20host%20VM.%20I%20am%20not%20sure%20which%20logs%20I%20would%20need%20to%20upload%20to%20give%20more%20context%20for%20this%20situation.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1123381%22%20slang%3D%22en-US%22%3ERe%3A%20FSLogix%20-%20Profile%20Issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1123381%22%20slang%3D%22en-US%22%3EAdditional%20information%3A%20we%20disabled%20our%20endpoint%20protection%20software%2C%20but%20this%20did%20not%20change%20any%20of%20the%20issues%20we%20are%20experiencing.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1181734%22%20slang%3D%22en-US%22%3ERe%3A%20FSLogix%20-%20Profile%20Issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1181734%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F344062%22%20target%3D%22_blank%22%3E%40dbriles%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3Ei'm%20experiencing%20the%20same%20issues%2C%20any%20updates%20on%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1184972%22%20slang%3D%22en-US%22%3ERe%3A%20FSLogix%20-%20Profile%20Issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1184972%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F344062%22%20target%3D%22_blank%22%3E%40dbriles%3C%2FA%3E%26nbsp%3B%20-%20We%20have%20not%20seen%20this%20behavior%20but%20are%20using%20FSLogix%20profiles%20with%20a%20file%20share%20on%20a%202019%20server%20in%20Azure%20and%20not%20the%20Azure%20File%20Shares.%20%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1199096%22%20slang%3D%22en-US%22%3ERe%3A%20FSLogix%20-%20Profile%20Issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1199096%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F563049%22%20target%3D%22_blank%22%3E%40Mkoele%3C%2FA%3E-%20two%20things%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20Several%20users%20had%20VPN%20connections%20to%20one%20of%20our%20on-prem%20locations%20from%20the%20host%20machine%20(i.e.%20a%20VPN%20connection%20per%20user%2C%20so%20several%20VPN%20connections%20from%20the%20one%20WVD%20host%20machine).%20This%20was%20the%20biggest%20factor.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E2.%20We%20use%20several%20shared%20mailboxes%20in%20Outlook%20very%20actively%20throughout%20the%20day.%20Adding%20several%20shared%20mailboxes%20as%20additional%20accounts%20and%20with%20cached%20exchange%20mode%20meant%20the%20OST%20file%20for%20each%20user%20was%20pretty%20big%20and%20had%20a%20lot%20of%20activity.%20I%20don't%20think%20Azure%20Files%20has%20the%20IOPS%20to%20support%20this.%20We%20were%20able%20to%20solve%20this%20by%20adding%20each%20mailbox%20as%20an%20individual%20account%20in%20Outlook%20(which%20get%20their%20own%20OST%20file)%20and%20changing%20the%20%22mail%20to%20keep%20offline%22%20setting%20to%20two%20weeks.%20I%20don't%20really%20like%20this%20solution%2C%20but%20the%20alternative%20was%20keeping%20Outlook%20profiles%20out%20of%20the%20FSLogix%20container%20and%20roaming%20Outlook%20profiles%20was%20one%20of%20the%20reasons%20we%20wanted%20FSLogix%20in%20the%20first%20place.%20We're%20also%20using%20randomly%20generated%20passwords%20for%20each%20shared%20mailbox%20which%20only%20admins%20have%20access%20to%20in%20our%20password%20manager.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1204195%22%20slang%3D%22en-US%22%3ERe%3A%20FSLogix%20-%20Profile%20Issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1204195%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F516423%22%20target%3D%22_blank%22%3E%40jasonhand%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20Jason%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYou%20are%20saying%20you%20are%20using%20the%20FSLogix%20on%20a%20File%20share%20on%20a%20VM%20in%20Azure%20and%20having%20no%20issues%20at%20all.%3C%2FP%3E%3CP%3EIs%20there%20any%20way%20you%20can%20tell%20me%20what%20your%20setup%20is%20and%20how%20you%20configured%20FSLogix%3F%20We%20are%20having%20a%20lot%20of%20issues%20with%20FSLogix%20on%20a%20file%20share..%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1204486%22%20slang%3D%22en-US%22%3ERe%3A%20FSLogix%20-%20Profile%20Issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1204486%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F435459%22%20target%3D%22_blank%22%3E%40DP-MSFT%3C%2FA%3ESure%2C%20we%20have%20a%20D16sv3%20file%20server%20provisioned%20and%20a%20profiles%24%20share%20provisioned%20from%20it%20to%20use%20with%20FSLogix.%26nbsp%3B%20We%20have%20the%20VM%20regkeys%20set%20for%20FSLogix%20like%20the%20screenshot%20included%20on%20this%20reply.%26nbsp%3B%20We%20do%20see%20the%20occasional%20issue%20with%20corrupted%20profiles%20but%20with%20almost%20200%20daily%20users%20that%20is%20going%20to%20happen.%26nbsp%3B%20Sometimes%20the%20printers%20don't%20load%20but%20a%20logoff%20and%20logon%20fixes%20that.%26nbsp%3B%20There%20are%20definitely%20quirks%20and%20we%20are%20learning%20what%20they%20are%20so%20we%20can%20advise%20helpdesk%20and%20the%20end-user%20about%20them.%26nbsp%3B%20I%20still%20don't%20think%20this%20WVD%20environment%20is%20100%25%20reliable%20due%20to%20its%20new%20nature%20and%20trying%20to%20use%20a%20desktop%20OS%20to%20house%20multiple%20users%20but%20the%20cost%20and%20ease%20of%20use%20is%20hard%20to%20beat.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

We are experiencing two issues:

 

1 - Some users, when logging in, see a black screen for a long time before their profile loads. This happens each time they long in after logging off completely (i.e. not just disconnecting from the the remote session). If I stop the "App Readiness" service, the profile will load instantaneously... it seems that this service is running at every log in instead of just when the profile is initially created?


2 - Some users will be working and suddenly their profile will unload. All icon thumbnails will disappear, they are unable to use Outlook, Teams, and other apps, and their remote session becomes generally unusable. The only way to fix this is to restart the host VM. Sometimes this problem will came back fairly immediately, sometimes it only happens every few days.

 

Our user profiles are stored in an Azure Files share in the same region as the host VM. I am not sure which logs I would need to upload to give more context for this situation.

6 Replies
Highlighted
Additional information: we disabled our endpoint protection software, but this did not change any of the issues we are experiencing.
Highlighted

@dbriles 
i'm experiencing the same issues, any updates on this?

Highlighted

@dbriles  - We have not seen this behavior but are using FSLogix profiles with a file share on a 2019 server in Azure and not the Azure File Shares.  

Highlighted

@Mkoele- two things:

 

1. Several users had VPN connections to one of our on-prem locations from the host machine (i.e. a VPN connection per user, so several VPN connections from the one WVD host machine). This was the biggest factor.

2. We use several shared mailboxes in Outlook very actively throughout the day. Adding several shared mailboxes as additional accounts and with cached exchange mode meant the OST file for each user was pretty big and had a lot of activity. I don't think Azure Files has the IOPS to support this. We were able to solve this by adding each mailbox as an individual account in Outlook (which get their own OST file) and changing the "mail to keep offline" setting to two weeks. I don't really like this solution, but the alternative was keeping Outlook profiles out of the FSLogix container and roaming Outlook profiles was one of the reasons we wanted FSLogix in the first place. We're also using randomly generated passwords for each shared mailbox which only admins have access to in our password manager.

Highlighted

@jasonhand 

 

Hi Jason,

 

You are saying you are using the FSLogix on a File share on a VM in Azure and having no issues at all.

Is there any way you can tell me what your setup is and how you configured FSLogix? We are having a lot of issues with FSLogix on a file share..

Highlighted

@DP-MSFTSure, we have a D16sv3 file server provisioned and a profiles$ share provisioned from it to use with FSLogix.  We have the VM regkeys set for FSLogix like the screenshot included on this reply.  We do see the occasional issue with corrupted profiles but with almost 200 daily users that is going to happen.  Sometimes the printers don't load but a logoff and logon fixes that.  There are definitely quirks and we are learning what they are so we can advise helpdesk and the end-user about them.  I still don't think this WVD environment is 100% reliable due to its new nature and trying to use a desktop OS to house multiple users but the cost and ease of use is hard to beat.