FSLOGIX Profile Issue when opening Internet Explorer

%3CLINGO-SUB%20id%3D%22lingo-sub-1454678%22%20slang%3D%22en-US%22%3EFSLOGIX%20Profile%20Issue%20when%20opening%20Internet%20Explorer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1454678%22%20slang%3D%22en-US%22%3E%3CP%3EUsers%20are%20logging%20into%20a%20web%20site%20via%20IE%20and%20they%20get%20a%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%22Can't%20Connect%20Securely%20to%20site%20users%20outdated%20or%20unsafe%20TLS%20security%20settings.%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20IE%20security%20issue%20is%20failing%20on%20most%20users%20account%20when%20connecting%20with%20FSLogix%20Profile.%20Only%20a%20hand%20full%20have%20allowed%20user%20to%20access%20web%20site.%20One%20thing%20noticed%20is%20that%20when%20the%20fslogix%20profile%20is%20deleted%20it%20sometimes%20will%20allow%20the%20user%20access%20but%20after%20logging%20off%20and%20back%20on%20the%20session%20displays%20the%20error%20message%20again.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1470772%22%20slang%3D%22en-US%22%3ERe%3A%20FSLOGIX%20Profile%20Issue%20when%20opening%20Internet%20Explorer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1470772%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F695619%22%20target%3D%22_blank%22%3E%40shockashark%3C%2FA%3E%26nbsp%3Bthis%20will%20require%20specific%20trouble%20shooting%20of%20the%20environment%2C%20website%2C%20FSLogix%20configuration%2C%20etc.%26nbsp%3B%20I%20would%20suggest%20opening%20a%20support%20ticket%20as%20this%20is%20not%20a%20known%20general%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1585114%22%20slang%3D%22en-US%22%3ERe%3A%20FSLOGIX%20Profile%20Issue%20when%20opening%20Internet%20Explorer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1585114%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F314266%22%20target%3D%22_blank%22%3E%40Doug_Coombs%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%20Doug%2C%20We%20are%20having%20a%20similar%20issue%20and%20I%20was%20wondering%20if%20a%20fix%20has%20been%20found%20in%20FSLogix%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1585125%22%20slang%3D%22en-US%22%3ERe%3A%20FSLOGIX%20Profile%20Issue%20when%20opening%20Internet%20Explorer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1585125%22%20slang%3D%22en-US%22%3E%3CP%3ESir%2C%20I%20removed%20the%20users%20fxlogixofficeprofile%20and%20fxlogixprofiles%20then%20reloaded%20user.%20My%20issue%20was%20from%20power%20shell%20and%20robo%20copying%20Desktop%2C%20Docs%2C%20etc...%20The%20Default%20Apps%20copy%20over%20is%20what%20I%20believe%20broke%20the%20IE.%26nbsp%3B%20Again%20in%20some%20way%20I%20believe%20it%20broke%20the%20users%20profile%20when%20coping%20this%20data%20over.%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F757599%22%20target%3D%22_blank%22%3E%40Philippm%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1770320%22%20slang%3D%22en-US%22%3ERe%3A%20FSLOGIX%20Profile%20Issue%20when%20opening%20Internet%20Explorer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1770320%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F695619%22%20target%3D%22_blank%22%3E%40shockashark%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20same%20issue%20and%20following%20steps%20solved%20my%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EExcluding%20%22AppData%5CLocalLow%5CMicrosoft%22%20didn't%20help%20with%20all%20the%20users%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERoot%20cause%3A%20Local%20profile%20wasn't%20deleted%20properly%20and%20especially%20this%20folder%20(locallow%5Cmicrosoft%5Ccrypto%5CTokenBindingKeys)%20was%20causing%20the%20issue.%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22tokenBindingKeys.jpg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F225903i041AC7DB616E7269%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22tokenBindingKeys.jpg%22%20alt%3D%22tokenBindingKeys.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELots%20of%20users%20were%20already%20used%20WVD%20and%20FSLogix%20so%20it%20was%20unable%20to%20exclude%20the%20folder%20from%20some%20of%20the%20session%20hosts.%20To%20tackle%20the%20issue%20I%20enabled%20the%20following%20Group%20Policy%20and%20it%20worked%20like%20a%20charm.%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22ProfileContainer.jpg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F225904iA0FF9F5C169997E7%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22ProfileContainer.jpg%22%20alt%3D%22ProfileContainer.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EExample%20of%20my%20redirection.xml%20file%3C%2FP%3E%3CPRE%3E%26lt%3B%3Fxml%20version%3D%221.0%22%3F%26gt%3B%0A%0A%26lt%3BFrxProfileFolderRedirection%20ExcludeCommonFolders%3D%220%22%26gt%3B%0A%20%0A%26lt%3BExcludes%26gt%3B%20%0A%0A%20%26lt%3BExclude%20Copy%3D%220%22%26gt%3BAppData%5CLocalLow%5CMicrosoft%26lt%3B%2FExclude%26gt%3B%20%0A%0A%20%26lt%3BExclude%20Copy%3D%220%22%26gt%3BAppData%5CLocal%5CGoogle%5CChrome%5CUser%20Data%5CDefault%5CCache%26lt%3B%2FExclude%26gt%3B%0A%0A%20%26lt%3BExclude%20Copy%3D%220%22%26gt%3BAppData%5CLocal%5CMicrosoft%5CEdge%5CUser%20Data%5CDefault%5CCache%26lt%3B%2FExclude%26gt%3B%0A%0A%20%26lt%3BExclude%20Copy%3D%220%22%26gt%3BAppData%5CLocal%5CPackages%5CMicrosoft.MicrosoftEdge_8wekyb3d8bbwe%5CAC%5CMicrosoftEdge%5CCache%26lt%3B%2FExclude%26gt%3B%0A%0A%20%26lt%3BExclude%20Copy%3D%220%22%26gt%3BAppData%5CLocal%5CBraveSoftware%5CBrave-Browser%5CUser%20Data%5CDefault%5CCache%26lt%3B%2FExclude%26gt%3B%0A%0A%26lt%3B%2FExcludes%26gt%3B%0A%20%20%0A%26lt%3BIncludes%26gt%3B%0A%0A%20%26lt%3BInclude%20Copy%3D%223%22%26gt%3BAppData%5CLocalLow%5CSun%5CJava%5CDeployment%5Csecurity%26lt%3B%2FInclude%26gt%3B%0A%0A%26lt%3B%2FIncludes%26gt%3B%0A%0A%26lt%3B%2FFrxProfileFolderRedirection%26gt%3B%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20that%20will%20help.%3C%2FP%3E%3CP%3EPlease%20don't%20forget%20to%20restart%20your%20Session%20Hosts.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1770353%22%20slang%3D%22en-US%22%3ERe%3A%20FSLOGIX%20Profile%20Issue%20when%20opening%20Internet%20Explorer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1770353%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F695619%22%20target%3D%22_blank%22%3E%40shockashark%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20same%20issue%20and%20following%20steps%20solved%20my%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EExcluding%20%22AppData%5CLocalLow%5CMicrosoft%22%20didn't%20help%20with%20all%20the%20users%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CU%3E%3CSTRONG%3ERoot%20cause%3A%3C%2FSTRONG%3E%3C%2FU%3E%20Local%20profile%20wasn't%20deleted%20properly%20and%20especially%20this%20folder%20(locallow%5Cmicrosoft%5Ccrypto%5CTokenBindingKeys)%20was%20causing%20the%20issue.%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3ELots%20of%20users%20were%20already%20used%20WVD%20and%20FSLogix%20so%20it%20was%20unable%20to%20exclude%20the%20folder%20from%20some%20of%20the%20session%20hosts.%20To%20tackle%20the%20issue%20I%20enabled%20the%20following%20Group%20Policy%20and%20it%20worked%20like%20a%20charm.%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EExample%20of%20my%20redirection.xml%20file%3C%2FP%3E%3CPRE%3E%26lt%3B%3Fxml%20version%3D%221.0%22%3F%26gt%3B%0A%0A%26lt%3BFrxProfileFolderRedirection%20ExcludeCommonFolders%3D%220%22%26gt%3B%0A%20%0A%26lt%3BExcludes%26gt%3B%20%0A%0A%20%26lt%3BExclude%20Copy%3D%220%22%26gt%3BAppData%5CLocalLow%5CMicrosoft%26lt%3B%2FExclude%26gt%3B%20%0A%0A%20%26lt%3BExclude%20Copy%3D%220%22%26gt%3BAppData%5CLocal%5CGoogle%5CChrome%5CUser%20Data%5CDefault%5CCache%26lt%3B%2FExclude%26gt%3B%0A%0A%20%26lt%3BExclude%20Copy%3D%220%22%26gt%3BAppData%5CLocal%5CMicrosoft%5CEdge%5CUser%20Data%5CDefault%5CCache%26lt%3B%2FExclude%26gt%3B%0A%0A%20%26lt%3BExclude%20Copy%3D%220%22%26gt%3BAppData%5CLocal%5CPackages%5CMicrosoft.MicrosoftEdge_8wekyb3d8bbwe%5CAC%5CMicrosoftEdge%5CCache%26lt%3B%2FExclude%26gt%3B%0A%0A%20%26lt%3BExclude%20Copy%3D%220%22%26gt%3BAppData%5CLocal%5CBraveSoftware%5CBrave-Browser%5CUser%20Data%5CDefault%5CCache%26lt%3B%2FExclude%26gt%3B%0A%0A%26lt%3B%2FExcludes%26gt%3B%0A%20%20%0A%26lt%3BIncludes%26gt%3B%0A%0A%20%26lt%3BInclude%20Copy%3D%223%22%26gt%3BAppData%5CLocalLow%5CSun%5CJava%5CDeployment%5Csecurity%26lt%3B%2FInclude%26gt%3B%0A%0A%26lt%3B%2FIncludes%26gt%3B%0A%0A%26lt%3B%2FFrxProfileFolderRedirection%26gt%3B%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20that%20helps.%3C%2FP%3E%3CP%3EPlease%20don't%20forget%20to%20restart%20your%20Session%20Hosts.%3C%2FP%3E%3CP%3EThank%20you%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Users are logging into a web site via IE and they get a:

 

"Can't Connect Securely to site users outdated or unsafe TLS security settings."

 

This IE security issue is failing on most users account when connecting with FSLogix Profile. Only a hand full have allowed user to access web site. One thing noticed is that when the fslogix profile is deleted it sometimes will allow the user access but after logging off and back on the session displays the error message again.

 

 

 

 

 

 

5 Replies

@shockashark this will require specific trouble shooting of the environment, website, FSLogix configuration, etc.  I would suggest opening a support ticket as this is not a known general issue.

@Doug_Coombs 

Hello Doug, We are having a similar issue and I was wondering if a fix has been found in FSLogix?

Sir, I removed the users fxlogixofficeprofile and fxlogixprofiles then reloaded user. My issue was from power shell and robo copying Desktop, Docs, etc... The Default Apps copy over is what I believe broke the IE.  Again in some way I believe it broke the users profile when coping this data over. @Philippm 

@shockashark 

 

I have the same issue and following steps solved my issue.

 

Excluding "AppData\LocalLow\Microsoft" didn't help with all the users

 

Root cause: Local profile wasn't deleted properly and especially this folder (locallow\microsoft\crypto\TokenBindingKeys) was causing the issue.

 

tokenBindingKeys.jpg

 

Lots of users were already used WVD and FSLogix so it was unable to exclude the folder from some of the session hosts. To tackle the issue I enabled the following Group Policy and it worked like a charm.

 

ProfileContainer.jpg

 

Example of my redirection.xml file

<?xml version="1.0"?>

<FrxProfileFolderRedirection ExcludeCommonFolders="0">
	
<Excludes>	

 <Exclude Copy="0">AppData\LocalLow\Microsoft</Exclude>	

 <Exclude Copy="0">AppData\Local\Google\Chrome\User Data\Default\Cache</Exclude>

 <Exclude Copy="0">AppData\Local\Microsoft\Edge\User Data\Default\Cache</Exclude>

 <Exclude Copy="0">AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\AC\MicrosoftEdge\Cache</Exclude>

 <Exclude Copy="0">AppData\Local\BraveSoftware\Brave-Browser\User Data\Default\Cache</Exclude>

</Excludes>
  
<Includes>

 <Include Copy="3">AppData\LocalLow\Sun\Java\Deployment\security</Include>

</Includes>

</FrxProfileFolderRedirection>

 

Hope that will help.

Please don't forget to restart your Session Hosts.

 

Thank you

@shockashark 

I have the same issue and following steps solved my issue.

 

Excluding "AppData\LocalLow\Microsoft" didn't help with all the users

 

Root cause: Local profile wasn't deleted properly and especially this folder (locallow\microsoft\crypto\TokenBindingKeys) was causing the issue.

 

Lots of users were already used WVD and FSLogix so it was unable to exclude the folder from some of the session hosts. To tackle the issue I enabled the following Group Policy and it worked like a charm.

 

 

 

Example of my redirection.xml file

<?xml version="1.0"?>

<FrxProfileFolderRedirection ExcludeCommonFolders="0">
	
<Excludes>	

 <Exclude Copy="0">AppData\LocalLow\Microsoft</Exclude>	

 <Exclude Copy="0">AppData\Local\Google\Chrome\User Data\Default\Cache</Exclude>

 <Exclude Copy="0">AppData\Local\Microsoft\Edge\User Data\Default\Cache</Exclude>

 <Exclude Copy="0">AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\AC\MicrosoftEdge\Cache</Exclude>

 <Exclude Copy="0">AppData\Local\BraveSoftware\Brave-Browser\User Data\Default\Cache</Exclude>

</Excludes>
  
<Includes>

 <Include Copy="3">AppData\LocalLow\Sun\Java\Deployment\security</Include>

</Includes>

</FrxProfileFolderRedirection>

 

Hope that helps.

Please don't forget to restart your Session Hosts.

Thank you