SOLVED

FSLogix and Azure Files - The requested session access is denied.

Contributor

Hi everyone, we are observing some weirdness in our test environment and here is the picture in nutshell

 

Day 1:

-  Created host pool with single VM, win 10 multi-session OS, uses Azure ADDS domain

- Configured profile container using FSLogix by following all steps here

- Assigned domain users to desktop app group

- Worked well, users could login using web and desktop client of WVD and profiles also got created in azure file share.

- Proves FSLogix was configured correctly as everything worked as expected.  

 

Setup was left idle (VM was kept running) overnight.   

 

Day 2: Tried logging in with same user for whom profile was already present (with web client as well as desktop WVD RDS client tool) and started facing an error "The requested session access is denied." Tried this with all existing users for which profiles were created and encountered same error. 

 

As a next troubleshooting step, tried creating a new user in Azure AD, assigned it to the desktop app group. Tried logging in using web client - and user could access the desktop but profile was not created in the file share. 

 

This indicated that something was wrong with existing user profiles and this being our test environment - ended up cleaning up azure files i.e. delete all directories in the azure files container assuming that it should create new profiles for users if it does not find any.

 

Tried logging in again with existing as well as new users - they now could log in fine using web as well as desktop wvd client, however profiles are not getting created in azure files for any of the user (new or existing users).  Note that I have already tried re-configuring azure files on this VM and ensured that the file share is accessible and FSLogix has valid entries in registry settings.

 

Any clue what could have gone wrong or if there is anything that could have triggered this behavior? 

Thanks in advance. 

1 Reply
best response confirmed by bhushangawale (Contributor)
Solution

@bhushangawale Got the issue, it was because of the fact that somehow the permissions to the azure file share went missing. 
Just in case if someone faces the similar issue - ensure that you have given relevant permissions on azure file share that hosts user profiles for users those will be signing in. You would at-least need to give Storage File Data SMB Share Contributor permissions on the file share.