Errors deploying a WVD Host Pool

%3CLINGO-SUB%20id%3D%22lingo-sub-1423434%22%20slang%3D%22en-US%22%3EErrors%20deploying%20a%20WVD%20Host%20Pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1423434%22%20slang%3D%22en-US%22%3E%3CP%20class%3D%22olark-visitor-message%22%3EWe%20have%20an%20onprem%20Windows%20Server%20Essentials%20that%20as%20AD%20Azure%20Sync%20(not%20AD%20connect%20as%20it%20is%20not%20supported).%20I%20have%20deployed%20Azure%20AD%20services%20and%20can%20see%20all%20the%20onprem%20users.%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3EI%20now%20want%20to%20deploy%20Azure%20Virtual%20Desktop%20but%20I%20continue%20to%20get%20deployment%20errors.%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3EWe%20have%20an%20onprem%20Windows%20Server%20Essentials%20that%20as%20AD%20Azure%20Sync%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3EI%20have%20deployed%20Azure%20AD%20services%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3Eand%20now%20want%20to%20deploy%20Azure%20Virtual%20Desktop%20but%20I%20continue%20to%20get%20deployment%20errors%3B%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3E%3CSPAN%3E%7B%22code%22%3A%22DeploymentFailed%22%2C%22message%22%3A%22At%20least%20one%20resource%20deployment%20operation%20failed.%20Please%20list%20deployment%20operations%20for%20details.%20Please%20see%20-ERR%3AREF-NOT-FOUND-%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FDeployOperations%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FDeployOperations%3C%2FA%3E%20for%20usage%20details.%22%2C%22details%22%3A%5B%7B%22code%22%3A%22Conflict%22%2C%22message%22%3A%22%7B%5Cr%5Cn%20%5C%22status%5C%22%3A%20%5C%22Failed%5C%22%2C%5Cr%5Cn%20%5C%22error%5C%22%3A%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22ResourceDeploymentFailure%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%5C%22%2C%5Cr%5Cn%20%5C%22details%5C%22%3A%20%5B%5Cr%5Cn%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22DeploymentFailed%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22At%20least%20one%20resource%20deployment%20operation%20failed.%20Please%20list%20deployment%20operations%20for%20details.%20Please%20see%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FDeployOperations%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FDeployOperations%3C%2FA%3E%20for%20usage%20details.%5C%22%2C%5Cr%5Cn%20%5C%22details%5C%22%3A%20%5B%5Cr%5Cn%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22Conflict%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22%7B%5C%5Cr%5C%5Cn%20%5C%5C%5C%22status%5C%5C%5C%22%3A%20%5C%5C%5C%22Failed%5C%5C%5C%22%2C%5C%5Cr%5C%5Cn%20%5C%5C%5C%22error%5C%5C%5C%22%3A%20%7B%5C%5Cr%5C%5Cn%20%5C%5C%5C%22code%5C%5C%5C%22%3A%20%5C%5C%5C%22ResourceDeploymentFailure%5C%5C%5C%22%2C%5C%5Cr%5C%5Cn%20%5C%5C%5C%22message%5C%5C%5C%22%3A%20%5C%5C%5C%22The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%5C%5C%5C%22%2C%5C%5Cr%5C%5Cn%20%5C%5C%5C%22details%5C%5C%5C%22%3A%20%5B%5C%5Cr%5C%5Cn%20%7B%5C%5Cr%5C%5Cn%20%5C%5C%5C%22code%5C%5C%5C%22%3A%20%5C%5C%5C%22VMExtensionProvisioningError%5C%5C%5C%22%2C%5C%5Cr%5C%5Cn%20%5C%5C%5C%22message%5C%5C%5C%22%3A%20%5C%5C%5C%22VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'joindomain'.%20Error%20message%3A%20%5C%5C%5C%5C%5C%5C%5C%22Exception(s)%20occured%20while%20joining%20Domain%20'%3CDOMAIN%3E.onmicrosoft.com'%5C%5C%5C%5C%5C%5C%5C%22%5C%5C%5C%5Cr%5C%5C%5C%5Cn%5C%5C%5C%5Cr%5C%5C%5C%5CnMore%20information%20on%20troubleshooting%20is%20available%20at%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2Fvmextensionwindowstroubleshoot%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2Fvmextensionwindowstroubleshoot%3C%2FA%3E%20%5C%5C%5C%22%5C%5Cr%5C%5Cn%20%7D%5C%5Cr%5C%5Cn%20%5D%5C%5Cr%5C%5Cn%20%7D%5C%5Cr%5C%5Cn%7D%5C%22%5Cr%5Cn%20%7D%5Cr%5Cn%20%5D%5Cr%5Cn%20%7D%5Cr%5Cn%20%5D%5Cr%5Cn%20%7D%5Cr%5Cn%7D%22%7D%5D%7D%3C%2FDOMAIN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3E%3CSPAN%3EHave%20tried%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3E%3CSPAN%3E-%20specifiying%20OU%20%2F%20domain%20off%20and%20on%3C%2FSPAN%3E%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3E%3CSPAN%3E-%20same%20Subnet%20as%20Azure%20AD%20host%3C%2FSPAN%3E%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22olark-visitor-message%22%3E%3CSPAN%3EPlease%20help%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

We have an onprem Windows Server Essentials that as AD Azure Sync (not AD connect as it is not supported). I have deployed Azure AD services and can see all the onprem users.

I now want to deploy Azure Virtual Desktop but I continue to get deployment errors.

 

We have an onprem Windows Server Essentials that as AD Azure Sync

I have deployed Azure AD services

and now want to deploy Azure Virtual Desktop but I continue to get deployment errors;

 

{"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details.","details":[{"code":"Conflict","message":"{\r\n \"status\": \"Failed\",\r\n \"error\": {\r\n \"code\": \"ResourceDeploymentFailure\",\r\n \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n \"details\": [\r\n {\r\n \"code\": \"DeploymentFailed\",\r\n \"message\": \"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details.\",\r\n \"details\": [\r\n {\r\n \"code\": \"Conflict\",\r\n \"message\": \"{\\r\\n \\\"status\\\": \\\"Failed\\\",\\r\\n \\\"error\\\": {\\r\\n \\\"code\\\": \\\"ResourceDeploymentFailure\\\",\\r\\n \\\"message\\\": \\\"The resource operation completed with terminal provisioning state 'Failed'.\\\",\\r\\n \\\"details\\\": [\\r\\n {\\r\\n \\\"code\\\": \\\"VMExtensionProvisioningError\\\",\\r\\n \\\"message\\\": \\\"VM has reported a failure when processing extension 'joindomain'. Error message: \\\\\\\"Exception(s) occured while joining Domain '<domain>.onmicrosoft.com'\\\\\\\"\\\\r\\\\n\\\\r\\\\nMore information on troubleshooting is available at https://aka.ms/vmextensionwindowstroubleshoot \\\"\\r\\n }\\r\\n ]\\r\\n }\\r\\n}\"\r\n }\r\n ]\r\n }\r\n ]\r\n }\r\n}"}]}

 

Have tried;

- specifiying OU / domain off and on

- same Subnet as Azure AD host

 

Please help

1 Reply
Highlighted

@nicknz  one of a few things that typically cause this in my experience. 

 

1) The user account specified for domain join does not have permission to join the vm

2) The domain name specified in the deployment is not correct

3) The OU specified has an issue in the syntax

4) DNS settings are missing from the VNET

5) There are issues with firewall rules on the DC

 

let me know what you find after checking these items.