Deployment Error

%3CLINGO-SUB%20id%3D%22lingo-sub-382793%22%20slang%3D%22en-US%22%3EDeployment%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-382793%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EHi%2C%20Getting%20the%20following%20deployment%20error.%20Is%20Azure%20AD%20domain%20services%20supported%20for%20the%20AD%20environment%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E%7B%22code%22%3A%22DeploymentFailed%22%2C%22message%22%3A%22At%20least%20one%20resource%20deployment%20operation%20failed.%20Please%20list%20deployment%20operations%20for%20details.%20Please%20see%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2Farm-debug%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2Farm-debug%3C%2FA%3E%20for%20usage%20details.%22%2C%22details%22%3A%5B%7B%22code%22%3A%22Conflict%22%2C%22message%22%3A%22%7B%5Cr%5Cn%20%5C%22status%5C%22%3A%20%5C%22Failed%5C%22%2C%5Cr%5Cn%20%5C%22error%5C%22%3A%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22ResourceDeploymentFailure%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%5C%22%2C%5Cr%5Cn%20%5C%22details%5C%22%3A%20%5B%5Cr%5Cn%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22VMExtensionProvisioningError%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'dscextension'.%20Error%20message%3A%20%5C%5C%5C%22DSC%20Configuration%20'FirstSessionHost'%20completed%20with%20error(s).%20Following%20are%20the%20first%20few%3A%20PowerShell%20DSC%20resource%20MSFT_ScriptResource%20failed%20to%20execute%20Set-TargetResource%20functionality%20with%20error%20message%3A%20One%20or%20more%20errors%20occurred.%20The%20SendConfigurationApply%20function%20did%20not%20succeed.%5C%5C%5C%22.%5C%22%5Cr%5Cn%20%7D%5Cr%5Cn%20%5D%5Cr%5Cn%20%7D%5Cr%5Cn%7D%22%7D%5D%7D%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-394511%22%20slang%3D%22en-US%22%3ERe%3A%20Deployment%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-394511%22%20slang%3D%22en-US%22%3EIndeed%20it%20is.%20I%20succesfully%20deployed%20a%20WVD%2C%20setting%20the%20correct%20permissions%20and%20created%20a%20blogpost%20about%20it%3A%20%3CA%20href%3D%22https%3A%2F%2Ferjenrijnders.nl%2F2019%2F04%2F04%2Fhow-to-deploy-windows-virtual-desktop-in-azure%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Ferjenrijnders.nl%2F2019%2F04%2F04%2Fhow-to-deploy-windows-virtual-desktop-in-azure%2F%3C%2FA%3E%20Please%20let%20me%20know%20if%20that%20works%20for%20you%2C%20otherwise%20let%20me%20know%20where%20you%20struggle.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-392064%22%20slang%3D%22en-US%22%3ERe%3A%20Deployment%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-392064%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310144%22%20target%3D%22_blank%22%3E%40byertjames%3C%2FA%3E%26nbsp%3B%20Yes%2C%20it%20was%20the%20permissions%20for%20the%20service%20principal.%20The%20link%20above%20has%20the%20steps%20for%20setting%20up%20this%20account.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-390457%22%20slang%3D%22en-US%22%3ERe%3A%20Deployment%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-390457%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F306339%22%20target%3D%22_blank%22%3E%40Dave1200%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20Dave%2C%20did%20you%20get%20this%20resolved%3F%20I%20am%20experiencing%20the%20same%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-382811%22%20slang%3D%22en-US%22%3ERe%3A%20Deployment%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-382811%22%20slang%3D%22en-US%22%3EOn%20further%20research%2C%20it's%20probably%20related%20to%20the%20service%20principal%20role%20assignments.%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fcreate-service-principal-role-powershell%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fcreate-service-principal-role-powershell%3C%2FA%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hi, Getting the following deployment error. Is Azure AD domain services supported for the AD environment?

 

{"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.","details":[{"code":"Conflict","message":"{\r\n \"status\": \"Failed\",\r\n \"error\": {\r\n \"code\": \"ResourceDeploymentFailure\",\r\n \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n \"details\": [\r\n {\r\n \"code\": \"VMExtensionProvisioningError\",\r\n \"message\": \"VM has reported a failure when processing extension 'dscextension'. Error message: \\\"DSC Configuration 'FirstSessionHost' completed with error(s). Following are the first few: PowerShell DSC resource MSFT_ScriptResource failed to execute Set-TargetResource functionality with error message: One or more errors occurred. The SendConfigurationApply function did not succeed.\\\".\"\r\n }\r\n ]\r\n }\r\n}"}]}

4 Replies
Highlighted
On further research, it's probably related to the service principal role assignments.
https://docs.microsoft.com/en-us/azure/virtual-desktop/create-service-principal-role-powershell
Highlighted

@Dave1200 

Hi Dave, did you get this resolved? I am experiencing the same issue.

Highlighted

@byertjames  Yes, it was the permissions for the service principal. The link above has the steps for setting up this account.

Highlighted
Indeed it is. I succesfully deployed a WVD, setting the correct permissions and created a blogpost about it: https://erjenrijnders.nl/2019/04/04/how-to-deploy-windows-virtual-desktop-in-azure/ Please let me know if that works for you, otherwise let me know where you struggle.