Deployment Error: Exception(s) occured while joining Domain

%3CLINGO-SUB%20id%3D%22lingo-sub-876185%22%20slang%3D%22en-US%22%3EDeployment%20Error%3A%20Exception(s)%20occured%20while%20joining%20Domain%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-876185%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3E%7B%22code%22%3A%22DeploymentFailed%22%2C%22message%22%3A%22At%20least%20one%20resource%20deployment%20operation%20failed.%20Please%20list%20deployment%20operations%20for%20details.%20Please%20see%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2Farm-debug%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2Farm-debug%3C%2FA%3E%20for%20usage%20details.%22%2C%22details%22%3A%5B%7B%22code%22%3A%22Conflict%22%2C%22message%22%3A%22%7B%5Cr%5Cn%20%5C%22status%5C%22%3A%20%5C%22Failed%5C%22%2C%5Cr%5Cn%20%5C%22error%5C%22%3A%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22ResourceDeploymentFailure%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%5C%22%2C%5Cr%5Cn%20%5C%22details%5C%22%3A%20%5B%5Cr%5Cn%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22VMExtensionProvisioningError%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'joindomain'.%20Error%20message%3A%20%5C%5C%5C%22Exception(s)%20occured%20while%20joining%20Domain%20'mydomain.com'%5C%5C%5C%22.%5C%22%5Cr%5Cn%20%7D%5Cr%5Cn%20%5D%5Cr%5Cn%20%7D%5Cr%5Cn%7D%22%7D%5D%7D%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI'm%20just%20testing%20this%20solution%20out%20and%20trying%20to%20control%20costs.%26nbsp%3B%20Do%20I%20have%20to%20have%20a%20Domain%20Controller%26nbsp%3Bor%20Azure%20AD%20Domain%20Services%20to%20use%20Windows%20Virtual%20Desktop%20with%20Windows%2010%20multi-host%3F%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-881500%22%20slang%3D%22en-US%22%3ERe%3A%20Deployment%20Error%3A%20Exception(s)%20occured%20while%20joining%20Domain%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-881500%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F415459%22%20target%3D%22_blank%22%3E%40AjantiDaggar%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYou%20are%20correct%2C%20you%20need%20a%26nbsp%3B%3CSPAN%3EWindows%20Server%20Active%20Directory%20in%20sync%20with%20Azure%20Active%20Directory.%20This%20can%20be%20enabled%20through%3A%3C%2FSPAN%3E%3C%2FP%3E%3CUL%3E%3CLI%3EAn%20Azure%20VM%20in%20your%20VNET%2C%20with%20the%20Windows%20AD%20role%20%26amp%3B%20Azure%20AD%20Connect%3C%2FLI%3E%3CLI%3EAzure%20AD%20Domain%20Services%3C%2FLI%3E%3C%2FUL%3E%3CP%3ESo%20it%20is%20important%2C%20during%20the%20deployment%2C%20that%20you%20select%20a%20VNET%20that%20has%20either%20one%20of%20these%20options%20enabled%20in%20it%20so%20the%20SessionHosts%20(WVD%20hosts)%20can%20join%20that%20domain.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20this%20helps%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Senior Member

{"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.","details":[{"code":"Conflict","message":"{\r\n \"status\": \"Failed\",\r\n \"error\": {\r\n \"code\": \"ResourceDeploymentFailure\",\r\n \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n \"details\": [\r\n {\r\n \"code\": \"VMExtensionProvisioningError\",\r\n \"message\": \"VM has reported a failure when processing extension 'joindomain'. Error message: \\\"Exception(s) occured while joining Domain 'mydomain.com'\\\".\"\r\n }\r\n ]\r\n }\r\n}"}]}

 

I'm just testing this solution out and trying to control costs.  Do I have to have a Domain Controller or Azure AD Domain Services to use Windows Virtual Desktop with Windows 10 multi-host? 

1 Reply
Highlighted

Hi @AjantiDaggar ,

 

You are correct, you need a Windows Server Active Directory in sync with Azure Active Directory. This can be enabled through:

  • An Azure VM in your VNET, with the Windows AD role & Azure AD Connect
  • Azure AD Domain Services

So it is important, during the deployment, that you select a VNET that has either one of these options enabled in it so the SessionHosts (WVD hosts) can join that domain.

 

Hope this helps