Create Host Pool - Domain Join Failing

%3CLINGO-SUB%20id%3D%22lingo-sub-737215%22%20slang%3D%22en-US%22%3ECreate%20Host%20Pool%20-%20Domain%20Join%20Failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-737215%22%20slang%3D%22en-US%22%3E%3CP%3EHey%20guys%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EStuck%20on%20trying%20to%20get%20this%20new%20host%20pool%20setup.%20Followed%20the%20MS%20documentation%20on%20setting%20up%20WVD%20but%20still%20experiencing%20problems.%20I've%20deleted%20the%20resource%20group%20and%20started%20from%20scratch%20a%20couple%20times.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20using%20the%20marketplace%20template%20to%20create%20a%20new%20host%20pool.%20Running%20Azure%20AD%20and%20Azure%20AD%20Domain%20Services%2C%20have%20user%20in%20AAD%20DC%20Administrators%20group%2C%20using%20a%20service%20principal.%20Consistently%20getting%20the%20following%20error%20in%20the%20domain%20join%20process%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%3E%7B%20%22id%22%3A%20%22%2Fsubscriptions%2Fa96af9dd-1c28-4e2f-b43e-0060ee2decc3%2FresourceGroups%2FAdaria-WVD%2Fproviders%2FMicrosoft.Resources%2Fdeployments%2Frds.wvd-provision-host-pool-20190703171029%2Foperations%2F8AAE0EA9BA89B6DA%22%2C%20%22operationId%22%3A%20%228AAE0EA9BA89B6DA%22%2C%20%22properties%22%3A%20%7B%20%22provisioningOperation%22%3A%20%22Create%22%2C%20%22provisioningState%22%3A%20%22Failed%22%2C%20%22timestamp%22%3A%20%222019-07-03T21%3A21%3A27.0269336Z%22%2C%20%22duration%22%3A%20%22PT4M9.1812873S%22%2C%20%22trackingId%22%3A%20%22d677e859-8c7e-4a8f-9d1c-a63ee9574cd7%22%2C%20%22statusCode%22%3A%20%22Conflict%22%2C%20%22statusMessage%22%3A%20%7B%20%22status%22%3A%20%22Failed%22%2C%20%22error%22%3A%20%7B%20%22code%22%3A%20%22ResourceDeploymentFailure%22%2C%20%22message%22%3A%20%22The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%22%2C%20%22details%22%3A%20%5B%20%7B%20%22code%22%3A%20%22VMExtensionProvisioningError%22%2C%20%22message%22%3A%20%22VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'joindomain'.%20Error%20message%3A%20%5C%22Exception(s)%20occured%20while%20joining%20Domain%20'adaria.ca'%5C%22.%22%20%7D%20%5D%20%7D%20%7D%2C%20%22targetResource%22%3A%20%7B%20%22id%22%3A%20%22%2Fsubscriptions%2Fa96af9dd-1c28-4e2f-b43e-0060ee2decc3%2FresourceGroups%2FAdaria-WVD%2Fproviders%2FMicrosoft.Compute%2FvirtualMachines%2FWVD-VM-0%2Fextensions%2Fjoindomain%22%2C%20%22resourceType%22%3A%20%22Microsoft.Compute%2FvirtualMachines%2Fextensions%22%2C%20%22resourceName%22%3A%20%22WVD-VM-0%2Fjoindomain%22%20%7D%20%7D%7D%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%3EAny%20ideas%3F%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1083879%22%20slang%3D%22en-US%22%3ERe%3A%20Create%20Host%20Pool%20-%20Domain%20Join%20Failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1083879%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F370823%22%20target%3D%22_blank%22%3E%40jkwyeung%3C%2FA%3E%26nbsp%3B%3A%20Apologies%20for%20the%20delay.%20Have%20you%20tried%20again%20lately%3F%20Please%20let%20us%20know%20if%20this%20persists.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

Hey guys,

 

Stuck on trying to get this new host pool setup. Followed the MS documentation on setting up WVD but still experiencing problems. I've deleted the resource group and started from scratch a couple times.

 

I am using the marketplace template to create a new host pool. Running Azure AD and Azure AD Domain Services, have user in AAD DC Administrators group, using a service principal. Consistently getting the following error in the domain join process:

 

{ "id": "/subscriptions/a96af9dd-1c28-4e2f-b43e-0060ee2decc3/resourceGroups/Adaria-WVD/providers/Microsoft.Resources/deployments/rds.wvd-provision-host-pool-20190703171029/operations/8AAE0EA9BA89B6DA", "operationId": "8AAE0EA9BA89B6DA", "properties": { "provisioningOperation": "Create", "provisioningState": "Failed", "timestamp": "2019-07-03T21:21:27.0269336Z", "duration": "PT4M9.1812873S", "trackingId": "d677e859-8c7e-4a8f-9d1c-a63ee9574cd7", "statusCode": "Conflict", "statusMessage": { "status": "Failed", "error": { "code": "ResourceDeploymentFailure", "message": "The resource operation completed with terminal provisioning state 'Failed'.", "details": [ { "code": "VMExtensionProvisioningError", "message": "VM has reported a failure when processing extension 'joindomain'. Error message: \"Exception(s) occured while joining Domain 'adaria.ca'\"." } ] } }, "targetResource": { "id": "/subscriptions/a96af9dd-1c28-4e2f-b43e-0060ee2decc3/resourceGroups/Adaria-WVD/providers/Microsoft.Compute/virtualMachines/WVD-VM-0/extensions/joindomain", "resourceType": "Microsoft.Compute/virtualMachines/extensions", "resourceName": "WVD-VM-0/joindomain" } }}

 

Any ideas?

1 Reply
Highlighted

@jkwyeung : Apologies for the delay. Have you tried again lately? Please let us know if this persists.