Cannot retrieve licensing from AAD

%3CLINGO-SUB%20id%3D%22lingo-sub-1076040%22%20slang%3D%22en-US%22%3ECannot%20retrieve%20licensing%20from%20AAD%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1076040%22%20slang%3D%22en-US%22%3E%3CP%3EAll%20users%20on%20at%20least%20one%20of%20our%20WVD%20hosts%20are%20seeing%20that%20they%20are%20not%20licensed%20in%20Office%2C%20and%20the%20WVD%20hosts%20reports%20lots%20of%20%22Remote%20Desktop%20Session%20Host%20server%20was%20unable%20to%20retrieve%20user%20licensing%20information%20from%20AAD.%20Error%20User%20Domain%5Cuser%20%2C%20hr%20%3D%200x80070057%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20with%20any%20information%20about%20this%3F%20I%20saw%20another%20similar%20thread%20here%2C%20but%20my%20users%20are%20not%20disconnected%2C%20dont%20know%20if%20this%20is%20the%20same%20problem.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1076575%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20retrieve%20licensing%20from%20AAD%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1076575%22%20slang%3D%22en-US%22%3EThe%20licensing%20error%20from%20AAD%20is%20a%20known%20issue%20that%20should%20be%20fixed%20beginning%202020.%20This%20is%20due%20to%20a%20connection%20issue%20between%20AAD%20and%20WVD%20host%20pool%20and%20is%20not%20related%20to%20the%20Office%20suite%20installation%20but%20more%20RDS%20licensing%20related.%3CBR%20%2F%3E%3CBR%20%2F%3ERegarding%20not%20licensed%20in%20Office%2C%20which%20is%20the%20exact%20message%20they%20get%3F%20Did%20you%20activate%20Shared%20Computer%20Activation%3F%20Can%20you%20confirm%20it%20is%20working%20correctly%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1078271%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20retrieve%20licensing%20from%20AAD%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1078271%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F468579%22%20target%3D%22_blank%22%3E%40knowlite%3C%2FA%3E%26nbsp%3BThe%20%22not%20licensed%20in%20Office%22%20issue%20is%2C%20sort%20of%2C%20resolved.%20I%20have%20turned%20off%20Modern%20Authentication%20with%20the%20EnableAdal%3D0%20reg%20entry%2C%20and%20now%20it%20all%20works.%20But%20would%20like%20to%20know%20when%20Modern%20Authentication%20will%20be%20fully%20supported%20in%20WVD%2C%20as%20we%20are%20planning%20to%20use%20MFA%20very%20soon..%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1078283%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20retrieve%20licensing%20from%20AAD%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1078283%22%20slang%3D%22en-US%22%3EExact%20same%20story%20I%20have%20at%20a%20customer.%20Needed%20to%20turn%20off%20ADAL%20because%20outlook%20became%20disconnected%20and%20login%20screen%20did%20not%20appear.%20Turning%20off%20ADAL%20resolved%20the%20issue.%20Now%20customer%20wants%20to%20start%20using%20MFA%2C%20next%20issue...%3C%2FLINGO-BODY%3E
Contributor

All users on at least one of our WVD hosts are seeing that they are not licensed in Office, and the WVD hosts reports lots of "Remote Desktop Session Host server was unable to retrieve user licensing information from AAD. Error User Domain\user , hr = 0x80070057".

 

Anyone with any information about this? I saw another similar thread here, but my users are not disconnected, dont know if this is the same problem. 

3 Replies
The licensing error from AAD is a known issue that should be fixed beginning 2020. This is due to a connection issue between AAD and WVD host pool and is not related to the Office suite installation but more RDS licensing related.

Regarding not licensed in Office, which is the exact message they get? Did you activate Shared Computer Activation? Can you confirm it is working correctly?

@knowlite The "not licensed in Office" issue is, sort of, resolved. I have turned off Modern Authentication with the EnableAdal=0 reg entry, and now it all works. But would like to know when Modern Authentication will be fully supported in WVD, as we are planning to use MFA very soon.. 

Exact same story I have at a customer. Needed to turn off ADAL because outlook became disconnected and login screen did not appear. Turning off ADAL resolved the issue. Now customer wants to start using MFA, next issue...