SOLVED

Cannot provision a host pool

%3CLINGO-SUB%20id%3D%22lingo-sub-860420%22%20slang%3D%22en-US%22%3ECannot%20provision%20a%20host%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-860420%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20I%20go%20to%26nbsp%3B%3CSPAN%20class%3D%22ext-gallery-details-header-displayname%22%3EWindows%20Virtual%20Desktop%20-%20Provision%20a%20host%20pool%20and%20click%20Create%20I%20get%20the%20following%20error%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22ext-gallery-details-header-displayname%22%3E%3CSPAN%3ECreate%20MultiVm%3A%20failed%20to%20parse%20createUIdefinition%20file.%20Error%3A%20readyState%3A%204%20responseText%3A%20responseXML%3A%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22ext-gallery-details-header-displayname%22%3E%3CSPAN%3E%7B%20%22shellProps%22%3A%20%7B%20%22sessionId%22%3A%20%22ca1f4d2eb8184589b8bac3f624a3b69c%22%2C%20%22extName%22%3A%20%22Microsoft_Azure_Compute%22%2C%20%22contentName%22%3A%20%22CreateMultiVmWizardPart%22%20%7D%2C%20%22error%22%3A%20%7B%20%22message%22%3A%20%22Create%20MultiVm%3A%20failed%20to%20parse%20createUIdefinition%20file.%20Error%3A%20readyState%3A%204%5Cr%5CnresponseText%3A%3C!--%20%20%3Fxml%20version%3D%5C%26amp%3Bquot%3B1.0%5C%26amp%3Bquot%3B%20encoding%3D%5C%26amp%3Bquot%3Butf-8%5C%26amp%3Bquot%3B%3F%20%20--%3E%20%5CnAuthenticationFailedServer%20failed%20to%20authenticate%20the%20request.%20Make%20sure%20the%20value%20of%20Authorization%20header%20is%20formed%20correctly%20including%20the%20signature.%5CnRequestId%3A40a319f2-f01e-0012-44da-6dfb37000000%5CnTime%3A2019-09-18T04%3A34%3A42.2905937ZAuthentication%20scheme%20Bearer%20is%20not%20supported%20in%20this%20version.%5Cr%5CnresponseXML%3A%20%5Cr%5Cnstatus%3A%20403%5Cr%5CnstatusText%3A%20error%5Cr%5Cn%22%2C%20%22code%22%3A%20null%20%7D%7D%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22ext-gallery-details-header-displayname%22%3E%3CSPAN%3ENot%20sure%20what%20to%20try%20next%3F%20Any%20help%20appreciated.%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-860701%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20provision%20a%20host%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-860701%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F410751%22%20target%3D%22_blank%22%3E%40DannyD300%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20experiencing%20the%20exact%20same%20error.%20We%20are%20not%20able%20to%20create%20a%20new%20WVD%20environment.%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20directions%20to%20solve%20this%20issue%20are%20more%20then%20welcome.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-860777%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20provision%20a%20host%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-860777%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F410751%22%20target%3D%22_blank%22%3E%40DannyD300%3C%2FA%3E%26nbsp%3B%20I%20am%20also%20experiencing%20this%20issue%2C%20any%20update%20would%20be%20appreciated.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EError%3A%26nbsp%3B%3CSPAN%3ECreate%20MultiVm%3A%20failed%20to%20parse%20createUIdefinition%20file.%20Error%3A%20readyState%3A%204%20responseText%3A%20responseXML%3A%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-860911%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20provision%20a%20host%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-860911%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F410751%22%20target%3D%22_blank%22%3E%40DannyD300%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%20all%2C%20suddenly%20it%20is%20working%20again.%20I'm%20now%20able%20to%20create%20a%20new%20WVD%20environment.%20SO%20Microsoft%20is%20fixing%20at%20the%20background%20I%20suppose.%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-860961%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20provision%20a%20host%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-860961%22%20slang%3D%22en-US%22%3EI'm%20Still%20having%20issues%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-861886%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20provision%20a%20host%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-861886%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F410751%22%20target%3D%22_blank%22%3E%40DannyD300%3C%2FA%3E%26nbsp%3BI%20seem%20to%20be%20having%20the%20same%20issue.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-861889%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20provision%20a%20host%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-861889%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F410936%22%20target%3D%22_blank%22%3E%40AttackonAzure%3C%2FA%3E%26nbsp%3B%3A%20Our%20Azure%20Marketplace%20team%20is%20aware%20of%20this%20incident%20and%20are%20tracking%20it%20down.%20We've%20noticed%20that%20not%20all%20customers%20hit%20this%20issue%2C%20or%20were%20originally%20hitting%20the%20issue%20but%20now%20do%20not.%20If%20you%20are%20still%20hitting%20this%20issue%2C%20please%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Fcreate-host-pools-arm-template%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Efollow%20the%20steps%3C%2FA%3E%20to%20deploy%20the%20GitHub%20ARM%20template%20in%20the%20meantime.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAs%20the%20teams%20investigate%2C%20we'll%20continue%20monitoring%20for%20information%20and%20report%20back.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-862312%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20provision%20a%20host%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-862312%22%20slang%3D%22en-US%22%3EAny%20Updates%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-862996%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20provision%20a%20host%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-862996%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20issue%20should%20be%20resolved.%20Had%20the%20same%20issue%20yesterday%20at%20multiple%20Tenants%2C%20but%20now%2C%20all%20Tenants%20are%20able%20to%20deploy%20using%20the%20Marketplace.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-867953%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20provision%20a%20host%20pool%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-867953%22%20slang%3D%22en-US%22%3E%3CP%3EConfirming%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F298270%22%20target%3D%22_blank%22%3E%40michawets%3C%2FA%3E%26nbsp%3Bobservation.%20You%20should%20be%20able%20to%20run%20the%20Azure%20Marketplace%20offering%20successfully%20now!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

When I go to Windows Virtual Desktop - Provision a host pool and click Create I get the following error:

 

Create MultiVm: failed to parse createUIdefinition file. Error: readyState: 4 responseText: responseXML:

 

{ "shellProps": { "sessionId": "ca1f4d2eb8184589b8bac3f624a3b69c", "extName": "Microsoft_Azure_Compute", "contentName": "CreateMultiVmWizardPart" }, "error": { "message": "Create MultiVm: failed to parse createUIdefinition file. Error: readyState: 4\r\nresponseText: \nAuthenticationFailedServer failed to authenticate the request. Make sure the value of Authorization header is formed correctly including the signature.\nRequestId:40a319f2-f01e-0012-44da-6dfb37000000\nTime:2019-09-18T04:34:42.2905937ZAuthentication scheme Bearer is not supported in this version.\r\nresponseXML: \r\nstatus: 403\r\nstatusText: error\r\n", "code": null }}

 

Not sure what to try next? Any help appreciated.

9 Replies
Highlighted

@DannyD300 

 

We are experiencing the exact same error. We are not able to create a new WVD environment. 

Any directions to solve this issue are more then welcome. 

Highlighted

@DannyD300  I am also experiencing this issue, any update would be appreciated.

 

Error: Create MultiVm: failed to parse createUIdefinition file. Error: readyState: 4 responseText: responseXML:

Highlighted

@DannyD300 

 

Hello all, suddenly it is working again. I'm now able to create a new WVD environment. SO Microsoft is fixing at the background I suppose. :)

 

 

Highlighted
I'm Still having issues
Highlighted

@DannyD300 I seem to be having the same issue. 

Highlighted
Best Response confirmed by Eva Seydl (Microsoft)
Solution

@AttackonAzure : Our Azure Marketplace team is aware of this incident and are tracking it down. We've noticed that not all customers hit this issue, or were originally hitting the issue but now do not. If you are still hitting this issue, please follow the steps to deploy the GitHub ARM template in the meantime.

 

As the teams investigate, we'll continue monitoring for information and report back.

Highlighted
Any Updates
Highlighted

Hi all,

 

The issue should be resolved. Had the same issue yesterday at multiple Tenants, but now, all Tenants are able to deploy using the Marketplace.

Highlighted

Confirming @michawets observation. You should be able to run the Azure Marketplace offering successfully now!