SOLVED

Can't connect to WVD client because of error meesage " no available resources"

%3CLINGO-SUB%20id%3D%22lingo-sub-1095927%22%20slang%3D%22en-US%22%3ECan't%20connect%20to%20WVD%20client%20because%20of%20error%20meesage%20%22%20no%20available%20resources%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1095927%22%20slang%3D%22en-US%22%3E%3CP%3EI%20need%20help%20because%20I%20cant%20connect%20to%20WVD%20desktop.%20deploy%20was%20successful%20and%20users%20exist.%20I%20checked%20avairable%20users%20with%20following%20command%2C%20Get-RdsAppGroupUser%20-TenantName%20%22xxx%22%20-HostPoolName%20%22xxx%22%20-AppGroupName%20%22Desktop%20Application%20Group%22.%20and%20there%20are%20two%20available%20users.%3C%2FP%3E%3CP%3EWhen%20I%20use%20both%20desktop%20app%20on%20Laptop%20and%20web%20browser%2C%20I%20failed%20and%20got%20error%20messages%20%22%20you%20can%20connect%20because%20there%20are%20currently%20no%20available%20resources%22.%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20have%20the%20same%20problems%3F%20I'm%20happy%20if%20someone%20share%20the%20resolutions%20on%20this.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EConfiguration%3A%3C%2FP%3E%3CP%3EActive%20Directory%20%3A%20AAD%20DS%3C%2FP%3E%3CP%3EDN%3A%20AAD%20domain%20name%20is%20xxx.co.jp%2C%20AAD%20DS%20domain%20name%20is%20ooo.xxx.co.jp%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20access%20to%20the%20target%20machine%20with%20remote%20desktop%20from%20Windows%20server%20on%20the%20same%20vNet.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%23%23WVD%20machine%20which%20I%20cant%20access%20with%20WVD%20client%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F164201i01395DE7A8A27CA7%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22image.png%22%20title%3D%22image.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F164200i64FCE846F3BFEB2C%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22image.png%22%20title%3D%22image.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1095979%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20connect%20to%20WVD%20client%20because%20of%20error%20meesage%20%22%20no%20available%20resources%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1095979%22%20slang%3D%22en-US%22%3E%3CP%3EI%20can%20access%20to%20the%20target%20machine(prod-it-wvd-0)%20with%20remotedesktop%20from%20Windows%20server%20on%20the%20same%20vNet.%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F164202iB2E9BEA8C3ED88D3%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22image.png%22%20title%3D%22image.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1096079%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20connect%20to%20WVD%20client%20because%20of%20error%20meesage%20%22%20no%20available%20resources%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1096079%22%20slang%3D%22en-US%22%3E%3CP%3E%3CFONT%3E%26gt%3B%26nbsp%3B%20Get-RdsSessionHost%20-TenantName%20%22prod-it-wvd%22%20-HostPoolName%20%22prod-it-wvd%22%3CBR%20%2F%3ESessionHostName%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%20prod-it-wvd-0.xxx.xxx.xxx.co.jp%3CBR%20%2F%3ETenantName%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%20prod-it-wvd%3CBR%20%2F%3ETenantGroupName%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%20Default%20Tenant%20Group%3CBR%20%2F%3EHostPoolName%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%20prod-it-wvd%3CBR%20%2F%3EAllowNewSession%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%20True%3CBR%20%2F%3ESessions%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%200%3CBR%20%2F%3ELastHeartBeat%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%202020%2F01%2F04%2005%3A22%3A26%3CBR%20%2F%3EAgentVersion%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%201.0.833.5%3CBR%20%2F%3EAssignedUser%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%3CBR%20%2F%3EOsVersion%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%2010.0.18362%3CBR%20%2F%3ESxSStackVersion%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%20rdp-sxs191031003%3CBR%20%2F%3EStatus%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%20NoHeartbeat%3CBR%20%2F%3EUpdateState%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%20Succeeded%3CBR%20%2F%3ELastUpdateTime%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3A%202020%2F01%2F04%2005%3A16%3A45%3CBR%20%2F%3EUpdateErrorMessage%20%3A%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1111882%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20connect%20to%20WVD%20client%20because%20of%20error%20meesage%20%22%20no%20available%20resources%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1111882%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F479688%22%20target%3D%22_blank%22%3E%40yatsu40%3C%2FA%3EI%20made%20new%20hostPool%2Cthen%20this%20problem%20was%20fixed.%3C%2FP%3E%3CP%3EThx%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1112299%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20connect%20to%20WVD%20client%20because%20of%20error%20meesage%20%22%20no%20available%20resources%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1112299%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F479688%22%20target%3D%22_blank%22%3E%40yatsu40%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20Status%20%3D%20no%20heartbeat%20is%20the%20issue.%20It's%20telling%20you%20that%20the%20pool%20cannot%20see%20the%20host%20(aka%20VM).%20This%20typically%20because%20there%20is%20an%20issues%20with%20the%20following%20post%20I%20found%20very%20help%20in%20troubleshooting%20and%20resolving%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fwindows-virtual-desktop%2Fwvd-outage-hosts-unavailable-with-status-quot-noheartbeat-quot%2Fm-p%2F1030437%22%20target%3D%22_blank%22%20rel%3D%22noopener%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fwindows-virtual-desktop%2Fwvd-outage-hosts-unavailable-with-status-quot-noheartbeat-quot%2Fm-p%2F1030437%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIn%20my%20case%20I%20found%20I%20was%20no%20copying%2Fpasting%20the%20Token%20correctly%20which%20stuffed%20up%20the%20heartbeat.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1117343%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20connect%20to%20WVD%20client%20because%20of%20error%20meesage%20%22%20no%20available%20resources%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1117343%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F72532%22%20target%3D%22_blank%22%3E%40Robert%20Crane%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20Robert%2C%20Azure%20support%20announced%20the%20same%20answer.%20But%20it%20didnt%20work%20on%20my%26nbsp%3B%3CFONT%3Eenvilonment%3C%2FFONT%3E.%3C%2FP%3E%3CP%3EI%20dont%20know%20why%2C%20maybe%20because%20I%20re-made%20and%20deleted%20it%20with%20same%20paramaters%20over%20and%20over.%20%3CSPAN%3ENow%20I%20use%20the%20different%20host%20pool%20name%20and%20there%20seems%20to%20be%20no%20problems%20to%20access%20a%20new%20client.%3C%2FSPAN%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20deleted%20the%20problem%20host%20pool%20from%20management%20console%20of%20WVD.%20I%20will%20try%20to%20make%20the%20same%20name%20host%20pool%20to%20the%20problem%20one%20and%20access%20later.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

I need help because I cant connect to WVD desktop. deploy was successful and users exist. I checked avairable users with following command, Get-RdsAppGroupUser -TenantName "xxx" -HostPoolName "xxx" -AppGroupName "Desktop Application Group". and there are two available users.

When I use both desktop app on Laptop and web browser, I failed and got error messages " you can connect because there are currently no available resources". 

Does anyone have the same problems? I'm happy if someone share the resolutions on this.

 

Configuration:

Active Directory : AAD DS

DN: AAD domain name is xxx.co.jp, AAD DS domain name is ooo.xxx.co.jp

 

5 Replies
Highlighted

I can access to the target machine(prod-it-wvd-0) with remotedesktop from Windows server on the same vNet.

 

image.png

Highlighted

>  Get-RdsSessionHost -TenantName "prod-it-wvd" -HostPoolName "prod-it-wvd"
SessionHostName    : prod-it-wvd-0.xxx.xxx.xxx.co.jp
TenantName         : prod-it-wvd
TenantGroupName    : Default Tenant Group
HostPoolName       : prod-it-wvd
AllowNewSession    : True
Sessions           : 0
LastHeartBeat      : 2020/01/04 05:22:26
AgentVersion       : 1.0.833.5
AssignedUser       :
OsVersion          : 10.0.18362
SxSStackVersion    : rdp-sxs191031003
Status             : NoHeartbeat
UpdateState        : Succeeded
LastUpdateTime     : 2020/01/04 05:16:45
UpdateErrorMessage :

Highlighted

@yatsu40I made new hostPool,then this problem was fixed.

Thx

Highlighted
Best Response confirmed by yatsu40 (Occasional Contributor)
Solution

@yatsu40 

The Status = no heartbeat is the issue. It's telling you that the pool cannot see the host (aka VM). This typically because there is an issues with the following post I found very help in troubleshooting and resolving:

 

https://techcommunity.microsoft.com/t5/windows-virtual-desktop/wvd-outage-hosts-unavailable-with-sta...

 

In my case I found I was no copying/pasting the Token correctly which stuffed up the heartbeat.

Highlighted

@Robert Crane 

Thank you Robert, Azure support announced the same answer. But it didnt work on my envilonment.

I dont know why, maybe because I re-made and deleted it with same paramaters over and over. Now I use the different host pool name and there seems to be no problems to access a new client. 

I deleted the problem host pool from management console of WVD. I will try to make the same name host pool to the problem one and access later.