Home

Can Publish Snipping Tool as a Remote App but it doesn't launch

%3CLINGO-SUB%20id%3D%22lingo-sub-1126569%22%20slang%3D%22en-US%22%3ECan%20Publish%20Snipping%20Tool%20as%20a%20Remote%20App%20but%20it%20doesn't%20launch%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1126569%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20working%20through%20a%20strange%20issue.%26nbsp%3B%20I've%20used%20the%20Web-ux%20to%20deploy%20a%20start%20menu%20app%2C%20in%20this%20case%20Snipping%20Tool%2C%20and%20it%20shows%20as%20an%20available%20app.%26nbsp%3B%20When%20I%20try%20to%20open%20it%2C%20I%20get%20the%20attached%20error.%26nbsp%3B%20I%20have%20set%20a%20regkey%20to%20disable%20the%20allowed%20apps%20list.%26nbsp%3B%20I've%20published%20everything%20else%20via%20powershell%20and%20it's%20fine%20but%20using%20the%20web%20UI%20or%20powershell%20to%20add%20it%20as%20an%20available%20app%20simply%20won't%20load.%26nbsp%3B%20Now%2C%20if%20I%20get%20tricky%20and%20go%20to%20word%20or%20something%2C%20File%20%26gt%3B%20Open%20and%20then%20migrating%20to%20snipping%20tool%20in%20system32%20directory%2C%20right%20clicking%20it%20and%20opening%20it%20from%20there%2C%20it%20works.%26nbsp%3B%20Just%20won't%20open%20using%20the%20WVD%20windows%20app.%26nbsp%3B%20Now%20here%20is%20another%20weird%20thing%2C%20I%20can%20launch%20it%20using%20the%20web%20interface%20just%20fine%20and%20then%20it%20works%20in%20the%20RD%20app%20consistently%20going%20forward.%26nbsp%3B%20Also%2C%20how%20the%20heck%20can%20we%20publish%20Teams%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F166993iC8BB230136999A75%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1132245%22%20slang%3D%22en-US%22%3ERe%3A%20Can%20Publish%20Snipping%20Tool%20as%20a%20Remote%20App%20but%20it%20doesn't%20launch%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1132245%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F279502%22%20target%3D%22_blank%22%3E%40stevenzelenko%3C%2FA%3E%26nbsp%3B%3A%20Can%20you%20try%20fully%20logging%20off%20the%20user%20from%20the%20session%2C%20then%20launching%26nbsp%3B%3CSTRONG%3ESnipping%20Tool%3C%2FSTRONG%3E%20from%20the%20client%3F%20Unfortunately%2C%20I%20don't%20have%20too%20much%20experience%20using%20the%20%22Allowed%20apps%20list%22%20and%20changing%20the%20registry%2C%20so%20I%20don't%20know%20if%20it%20requires%20a%20user%20logoff%20or%20system%20restart%20to%20actually%20take%20effect.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWe%20don't%20yet%20have%20Teams%20out%20in%20Public%20Preview%2C%20but%20it%20will%20be%20similar%20to%20this%2C%20where%20you%20install%20on%20a%20device-wide%20install%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Fteams-for-vdi%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Fteams-for-vdi%3C%2FA%3E%26nbsp%3B.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1161797%22%20slang%3D%22en-US%22%3ERe%3A%20Can%20Publish%20Snipping%20Tool%20as%20a%20Remote%20App%20but%20it%20doesn't%20launch%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1161797%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F305776%22%20target%3D%22_blank%22%3E%40christianmontoya%3C%2FA%3E%26nbsp%3Bit%20was%20very%20weird%20with%20this%20one.%26nbsp%3B%20I%20had%20to%20log%20into%20the%20web%20browser%20and%20launch%20the%20app%20and%20then%20it%20launched%20using%20the%20RD%20app%20for%26nbsp%3B%20windows.%26nbsp%3B%20As%20far%20as%20Team%2C%20looks%20like%20the%20VDI%20install%20is%20out%20but%20it%20ain't%20perfect.%26nbsp%3B%20We%20have%20to%20run%20a%20logon%20script%20to%20get%20it%20to%20open%20at%20user%20logon%20when%20using%20published%20apps.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1164814%22%20slang%3D%22en-US%22%3ERe%3A%20Can%20Publish%20Snipping%20Tool%20as%20a%20Remote%20App%20but%20it%20doesn't%20launch%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1164814%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F279502%22%20target%3D%22_blank%22%3E%40stevenzelenko%3C%2FA%3E%26nbsp%3B%3A%20Let%20me%20pass%20the%20feedback%20along%20to%20the%20team.%20As%20always%2C%20we%20really%20appreciate%20your%20testing%20and%20feedback.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

I'm working through a strange issue.  I've used the Web-ux to deploy a start menu app, in this case Snipping Tool, and it shows as an available app.  When I try to open it, I get the attached error.  I have set a regkey to disable the allowed apps list.  I've published everything else via powershell and it's fine but using the web UI or powershell to add it as an available app simply won't load.  Now, if I get tricky and go to word or something, File > Open and then migrating to snipping tool in system32 directory, right clicking it and opening it from there, it works.  Just won't open using the WVD windows app.  Now here is another weird thing, I can launch it using the web interface just fine and then it works in the RD app consistently going forward.  Also, how the heck can we publish Teams?

 

clipboard_image_0.png

 

3 Replies
Highlighted

@stevenzelenko : Can you try fully logging off the user from the session, then launching Snipping Tool from the client? Unfortunately, I don't have too much experience using the "Allowed apps list" and changing the registry, so I don't know if it requires a user logoff or system restart to actually take effect.

 

We don't yet have Teams out in Public Preview, but it will be similar to this, where you install on a device-wide install: https://docs.microsoft.com/en-us/microsoftteams/teams-for-vdi .

Highlighted

@christianmontoya it was very weird with this one.  I had to log into the web browser and launch the app and then it launched using the RD app for  windows.  As far as Team, looks like the VDI install is out but it ain't perfect.  We have to run a logon script to get it to open at user logon when using published apps.

Highlighted

@stevenzelenko : Let me pass the feedback along to the team. As always, we really appreciate your testing and feedback.

Related Conversations
Heartburn Solution Program
heartburnhelps88 in Visio on
0 Replies
News bar (Beta) on Microsoft store
HotCakeX in Windows Insider Program on
0 Replies
List column customization
chinmaykulkarni in SharePoint on
1 Replies
Notification badges for PWAs pinned to the taskbar
HotCakeX in Discussions on
6 Replies