SOLVED

Camera/Mic not available even with CustomRdpProperty set

%3CLINGO-SUB%20id%3D%22lingo-sub-1459801%22%20slang%3D%22en-US%22%3ECamera%2FMic%20not%20available%20even%20with%20CustomRdpProperty%20set%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1459801%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3EHave%20a%20new%20multi%20session%20Windows%2010%202004%20host%20pool%20that%20the%20operating%20system%20or%20Teams%2032%20bit%20do%20not%20see%20the%20camera%20or%20mic%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20CustomRdpProperty%20is%20set%20as%20follows%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETenantName%20%3A%20WVD%20Tenant%3CBR%20%2F%3ETenantGroupName%20%3A%20Default%20Tenant%20Group%3CBR%20%2F%3EHostPoolName%20%3A%20Win10Multi%3CBR%20%2F%3EFriendlyName%20%3A%20Win10Multi%3CBR%20%2F%3EDescription%20%3A%20Created%20through%20ARM%20template%3CBR%20%2F%3EPersistent%20%3A%20False%3CBR%20%2F%3ECustomRdpProperty%20%3A%20audiomode%3Ai%3A0%3Baudiocapturemode%3Ai%3A1%3Bcamerastoredirect%3As%3A*%3Bdevicestoredirect%3As%3A*%3B%3CBR%20%2F%3EMaxSessionLimit%20%3A%202%3CBR%20%2F%3ELoadBalancerType%20%3A%20BreadthFirst%3CBR%20%2F%3EValidationEnv%20%3A%20False%3CBR%20%2F%3ERing%20%3A%3CBR%20%2F%3EAssignmentType%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETested%20on%20Lenovo%20p52s%20and%20Macbook%20Air%20with%20desktop%20clients%20as%20well%20as%20the%20web%20client.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1460279%22%20slang%3D%22en-US%22%3ERe%3A%20Camera%2FMic%20not%20available%20even%20with%20CustomRdpProperty%20set%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1460279%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F698042%22%20target%3D%22_blank%22%3E%40jameskol1776%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20not%20have%20a%20solution%20but%20I%20did%20experience%20issues%20where%20I%20was%20not%20seeing%20device%20redirection%20working%20properly.%20I%20found%20that%20I%20was%20making%20too%20many%20changes%20too%20quickly%20and%20not%20allowing%20time%20for%20these%20settings%20to%20propagate%20and%20apparently%20take%20effect.%20They%20definitely%20are%20not%20instantaneous%20as%20I%20have%20found%20it'll%20take%20at%20least%20an%20hour%20or%20more%20for%20a%20change%20to%20take%20effect%20across%20the%20entire%20pool.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%20check%20and%20confirm%20that%20you%20are%20are%20seeing%20the%20RDP%20Settings%20update%20within%20the%20host%20pools%20properties%20tab.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20my%20settings%20as%20such%20on%20Win%2010%202004%20and%20have%20success%20with%20both%20camera%20and%20mic%20redirection%3A%3C%2FP%3E%3CP%3Eaudiocapturemode%3Ai%3A1%3Baudiomode%3Ai%3A0%3Bdrivestoredirect%3As%3A*%3Bredirectclipboard%3Ai%3A1%3Bredirectcomports%3Ai%3A0%3Bredirectprinters%3Ai%3A1%3Bredirectsmartcards%3Ai%3A1%3Bscreen%20mode%20id%3Ai%3A2%3Bcamerastoredirect%3As%3A*%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1460899%22%20slang%3D%22en-US%22%3ERe%3A%20Camera%2FMic%20not%20available%20even%20with%20CustomRdpProperty%20set%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1460899%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F666497%22%20target%3D%22_blank%22%3E%40CMurphyUSA%3C%2FA%3EThanks%2C%20that%20was%20it.%26nbsp%3B%20I%20just%20needed%20to%20wait.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hello,

Have a new multi session Windows 10 2004 host pool that the operating system or Teams 32 bit do not see the camera or mic

 

The CustomRdpProperty is set as follows:

 

TenantName : WVD Tenant
TenantGroupName : Default Tenant Group
HostPoolName : Win10Multi
FriendlyName : Win10Multi
Description : Created through ARM template
Persistent : False
CustomRdpProperty : audiomode:i:0;audiocapturemode:i:1;camerastoredirect:s:*;devicestoredirect:s:*;
MaxSessionLimit : 2
LoadBalancerType : BreadthFirst
ValidationEnv : False
Ring :
AssignmentType :

 

Tested on Lenovo p52s and Macbook Air with desktop clients as well as the web client.

 

Thanks in advance

 

 

2 Replies
Best Response confirmed by jameskol1776 (New Contributor)
Solution

@jameskol1776 

 

Do not have a solution but I did experience issues where I was not seeing device redirection working properly. I found that I was making too many changes too quickly and not allowing time for these settings to propagate and apparently take effect. They definitely are not instantaneous as I have found it'll take at least an hour or more for a change to take effect across the entire pool.

 

Also check and confirm that you are are seeing the RDP Settings update within the host pools properties tab.

 

I have my settings as such on Win 10 2004 and have success with both camera and mic redirection:

audiocapturemode:i:1;audiomode:i:0;drivestoredirect:s:*;redirectclipboard:i:1;redirectcomports:i:0;redirectprinters:i:1;redirectsmartcards:i:1;screen mode id:i:2;camerastoredirect:s:*

@CMurphyUSAThanks, that was it.  I just needed to wait.