Bespoke application crashes in WVD, however runs perfectly fine on the host pool servers?

%3CLINGO-SUB%20id%3D%22lingo-sub-1332161%22%20slang%3D%22en-US%22%3EBespoke%20application%20crashes%20in%20WVD%2C%20however%20runs%20perfectly%20fine%20on%20the%20host%20pool%20servers%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1332161%22%20slang%3D%22en-US%22%3E%3CP%3EHello.%20I'd%20really%20appreciate%20any%20advice.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20created%20a%20new%20WVD%20environment%2C%20all%20works%20well.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20created%20an%20app%20group%20with%202%20apps%2C%20one%20being%20Word%20which%20works%20fine%2C%20and%20the%20second%20being%20a%20bespoke%20.NET%20application%20which%20crashes%20with%20the%20following%20error%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%22The%20exception%20unknown%20software%20exception%20(0xe0434352)%20occured%20in%20the%20application%20at%20location%200x0000000076AB4192%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%20stated%20in%20the%20title%2C%20the%20application%20runs%20absolutely%20fine%20when%20I%20RDP%20onto%20the%20WVD%20VM's.%20It's%20a%20simple%20applicaton%20that%20connects%20to%20some%20databases%2C%20etc.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20have%20any%20ideas%20why%20it%20would%20crash%20in%20WVD%20and%20not%20load%20at%20all%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20for%20reading%20this.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1333047%22%20slang%3D%22en-US%22%3ERe%3A%20Bespoke%20application%20crashes%20in%20WVD%2C%20however%20runs%20perfectly%20fine%20on%20the%20host%20pool%20servers%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1333047%22%20slang%3D%22en-US%22%3EIf%20I%20can%20offer%20some%20advice%20as%20someone%20who%20had%20to%20troubleshoot%20similar%20issues%20with%20other%20finicky%20software%20that%20worked%20fine%20when%20you%20RDP%20into%20the%20session%20host%20but%20failed%20when%20ran%20from%20WVD%3A%3CBR%20%2F%3E%3CBR%20%2F%3ECreate%20a%20Desktop%20Application%20Group.%20Launch%20the%20desktop%2C%20then%20try%20to%20launch%20the%20app.%20See%20if%20it%20works%20then.%20I%20was%20forced%20to%20use%20WVD%20Desktop%20Application%20Groups%20and%20serve%20up%20the%20entire%20desktop%20for%20some%20of%20our%20most%20finicky%20software.%3CBR%20%2F%3E%3CBR%20%2F%3EGet%20Process%20Monitor%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsysinternals%2Fdownloads%2Fprocmon%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsysinternals%2Fdownloads%2Fprocmon%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3ERun%20this%20when%20RDP'd%20into%20the%20session%20host%2C%20then%20again%20when%20you%20launch%20the%20application%20from%20a%20WVD%20Desktop.%20ProcMon%20should%20tell%20you%20exactly%20where%20it's%20failing.%20Tracking%20down%20the%20error%20from%20there%20is%20more%20art%20than%20science%2C%20but%20it%20should%20point%20you%20in%20the%20right%20direction.%20I've%20found%20that%2090%25%20of%20the%20time%20it's%20registry%20or%20file%20system%20permissions.%3CBR%20%2F%3E%3CBR%20%2F%3EHope%20that%20helps.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hello. I'd really appreciate any advice.

 

I have created a new WVD environment, all works well. 

 

I created an app group with 2 apps, one being Word which works fine, and the second being a bespoke .NET application which crashes with the following error:

 

"The exception unknown software exception (0xe0434352) occured in the application at location 0x0000000076AB4192".

 

As stated in the title, the application runs absolutely fine when I RDP onto the WVD VM's. It's a simple applicaton that connects to some databases, etc.

 

Does anyone have any ideas why it would crash in WVD and not load at all?

 

Thank you for reading this.

1 Reply
If I can offer some advice as someone who had to troubleshoot similar issues with other finicky software that worked fine when you RDP into the session host but failed when ran from WVD:

Create a Desktop Application Group. Launch the desktop, then try to launch the app. See if it works then. I was forced to use WVD Desktop Application Groups and serve up the entire desktop for some of our most finicky software.

Get Process Monitor: https://docs.microsoft.com/en-us/sysinternals/downloads/procmon

Run this when RDP'd into the session host, then again when you launch the application from a WVD Desktop. ProcMon should tell you exactly where it's failing. Tracking down the error from there is more art than science, but it should point you in the right direction. I've found that 90% of the time it's registry or file system permissions.

Hope that helps.