SOLVED

AAD Authentication Error

%3CLINGO-SUB%20id%3D%22lingo-sub-2108187%22%20slang%3D%22de-DE%22%3EAAD%20Authentication%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2108187%22%20slang%3D%22de-DE%22%3E%3CP%3EI%20have%20set%20up%20a%20fresh%20WVD%20host%20pool%20with%20two%20domain%20joined%20virtual%20machines%20running.%20I%20can%20subscribe%20to%20the%20feed%20with%20the%20Windows%20Virtual%20Desktop%20app%20from%20the%20store%2C%20but%20whenever%20I%20go%20through%20the%20webclient%2C%20I%20get%20an%20%22AAD%20Authentication%20Error%20-%20Your%20credentials%20do%20not%20have%20access%20to%20this%20web%20application.%20Please%20try%20again%20with%20different%20credentials%20or%20from%20an%20InPrivate%20browser%20session%22.%3C%2FP%3E%3CP%3EI%20tried%20it%20in%203%20different%20browsers%20and%20another%20device%20which%20is%20running%20under%20the%20AD%20account%20I%20have%20assigned%20to%20the%20application%20group.%20I%20also%20tried%20with%20a%20different%20account%20from%20the%20same%20assigned%20group.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20open%20a%20desktop%20session%20when%20using%20the%20store%20client%2C%20but%20why%20is%20the%20website%20not%20allowing%20access%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2127959%22%20slang%3D%22en-US%22%3ERe%3A%20AAD%20Authentication%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2127959%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F308010%22%20target%3D%22_blank%22%3E%40Niels_Ziegler%3C%2FA%3E%26nbsp%3B%20Hello.%20I%20am%20having%20this%20exact%20same%20issue%20when%20using%20the%20website%20to%20attempt%20to%20login.%20The%20Remote%20App%20works%20fine%20though.%20Have%20you%20managed%20to%20find%20the%20solution%20yet%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMarcus%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I have set up a fresh WVD host pool with two domain joined virtual machines running. I can subscribe to the feed with the Windows Virtual Desktop app from the store, but whenever I go through the webclient, I get an "AAD Authentication Error - Your credentials do not have access to this web application. Please try again with different credentials or from an InPrivate browser session".

I tried it in 3 different browsers and another device which is running under the AD account I have assigned to the application group. I also tried with a different account from the same assigned group.

 

I can open a desktop session when using the store client, but why is the website not allowing access?

3 Replies

@Niels_Ziegler  Hello. I am having this exact same issue when using the website to attempt to login. The Remote App works fine though. Have you managed to find the solution yet ?

 

Marcus

Best Response confirmed by Niels_Ziegler (New Contributor)
Solution

@MarcusMSRA 

 

Yes, I made the stupid mistake of using

https://rdweb.wvd.microsoft.com/webclient/index.html

 

instead of the link for the "after spring upate" version

https://rdweb.wvd.microsoft.com/arm/webclient/index.html

 

because the shortlink aka.ms/wvdweb led me to the older one.

@Niels_Ziegler it looks like I made the same mistake. Thanks for replying so quickly. This helped me out no end.

 

Marcus