Windows Update - Error 0x80007005

Occasional Contributor

I'm not sure if this is really the right place to ask this question so my apologies for wasting people's time if I've got it wrong.


However I've been trying for many, many months now to update one of my systems to the latest Windows 10 release. It was originally a Windows 7 system and I upgraded it during the initial 12 months of Windows 10 availability to Windows 10 Home.


My problem is that this is just about as far as I can get - for some reason whenever I try to get it to install the latest update it comes back with the message "Feature update to Windows 10, version 1607 - Error 0x80070005".


The problem is two fold - first I cannot find any reliable information as to exactly what this error code means which makes it a bit difficult for me to do any logical troubleshooting, and secondly I can't find any Microsoft solution suggestions for the problem. Sure I can find all sorts of 'hacks' on the web and although I have tried many of them that look safe none have made any difference to the problem. I would like to update this system to the latest level but its proving impossible. Settings Update tells me there is an update to Windows 1607 available but whenever I tell it to go ahead I get the same error message mentioned above back. I don;t want to have to do a Windows Reset because some of the apps on the system would be very difficult to reinstall (e.g. Lotus Notes) so that solution is out even if I took the risk that it would work - it might not and then I would have lost several critical apps (they are all legally installed and licensed by the way - its just a pain to redo the work and means contacting folks in Germany over the phone).


Can anyone tell me what the error message really means. and then ideally what the solution to the problem is please? 

10 Replies

Wow! This is really pickup adequately. 750 views and not a single answer!

I know its a while since I posed this question and I apologise if I haven't already posted what I think was the solution - at least in my case. I think I resolved the problem in the end by manually downloading the update from the Microsoft site (i.e. not using the inbuilt Windows Update process) and I believe running the update from this downloaded file resolved the problem. I imagine the issue is probably somehow related to permissions but as we know Microsoft error messages are far from comprehensive when it comes to telling us why something has failed, so often we have to just surmise. Anyway I believe I resolved the problem this way on two occasions.

Hey Bernard, thanks for sharing this.
I just upgraded the way you did and now it's OK.
Pity that noone else in this community responded.
Thanks again !

Please tell us the site where you downloaded the update file.


Thanks in advance


Tom Jones

Bernard, I'm sorry no one responded. You error code (as I'm sure you now know is "Access Denied". The question is/was to what? I'm glad you were able to get your machine upgraded, and hopefully are able to keep up to date. If you are not aware during the upgrade process all you can watch the setupact.log file located in C:\$Windows.~BT\Sources\Panther. This has been very helpful in tracking down Feature Update issues for me. Hope this is helpful in the future. -Eddie

Thanks Eddie, Yes I did solve the problem for a while but it has come back again when I try to get the 1809 update. As you say it looks like a permissions update. However the log you mentioned is about as clear as the previous error message and is actually 56 megabytes in size (I gave up trying to count how many lines were in it)! I'm just wondering however if one thing which I did some time ago (I cannot remember when) might be having some bearing on this problem.


Originally I think I set this machine up with a userid and password - nothing to do with a Microsoft account, and then at some stage I changed the user to one with a Microsoft account (and password) - do you think this may have a bearing on this problem? There's only ever been one user (defined by me) and this has always been an admin user.

Any updates that fail make a note of them and you can go here to download them and install them manually Try that and let me know Kind Regards Robert
Bernard, User accounts should have no impact at all. These processes run in the system context if I remember correctly. Eddie
Good point, Robert. I had some machines recently that were not updating with a different error ("User Cancelled") that turned out to be an issue with the latest Servicing Stack Update (SSU) not installing correctly. Eddie