Devices don't show up in Update Compliance

Iron Contributor

Hi, where can we start the troubleshooting if I don't see any devices showing up in my Update Compliance workspace.


I've ran the deployment script after editing the Commercial ID, and the devices don't show up.

I've also tried with the GPO settings, like explained here:
but nothing is showing up.

Thank you in advance and don't hesitate if you have any questions.

5 Replies

Hi @lalanc01 ,


How long have you waited? It takes anywhere between 24-48 hours for a device to show up once they've been configured with the commercial ID.


@lalanc01 Are devices at all showing in the update compliance workspace?

@Jason_Sandys I haven't been able to see any of the 3 devices I've tried over the last week.


I only see the devices that I've used for desktop analytics



Your best bet is filing a support request. There's a large amount of potential things that could be going on and we can't really narrow it down without getting more details. 


To do this:

  1. In Azure, go to the "?" in the top-right nav. 
  2. Click "Help + Support"
  3. Click "Create a support request"
  4. In Basics...
    1. Issue type: Technical
    2. Subscription: <Select the subscription of your UC workspace>
    3. Service: Log Analytics
    4. Resource: <Select your Log Analytics workspace that you selected when signing up for UC>
    5. Summary: "Devices don't show up in Update Compliance - Product owner requested I submit request"
    6. Problem type: Solutions and Insights
    7. Problem subtype: Update Compliance (Windows Analytics)
  5. In Solutions... Skip it. 
  6. In Details: Fill out the details.
    1. In Additional details:
      1. Mention that Charles Inglis the PM for Update Compliance requested you submit a ticket.
      2. Include your Commercial ID and Log Analytics Workspace ID. 
    2. For File upload, please include output from a run of the config script on one of the machines in Verbose mode.