WSL 2 not working after installing 20262

Copper Contributor

Just getting involved with Insider Preview...upgraded 2019 Datacenter (latest official release) to 20262. After the upgrade, downloaded and ran the Linux Kernel update package. When running WSL commands from the command-line, almost every command I run returns the same output that wsl --help enumerates. If I run wsl --set-default-version 2, it enumerates the help context. Did I miss a step to get this to work or is this a known bug?

35 Replies

@Byron Boudreaux 


i have the same problem



I have the same problem, wsl and docker does not start. It is a little random, but if I restart the PC sometimes it start again.

@Byron Boudreaux WSL 2 will not be included with the next LSTC of Windows Server, it was included in the SAC releases but was not in Windows Server 2019 (the prior LTSC).

@Taylor Brown So you said WSL2 will not be available in the 20270 build ? or should be but there is a bug ?

Could someone please clarify if this will be reinstated? and why it was removed. Its a really excellent development addition and it missing breaks my development experience. :(

I have tried on build 20285 and 20287 and the same experience.


I couldn't find any feedback, so I wrote one 

please upvote it






BTW the last build where it works is build 20241.

first go to insider website and sign-in Download Windows Server Insider Preview (

Then you can generate the link to download the older build here


After successfully installing a distro inside the build 20241 I have tried in-place upgrade to the latest 20287, which finished OK, but it doesn't only brakes the "wsl --set-default-version 2" command, it doesn't want to start the distro anymore, the error is something about mount failed.


I have just realized that the build 20241 where WSL2 works expired on January 31 2021 :sad: 

And it looks like the timebomb breaks the WSL, I am unable to start or import any distro and am getting "Invalid Data" error. As soon as I changed the date back in time everything works again.


I am looking forward to a new build with working WSL2.


Yes I did, it's in my first post.
I have tried both freshly installed build 20287 and also inplace upgrade of working WSL2 in 20241 to 20287, but the result is the same e.g. no working WSL2 :(

@LubomirH ok thats a shame. It wasn't clear in your post that you had done a fresh install,as well as an upgrade.  :sad:

build 20289 still with the same issue :sad:


@Mary Hoffman 

Why isn't the not working WSL2 as part of the Known Issues?

I am just wondering if it is part of some automatic tests or not.


thanks for any answer



@LubomirH I believe this issue persists because the product team does not intend to ship WSL in Windows Server.

@Byron Boudreaux 

well, this would be really a pity

I hope this is just a bug and you are not right!

Although I am able to run the WSL2 in the build 20241 while having the time set back, it doesn't really help much, because of the time difference SSL is broken and thus other things are broken and you can't install any docker container from online. :cry:


@Mary Hoffman

Mary can you please give us some official statement?

Is there any hope that WSL2 will be fixed in next builds or the rumors are right and WSL2 will not be part of the final WS2022 release?

I would be glad to test and report back, because I like the idea of having both Windows and Linux containers on one host next to each other.







@LubomirH It is my opinion that it is unlikely that WSL will be included in the final Windows Server product as it was was not included in Windows Server 2019.  The investigation on this issue is ongoing and I hope to have a more complete answer for you soon. We do recommend upgrading to the latest preview build in order to pick up all the recent fixes and updates.

@Mary Hoffman 

I am confused.

Isn't WSL part of the server since Windows Server 2019 (version 1709)?

It is at least written in the guide Install the Linux Subsystem on Windows Server | Microsoft Docs

And I could also find the WSL feature on the Windows Server 2019 LTSC (version 1809)


Am I missing something between the lines?





@LubomirH WSL was only available in the Semi-Annual Channel releases, not Windows Server LTSC. What may be confusing is that there was an 1809 version of both SAC and LTSC - they were released at the same time.