Windows Server 2022 Remote Desktop Services installation is failing

%3CLINGO-SUB%20id%3D%22%5C%26quot%3Blingo-sub-3052780%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Bde-DE%5C%26quot%3B%22%3EWindows%20Server%202022%20Remote%20Desktop%20Services%20installation%20is%20failing%26lt%3B%5C%2Flingo-sub%26gt%3B%3CLINGO-BODY%20id%3D%22%5C%26quot%3Blingo-body-3052780%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Bde-DE%5C%26quot%3B%22%3E%3CP%3ETried%20to%20install%20die%20RDP%20Services%20several%20times.%20Setup%20is%20always%20failing.%20Connection%20Broker%20can't%20be%20installed%20-%20responsible%20for%20the%20the%20failure%20seems%20to%20bethe%20windows%20internal%20database%20service%20-%20since%20it%20%3CSPAN%3E%20can't%20be%20started.%20Tried%20to%20install%20the%20service%20%26lt%3B%5C%2FSPAN%26gt%3B%20(windows%20internal%20database)%20%3CSPAN%3E%20on%20its%20own%20-%20resulting%20in%20the%20same%20error.%20Tried%20the%20same%20config%20with%20Windows%20Server%202019%20on%20the%20same%20hardware%20-%20working%20without%20any%20problems.%20Reinstalled%20it%20several%20times%20to%20no%20avail.%20I%20really%20have%20no%20idea%20how%20to%20solve%20it.%26lt%3B%5C%2FSPAN%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3ELooking%20for%20your%20help.%26lt%3B%5C%2FSPAN%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EBest%20wishes%20Werner%26lt%3B%5C%2FSPAN%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%26lt%3B%5C%2Flingo-body%26gt%3B%3CLINGO-LABS%20id%3D%22%5C%26quot%3Blingo-labs-3052780%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Bde-DE%5C%26quot%3B%22%3E%3CLINGO-LABEL%3EGeneral%26lt%3B%5C%2Flingo-label%26gt%3B%26lt%3B%5C%2Flingo-labs%26gt%3B%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3C%2FLINGO-SUB%3E
New Contributor

Tried to install die RDP Services several times. Setup is always failing. Connection Broker can't be installed - responsible for the the failure seems to bethe  windows internal database service - since it can't be started. Tried to install the service (windows internal database) on its own - resulting in the same error. Tried the same config with Windows Server 2019 on the same hardware - working without any problems. Reinstalled it several times to no avail. I really have no idea how to solve it.

Looking for ur help.

Best wishes Werner

 

4 Replies
Is this the RTM release of Server 2022 (build 20348) or the newer ones? I ask because you're posting in the Windows Server Insiders group, and it's important to clarify.

Regardless, a next step should be to look at the CBS (Component Based Servicing) log file which is located at C:\Windows\Logs\CBS\CBS.log. Open it up in Notepad and search for "Error" which should yield some clues, or at the very least, more to search upon. You'll also want to look at the Event Logs for any additional info there too.
Hello Jonathan,
thanks a lot for ur reply. Tried the current evaluation version of windows server 2022 - also allowed to download the available updates before the installation. Also tried a newly bought Windows Server 2022 essentials edition. Always the same issue. Already checked the Event Logs. The reason for the errors seems to be the windows internal database service - at least the Event Logs tell me that. Already tried a work around and wasted 2 days searching for a solution. This is why I soley tried to install the windows internal database service. But the installation abortet, too. The error message is (trying to translate it correctly from German): the windows internal database service has been unexpectetly terminated. This is also the same error that occurs when I try to install the RDS - this exact error message also occurs during the installation of the Connection Broker. With Windows Server 2019 - the installation of the RDS Roles works perfectly.
Thanks again for ur response.

@Werner2360 

My apologies Werner, I missed the part in your original post where you indicated that it "couldn't be started". So it seems the installation process is fine, the problem is starting the service(s) afterwards.

As a quick test, I installed all the RDS components (including WID) into a blank updated 2022 RTM VM (US English) and it seems to all work there.

 

However, as you might know, the WID (Windows Internal Database) is just a SQL Server instance. Naturally, it has its own log files too, which you'll find in the C:\Windows\WID\Log folder as "error.log", "error1.log", etc. The naming of the log files is a bit deceptive, as even without errors, they're still the main log files. It's likely the problem will become more clear in these files.

 

If there are no log files in that folder, it means the WID service has never started. The service uses its own service account (NT SERVICE\MSSQL$MICROSOFT##WID) to start, but if it doesn't have the rights to start as a service, or some other problem, that may be where you should be looking. I stress this is likely not the solution to your problem, but I found an example of that on Server 2012 R2.

Hello Jonathan, thanks a lot for ur reply. Sadly I‘m super busy with work right now - so I can test ur suggestions immediatly. But I‘m going to test! Thanks again for ur reply - I‘ll give feedback as soon as I have done some further testing. BTW I think that the WID serice could‘t start, cause its installation failed. Thanks again for ur great feedback.