WDS not working in build 17639

Copper Contributor

I installed the WDS Role thru server manager than I tried to configure WDS in standalone mode both thru the MMC WDS and the following command line:


wdsutil /initialize-server /reminst:"c:\reminst" /standalone


I get: 


Error Code: 0x41D
Error Description: The service did not respond to the start or control request in a timely fashion.


I tried both in a VM and on a phisical server. Still impossible to start the service...

15 Replies

Looking forward to getting this set up myself.  I get


Error Code: 0xC104013B
Error Description: The Windows Deployment Services management tools are not configured.


I realize this isn't the same issue but if you think we can help each other, please feel free to respond.

Same here cant get the wds server to start when I use the gui when I go to initiate the server it freezes

I have tried on a fresh install and as a standalone install with no other roles in the error log it just says cant start server

same problem with build 17650..


I hope they fix this bug.


All my business is based on WDS/MDT/SCCM...


won't work if WDS does NOT WORK...

Ok i mangaged to get the the wds service running in services.

Cant remeber exactly how i got it to work iam trying to replicate the steps to get the services running

still a issue with the mmc console when trying to configure the server it keeps freezing

but atleast the service is running when i find and replicate i will share my findings

Ok there seems to be a bug in mmc and wds as it crashes.

You can get wds to work as I have successfully deployed a window 10 with wds but you have to initiate and set all server boot locations dhcp settings server authorised allow all connections and all the configuration you would normally do using mmc in the terminal using wdsutil when you set the param make sure you stop the server using wdsutil command and when set params make sure you use verbose to see if you run into problems

I had running on same server as dhcp and a vm with out dhcp wdsutil needs different commands dependent on your config.

But as it stands wds does not work with mmc and can only be configured and run using wdsutil in term or power.

When I get up I will post a link of a site I found with the wdsutil commands that you will need to get it going

Ok this is bugging me because i just  dont like when things dont work when they are meant to.


Last 2 weeks have just been a big info download as i have just  moved over from linux, juju, maas and openstack after many years studying it.


I have been contemplating which platform to run a corp setup on windows server has a huge vote from me as windows you get good apps.


Never the less i think i will implemet a hybrid mix of the 2 in some sort of private cloud complicated but do able.


Any way last two weeks of serious info download to the cerebrum


I feel confident i can solve this problem with mmc and wds hanging within the next week


i will post with the solution once i debug the problem and and acquire a soloution

still NOT WORKING in build 17666 !!!


can someone fix this PLEEEESE ???

still not working in build 17677

WDSUTIL /initialize-server /standalone /reminst:c:\reminst  runs, but still gets stuck...


after reboot WDS service starts, but the MMC for WDS gets still stuck when launched.


The same thing happens to me in build 17666, wanting to configure WDS gets stuck.

Thanks for reporting this. We are investigating the issue and will try to get a fix in future builds. For now you can work around the problem by using wdsutil to manage the server.

Thanks, but wdsutils does not work w fine for this build


An error occurred while trying to execute the command.
Error Code: 0x41D
Error Description: The service did not respond to the start or control request in a timely fashion.

Works perfectly now in Build 17713 ! :) 

Effectively. I've tried it and it works perfectly Thaks!