RSAT missing DNS Server Tools?

Copper Contributor


on a fresh Win 10 insider client (16278 updated to 16299) I installed Windows_InsiderPreview_RSAT_x64_16279 but it seems to be missing DNS Server Tools, the MMC snap-in. All other tools like AD, DHCP, WSUS, RAS etc. are there.

It should be there, right?

Cheers, Oliver



56 Replies
I just solved this issue on the Windows 10 that I upgraded last night to 16299.15. If you have a Windows Server 2016 (not insider) machine on your network, or another Windows 10 with the WS2016 (not insider) RSAT tools installed, you need to copy four files from it to your Windows 10 after installing RSAT 16279. system32: dnsmgmt.msc and dnsmgr.dll system32\en-us: dnsmgmt.msc and DNSmgr.dll.mui (or slightly fewer keystrokes if you are using the command prompt to do it, copy dnsmg*.* in both system32 and system32\en-us folders) Then run this command as admin: regsvr32 c:\windows\system32\dnsmgr.dll

The formatting went wonky on what I just posted but hopefully it is usable.


The last step of course is to make a shortcut to system32\dnsmgmt.msc and copy it into your start menu admin tools folder.

Nice workaround, thx. I hope it will be fixed in future RSAT releases.

It has not been fixed in WindowsTH-RSAT_WS_1709-x64.msu released today :(


I've been having problems getting RSAT to install on build 16299 and tried your method above, but get the error "MMC could not create the snap-in."


It seems like Microsoft is trying to get away from MMC. Is there some new way I'm suppose to be managing my servers that isn't powershell?


Edit: disregard, I forgot to run the regsvr32 command at the end. "facepalm:

Edit 2: If you don't have another Windows 10 or Server 2016 machine to copy from, and you just upgraded your copy of Windows (which broke RSAT), you can copy the files from the C:\Windows.old directory.

But the above workaround still works. Thanks.

We're also seeing this issue on the current download here:


File: WindowsTH-RSAT_WS_1709-x64.msu


We'd prefer not to move files around manually in order to get DNS back - when can we expect an actual fix (i.e. a new release) for this issue?


And more importantly, how could this pass even the most basic of QA tests and be released to the general public? :)

In my "perfect world" people would get fired over this. Think of all the thousands of wasted hours this will now cause.

This solution works from me. The 1709 RSAT update still has the same issue.

I was able to accomplish the same thing by just copying the files out of the windows.old directory on the same PC after moving to build 1709. Workaround works, but MS should actually fix the actual issue...

The DNS team is validating an official solution and working on putting together a KB article with the details. Thanks for your patience!

Any update on this?

I do not have a 2016 server or a windows.old with relevant dns msc files.  Some MSC Admin tools are only used by a very small fraction, but DNS? 

Please provide an update soon.

Attached are the files I've been using for the workaround. Agreed that this issue needs to be fixed - it is a bit ridiculous. Literally - Windows haters ridicule Microsoft over stupid little things like this, and preventable mistakes just reinforce the stereotype.

Thanks, I'm able to use DNS Manager now.

Thanks! Worked for me. I use DNS all the time as a Sys Admin. I am on the Insiders Program and waiting for 17025.1000 to download and install. I installed 1709 and noticed that my RSAT tool tiles were missing on my Start menu. I found that I needed to install RSAT for 1709. But then missing my DNS tool, I cannot be without, although, I am using PowerShell more to work with DNS.

The above worked for me thanks :) 

I had to re-install the RSAT again after the preview installation of Build 17025.1000. Also had to re-run the registration and pin the DNS link back to my Start menu.

@Robert Affleck wrote:

In my "perfect world" people would get fired over this. Think of all the thousands of wasted hours this will now cause.

that won't solve the issue. Learn from the mistake and make sure won't happen again.

1 best response

Accepted Solutions
best response confirmed by Mary Hoffman (Microsoft)

[UPDATE] The final 1803 release of RSAT is now on the public RSAT download page. Look for the WS_1803 package there, thanks!




Here's the official KB workaround published by the DNS team: (thanks @Christoff MOrlOck for posting this previously)


The RSAT download page now also has this info under Additional Information:

Issue: DNS Tools missing
Impact: WS_1709 RSAT package users
Resolution: Use the WS2016 RSAT package or apply this workaround


The DNS team has also fixed the root cause for RS4 and so the workaround will not be required for the upcoming RS4 RSAT package update.



View solution in original post