SOLVED

Problem running microsoft/nanoserver-insider:10.0.17074.1000 image

Occasional Contributor

I'm running Windows Insider Server 17074 and encounter problems running the microsoft/nanoserver-insider:10.0.17074.1000 Docker image.

 

Docker either shows an error

 

docker run microsoft/nanoserver-insider cmd /c time
docker: Error response from daemon: container 301cd4c7ddd50a18a4107a074885b7a66069903e5e79cc959c3a4f582a9fe418 encountered an error during Start: failure in a Windows system call: The compute system exited unexpectedly. (0xc0370106).

 

or even crashes the machine with a BSOD Stop Code: “TERMINAL SERVER DRIVER MADE INCORRECT MEMORY REFERENCE”, What failed: win32k.sys

My current workaround is running the nanoserver-insider image with hyperv isolation which works

 

docker run --isolation hyperv microsoft/nanoserver-insider:10.0.17074.1000 cmd /c date
The current date is: Wed 01/17/2018 
Enter the new date: (mm-dd-yy) 


The windowsservercore-insider image works fine without hyperv isolation.

My 17074 VM runs in VMware Fusion Pro 10.1.1 and Vagrant 2.0.1. 

5 Replies

I am getting the same error on a new install in a Hyper-V VM running on windows 10. I am trying different Docker Packages but they all seem to have the same error.

 

It looks like we may have to wait for a fix.

best response confirmed by Stefan Scherer (Occasional Contributor)
Solution

Thanks for reporting this! I checked it out and it's definitely a bug. We know what caused it and a fix will be in an upcoming build. I added this to the release notes for 17074. It's a general problem with this build, and not specific to any virtualization platform.

Richard - does this also happen if you run microsoft/windowsservercore-insider ? I think this is specific to images based on microsoft/nanoserver.

Only nano server for me.

 

Thanks for updating the docs regarding the fault.

Hi @Patrick Lang,

I'm seeing this issue on one machine of Windows 10 pro 1809 with mcr.microsoft.com/windows/nanoserver:1809. The issue occurs in running or shutting down the image. Could you please take a look at the attached dump analysis file?