[ISSUE] b20251 b20257 b20262 b20270 b20282 b20287 Formatting a volume fails





affected builds (tested): b20251,b20257,b20262,b20270,b20282

remotely via Server Manager from b20201


initializing as GPT / reset / clean works fine.

creating partition works fine

formatting volume fails


repro steps:

reset disk

new volume

fs refs or ntfs, default settings

format will fail (see diskpart and Server Manager)

if server manager is used, update cache will run eternally until wizard is closed





37 Replies

@Karl_Wester-Ebbinghaus  Hi, thanks for reporting this issue! To help with the diagnosis, can you please also try using Disk Management? I'd like to see if this issue persists across Diskpart, Server Manager, AND Disk Management. 

Hi @AndrewHansen, unfortunately it does.

@Elden Christensen @AndrewHansen hi there I can confirm there is no change in b20270

Hello @AndrewHansen I am still seeing this issue that i cannot format any drives using diskpart, Server Manager in b20270 and b27282 on the local machine.


But now it is getting interesting. Using WAC 2012 Preview this works from a remote machine. I still have to believe there is something broken with the local commands.


Hi @Mary Hoffman do you know if anyone is actively triaging this?

@Karl_Wester-Ebbinghaus  Hi, apologies for the delay. We've investigated this a bit further. Can you look in “\windows\system32” directory to see if the files “untfs.dll” and “uReFS.dll” exist? It looks like dispart is failing to load those modules. 




Hi @AndrewHansen 

no problem, holiday, covid, potentially more reasons. As long we get a solution I am happy.




each match with the OS version b20282

Hi @Karl_Wester-Ebbinghaus,

Thanks for the response.

We tested on the latest flighting insider build and was not able to repro this issue. Formatting volumes (both NTFS and REFS) via Disk Management, Server Manager and diskpart all work fine. Can you please try upgrading to the latest build and see if the issue persist?


@YanranHao yes I will try. It will demand to move some VMs back and forth but that's ok. 

This is a local NvME disk where I have tried it last time. I can also double check the situation in Windows Server VM. It should give same results.  

@YanranHao this will take some more time as Ned Pyle is currently investigating an SMB related issue in b20282. 

hello@YanranHao this is the state with b20287, it is unchanged

- upgraded to b20287
- have emptied the internal NvME drive 

- reset disk via Server Manager (selected drive)

- formatted it with Server Manager (see screenshot results)




- using WAC would work but you need to reset disk first because the disk in in an inconsistent state


- WAC as of 2012 preview cannot initialize disks (or reset disks) that are already as GPT or MBR initialized @Prasidh_Arora,


- after "reset disk" in Server Manager WAC is able to initialize and format the disk properly, unlike Server Manager / diskpart etc. 







Hi @Karl_Wester-Ebbinghaus, thanks for the feedback. After you successfully formatted the volume via WAC, are you able to format the volume again (not resetting the disk, format the active volume directly) using Disk Management/Diskpart/format.com/Server Manager?

@YanranHao no. This does not work either. I have tested this weird thing on another machine and it works as intended. I noticed only one difference and I suspect that the troublemaker could be the Samsung NvME driver 3.3. I will be able to pinpoint this tomorrow. 

@Karl_Wester-Ebbinghaus I'm suspecting the hard disk driver too. I've tested the same repro step on non-Samsung NvME disk and did not find any problem.

@Karl_Wester-Ebbinghaus And you can try running "format.com /Q /FS:NTFS volume" on the volume to see if it give you more detail error information.

@YanranHao I am meanwhile in flight of build 20292. On this particular system I have the following setup
NvME disk, Samsung 3.3 NvME driver

Server Manager still gives the issue after reset and configuring the disk with the wizard.
It does not matter the FS used, so result for NTFS / ReFS is used. Also with configured Dedup VDI or no dedup same result
When I reset the disk in Server Manager and the process will stuck at formatting I am not able to use your format DOS command, as the wizard does not create a volume at all and thus no mounting point (driveletter)


What I could try is the following:
using server manage

initialize the disk as GPT via server manager 


sel dis 3

create part pri 
sel vol 4 (the raw volume)

assign letter=n
format.com /q /fs:ntfs n:
Result: this way it would work / same as with WAC remotely
I have to assume there is problem with Server Manager for no clear reason.
format gives no error opposite to Server Manager





@YanranHao I have no clue why Server Manager behaves this way but know it does utilize PowerShell under the hood (should).
for WAC this should be true the same way but something is different.
I will repeat the steps above and will try to leverage format-volume next and see what happens in comparison to format.com

@YanranHao I assume this is what Server Manager does as it result in the same error



so let's try a combination of the previous (creation of a raw volume with diskpart) and formatting with Powershell












Results: works

I see no relation to the used driver as both (Samsung or Standard NvME) give the same error and behaviour
1. format.com works only if I create a raw vol via diskpart and assign a letter to meet the technical requirements. Formatting is ok

2. format-volume works the same way
3. New-Volume and Server Manager give the same error. 

I have to assume that something is wrong with the new-volume cmdlet in the step to create a raw volume and assign the letter - because if manually done by diskpart this formatting is not an issue.


I understand you cannot reproduce this at your side, but on this system it is a consistent case and I hope we can find the reason for this insider. 

@YanranHao @AndrewHansen hi there meanwhile I have bought a new SSD 870 EVO and the behaviour is the same as with this internal NVME.

Also I am on 20295 now. It would mean a lot of work to go back and find out when this was introed and if I would see the same with 2019 LTSC. 

What can we do?


So can exclude finally exclude following factors imho:

- NvME driver (MS Default NvME or Samsung NvME 3.3)

- device issue


as the new SSD is connected via SATA3 an not NvME.

When you have time to reproduce this, can you please assure that you also have the deduplication feature installed? It does not have to be configured for the drive we want to format.