Iso of buld 20282 brokern?

Brass Contributor

I have tried several times to download the iso for the build 20282 of Windows Server vNext LTSC. One of them was via Microsoft Edge, on the previous Windows Server vNext LTSC build. I tested if the iso downloaded properly by un-zipping the iso with 7zip. It gave erros on multiple files. So, deleted the iso, then downloaded it again, on another machine that has Ubuntu 20.04 as the only os and used Firefox to download the iso. After the download, transfered the iso to an external hard drive, then to the Windows Server testing machine. When I un-zipped using 7zip, I got the same error message. Burn it to a DVD RW and tried to install from scratch, it failed to boot. Tried an in-place upgrade using both the setup file on the base of the installing DVD, then the setup file in the sources folder. Both were not working. The iso files might be broken.

13 Replies

@Radu Ilie what language do you select for download? Can you please check the SHA-1 hash of the file? For English download it should be C73C74B60F5A72564BDA031FDCFCB087996C5708. Thank you!

I agree with @Artem Pronichkin . @Radu Ilie you can use Powershell and the Get-hash command to get the hash of the file. I suggest to compare SHA256 for more security. It might not help you but my en-us b20282 LTSC ISOs work fine. 

Unfortunately there are none for SAC. 

best response confirmed by Elden Christensen (Microsoft)
Microsoft Verified Best Answer

I have re-downloaded the iso from another machine, in another location, with another ISP. The broken iso I had downloaded was already deleted, so not way to check to checksum. The re-downloaded iso seems fine, I was able to burn it to DVD and install it on the test machine.

Great to hear you are now up and running Radu.  Thank you for downloading and trying out the Windows Server Insider builds.



Actauly, the iso has repeated itself with build 20285. I can not download it from my ISP. No, downloading from another machine connected to other ISP is not a full solution, just a workaround.

@Elden Christensen 

I have download3ed the 20285 build from the same computer I have downloaded the 20282, not my own machine and not my own ISP. For a few months now, I have issues with the ISP, unfortunately, I can not change it. Something goes wrong in the download process, the same thing happened for both 20282 and 20285 iso files. I remember that, back in the day, when I had downloaded the beta iso for Windows 7, Microsoft offered for install the Akamai Download Manager, that did the job well. Those days I have downloaded a large Linux VHDX (larger then the Windows Server Insider iso)using the BitTorrent protocol, having the Transmission BitTorrent client and it went fine. This shows that a download manager seems to be the solution, at least for now. Perhaps someone can recommend a good download manager that is also free of charge, to be able to download the Windows Server Insider iso, next time. Akamai Download Manager seems to have disappeared.

@Radu Ilie which browser do you use Radu

  •  and what are the settings for internet options (no matter you are using IE or not) 
  •  I would recommend to disable TLS 1.1 / TLS 1.0 and enable TLS 1.2 there. 
  • Do you use 3rd party AV? You might want to check your system with Malwarebytes (free version only) if there is really nothing that has compromised the system. It is a great companion to Microsoft Defender. I would not recommend to use MBAM full version as it gives me a lot of troubles with performance and webfilter often enough and replaces Defender.
  • Otherwise if the image get corrupted I could only suspect deep packed inspection by a proxy or firewall. 


However download managers are not necessary imho. I would like recommend to use the new Edge browser which is a giant leap over Download Microsoft Edge Browser | Microsoft


Thanks for more details on your scenario. if you don't mind please let me know your networking adapter you are using for the download and driver version screenshots from device manager would be great.


Microsoft Edge on the previous Windows Server vNext build failed to download the 20282 iso, as well as Firefox on an Ubuntu 20.04 machine, both my test machine for Windows Server vNext and the Ubuntu machine share the rooter and the same ip. I have tried to download 20285 on Firefox, on Ubuntu, I had the same checksum issue. In the last few months, I have noticed issues on my internet connection, the download speed decreased pretty much (FTP), but web navigation did not seemed to be much affected (HTTP). The Huawei HG658 rooter belongs to my ISP, it is not my property, I do not know how much I am allowed to tap into it and change it. The builds 20282 and 20285 were downloaded in another location, with a different ISP, different rooter type, and much better download speed. Something is wrong, I do not know where. If the connection fails, the only solution would be, as I see it, to get a download manager like the one from Akamai that I knew years ago. Perhaps the servers from Microsoft were not configured to take into account a strange technical situation like this. I do not know what is going on, what I know is that I can not download the iso from this page, previous builds could have been downloaded.


The Akamai Download Manager that know seems to be discontinued worked, partially, in a similar way to the BitTorrent protocol, meaning that it split the file to be downloaded into several pieces, downloaded them separately, then re-asambled them into one file. The success into downloading that very large Linux vhdx via BitTorrent, using Transmission as BitTorrent client shows that, in the situation, a download manager like the defunct one from Akamai would, most likely, do the trick. The download speed would still be slow but, once the file was downloaded, it would not be corrupted. 

Hello from spain @Radu Ilie ... to download fast and without bugs... try with JDownloader.. that can reconnect automatically and download big files. have fun bro.

JDownloader seems abandoned since 2016. I do not know how safe shall it be to run it Windows Server vNext with Chromium Edge. I have tried Free Download Manager yesterday, it failed.

Also I have downloaded a Linux iso file, a small one, and the that iso seemed corrupted as well. So, it seems, it is something relating to the ISP, most likely.

I'm sorry to hear it, I know that with command prompt you can download too... I will fill in the command... and I will give you it... Give me one day, so I have a lot homework to do today... In sorry for my bad english, i am spanish

I have re-download that Linux iso, after discovering that their website has a function of online verification of the integrity of the downloaded iso. I have downloaded it on my other machine, the non-Windows one, and that iso seemed ok. So, it seems that, at least some iso file download correctly. Yet, that iso was small, just about 1,1 gb.

1 best response

Accepted Solutions
best response confirmed by Elden Christensen (Microsoft)
Microsoft Verified Best Answer

I have re-downloaded the iso from another machine, in another location, with another ISP. The broken iso I had downloaded was already deleted, so not way to check to checksum. The re-downloaded iso seems fine, I was able to burn it to DVD and install it on the test machine.

View solution in original post