Cannot Change Adapter settings

Copper Contributor

Windows Server 2019 TP build 17713 and earlier build 17650.

I cannot change the network adapter settings when the server is a domain controller and logged in as a Domain Administrator. The following error will show up:

Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item.


I am able to change the network adapter settings on standalone server Windows 2019 TP logged in as local Administrator.


Any tips to be able to change the network settings?

14 Replies


If you go to Server Manager->Local Server and in Properties view you see you´r nic. Change there?

Regards Phil

Yes, that's correct...I need to find the old Control Panel (Old GUI).

It does not allow to change the NIC settings from the Start Menu > Settings gear icon (Win10 GUI) or right clicking from the NIC icon at the task bar.

@Philip Rosen wrote:


If you go to Server Manager->Local Server and in Properties view you see you´r nic. Change there?

Regards Phil


Yeah. Now tell me how to change the VLAN that Hyüer-V injects there. Hint: you can not ;) How do I enable things like Routerguard or disble them? Hint: you can not. This is not about "oh, i am stupid", it is about a bug. Changing things in the VM does not help. THis is a bug - one that really needs fixing.

I am currently experiencing the same issue.  Did you ever get a resolution to this issue?  I installed my first two Windows 2019 Servers as DC's.  One worked perfectly the other did not.  


If I recall correctly, on one server I installed Windows 2019 and then went straight to Add Roles/Features to make it a DC without joining the domain first.


On the second server, I joined the domain and then promoted it to a DC.  This was the one that didn't work.  I've even demoted the server and checked the local Administrators group.  It's showing Domain Admins (which is how am I am logged in) in the Local Administrators group.   


Any thoughts on what is going on or what I may have done incorrectly?




I have the same problem, it must be a bug, because if you go to the domain and "copy" the "administrator" account to a new account, and log in to the server, you have been able to open the network card settings.

Look at this, it was a server policy that needs to be modified. Resolved for me .. ( forum = win10itprogeneral)

The problem is happened on 2019, if you use the "administrator" Account as primary Admin-Account (after Domain Join). Create a new user and apply the admin-groups and you will have no error.

This was the fix for me. Just spun up a VM on 6.7, Server 2019 Standard.

After adding AD and elevating to a DC the local admin no longer functions as an elevated admin within the domain. 

Copy local administrator account, rename to what you need and reboot. 

Problem staying solved, 

@Philip Rosen  This worked perfect for me, and I had the problem the op had. Thank You !

@Philip RosenGreat! It works there. Thanks.

Thank you for reporting this issue, we are working to address this issue in a future release of Windows Server.  Please leverage the workaround highlighted in this thread for the time being.  Apologies for the inconvenience and thank you for your patience while we work to address this issue.



@Elden Christensen I have tried the work around mentioned and I am still having the problems after rebooting the computer and signing in with the new Admin Account.  I am running Sever 2019 Datacenter Evaluation version 10.1.17763 Build 17763.

I removed the initial new administrator profile and did another one and then signed back in with the new one, and it finally worked.


This may not relate to topic but best feature added to Server 2022 is network reset. Saved me several times.