Wsus windows 21h1 update

Occasional Contributor

Hello everyone,

my wsus server (server 2016) synced the feature update to 21H1 but every client (all 20H2) is reporting not needed.

I noticed that it synced only the full update and not the enablement package.

Anyone have the same problem or know something?


Thank you

8 Replies
Are they old devices or new one?
Sometimes, there might be a blocking issue like there is compatibility issue and the update is not applicable yet.
Do a quick test and try check for update in one of the device manually and see if it offers the update to 21H1?
I tried to check online updates on two clients with completely different hardware and it not offered the update so I suppose you are right and the clients could not be ready.
But you have any guess on why wsus didn't sync the enablement package update?
i tried again today on one client to check online updates and it offer me the 21h1 upgrade, but wsus is still reporting as not needed.
On 7 july i made a reset to the wsus wsus for other reason and resync from scratch.
Still no enablement package synced.
Sorry to everyone, my very bad.
The enablement package is synced but when declining the fresh install on 7th july, i mistakenly declind it.
I fixed the problem and now everything is fine.
Sorry again.
best response confirmed by alescan (Occasional Contributor)
Thank you for the update and glad problem have been solved.
I am missing 21H1 as an option in my WSUS. 1903, 2004 and 20H2 were all downloaded just fine with my current configuration but 21H1 (either full or enablement) options are not available. Did you have to tweak your "products and classifications" to get 21H1 to download in WSUS?
No, you only need to select Windows 1903 and later.
Maybe you can try for a reset like I did.
@alescan. Thank you for the reply. My issue was the Upgrades classification got turned off somehow in my configuration. Once I turned that back on the update came down.
I appreciate your reply!