WS2016 failover cluster issues

Occasional Contributor

Hello all,


At work we have recently purchased 4 new and shiny Dell R730's. We have got 2 of the new servers in the new cluster and in operation at the moment. We have got 4 10gbe connections to the switch and SAN, on the 2nd node we have only got one resilient link to switch/SAN.


We have had to migrate our production exchange server to it over the weekend (even though the new cluster is still being tested) as everytime we tried to restore using VEEAM it caused the host in the old (overcommitted) cluster to BSOD. So as our options were limited we placed it on the new cluster. Everything worked fine until the moment I walked through the door this morning, when the iSCSI nic on the 1st node ended up being disabled (attempts to reenable were unsuccessful). I managed to sort of bring it back by enabling the 2nd iSCSI link (Dell Host Integration Tools for WS2016 haven' been released yet :( )


I had to reboot the 2nd node this afternoon as there was locked resources on it, as the 2nd node rebooted. The 1st nodes connection to the SAN dropped again (killing exchange)


Is there any particular reason why this would have happened? and what is the best thing to do regarding Exchange. I don't want to move it back as we will only need to move it again soon anyway

2 Replies
best response confirmed by Andrew Baker (Occasional Contributor)

Hello Andrew,


Locking problems could be due to missing or wrong configuration of MPIO?


MPIO settingsMPIO settings

Do you have two dedicated NICs for iSCSI and two for the Hyper-V switch? Are you using Switch Embedded Teaming or regular NIC teaming on the Hyper-V switch?





Hi Erwin,

I logged a support ticket with the company helping us install it. The MPIO feature was not installed. We have two dedicated nics for iSCSI and two for data.