Windows Server 2022 / Ubuntu 20.04, 22.04 / Processor compatibility mode / "can't allocate initrd"

Copper Contributor



I tried to create a new virtual machine on my upgraded window server (2019 -> 2022). Before the upgrade it worked fine with Ubuntu 20.04 linux virtual machines (gen 2).

But now the boot stops with "can't allocate initrd".

Disabling "Processor compatibility mode" helps, but blocks live migrations to different servers.

Can't even boot a live disk.


This happens on a System with a AMD Ryzen 5 3600 but not on a AMD Ryzen 7 5700G.


Without quiet mode i got a kernel panic.




4 Replies
Creted now a gen1 VM and installing ubuntu 20.04 seems to work. Any ideas?
Got to remove the quiet flag, now getting `Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)` on the live disk
It seems the "Processor compatibility mode" feature is the cause. When enabled i get the mentioned error.
Still happens on `Ubuntu 20.04.5 LTS (GNU/Linux 5.15.0-1031-azure x86_64)`.
Also happens on `5.15.0-58-generic` kernel on Ubuntu 22.04