Windows Server 2019 not using WPAD file

Contributor

Hi,

 

Has anyone seen an issue where IE is configured to autodetect, downloads the wpad file but then still appears to not use the proxy. I have a Windows 10 machine using CrEdge which works with the same file and installing Chrome on the server also works fine. So I don't think it's the file, this also appears to affect WinHTTP so services using that like powershell and MDE are also trying to go direct.

I've confirmed the dns name is resolvable and that the file is present, i've also got a wireshark trace that shows wpad.dat is requested and gets a 200 response with the file I expect.

6 Replies
Have you tried the Microsoft Edge too?
It is recommended to use Microsoft Edge.
Edge isn't part of Server 2019 and the legacy edge isn't supported anymore. CrEdge is based on Chromium so would expect is to be the same as Chrome. The issue seems to be around the use of WinHTTP to discovery the proxy.
Microsoft Edge is the replacement for Internet Explorer and you may download it from: https://www.microsoft.com/en-us/edge/business/download
Just select Windows x64 bit (considering you are using x64 bit version of Windows Server) and it will work.

@Reza_Ameri been through this, CrEdge works as expected (it doesn't use WinHTTP to perform WPAD decisions). Weirdly it only appears to be an issue on servers that are promoted to DCs (I think, I need to do some more testing before I am sure) 

Thank you for update, actually Internet Explorer is for backward compatibility and the recommendation is to use Microsoft Edge as the default browser.
Hi SimonR,
I have the same problem after a dcpromo.
I have solved the problem by reconstructing the permissions in the registry.
In my case the following path "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control" has the owner "Domain Admin". Every other Server has the owner System. I activate the inheritance on the Key Control and the permissions where set again. After this, the owner changed to "SYSTEM" and wpad works.