Windows 2022 will not display on 3+ monitors correctly

Copper Contributor




  • I have what I consider an odd situation, where I have 4 separate T420 Dell Power Edge Servers and I am having issues getting 3 monitors to Display on them, unless I use a single card that has 3 outputs

Server 1: T420, Dual Proc, 384 gigs of ram, Dell Nvidia Quadro 4000x(2) .

Situation 1(fails): 2 monitors plugged into each card for a total of 4 monitors. However, only 2 will have a picture. Depending on the order of plugging in the cable determines which monitors get a picture. So I only get 2 monitors

Situation 2(fails): (Same Server) I removed 1 of the Nvidia Q4000 cards. I plugged in 2 monitors and they displayed. I then used a USB WavLink, which has 2 additional (wimpy GPU) outputs. Again only 2 monitors will display. No matter what order I plug in, its just 2.

Situation 3 (works): (Same Server) I have another NVidia Card that supports 3 monitors for sure. So I unplugged the WavLink, Removed the Q4000 card and installed the Nvidia 1050 card. plugged in all the monitors and Bingo all of them lit up properly.


I am able to repro this on all my Dell T420s. 


What I have tried:

  1. Verified that the drivers are updated
  2. Verified in Device Manager that Windows Serve 2022 actually sees the devices
  3. In Device Manager, it shows I have 3 monitors (It lists all 3)
  4. In Device manager, when I right click a Monitor and look at the properties, under Location, (first page under General), it clearly shows the Location for each and in each case, they are properly assigned to the corresponding plug either on the Card(s), or on the LAPDOCK(wavlink), but the monitor will not show a picture.
  5. Made sure the cards were plugged into the correct lane/pcie slot
  6. Made sure to disable the onboard  GPU
  7. Rebooted... a lot
  8. Refreshed the entire system, so it only had Windows 2022 on it and the drivers for the video card and wavlink but still only 2 monitors actually show a picture.
  9. Looking in  Device manager at the events for the hardware, I see nothing but good messages
  10. All my Dells have the latest BIOS/Firmwares, everything. I even tried different memory and each machine of course has their own Dual Procs, and they are different in 2 of the 4.
  11. I have 3 total WavLinks and another USB (video) and same issue, still only 2 monitors
  12. Installed the Monitor driver (so it shows the correct Monitor versions)
  13. Here is something of note: On one of the servers, I installed the Dell Monitor Manager. Even though Windows (Device Manager) clearly shows 3 Monitors on the correct port/card, the Dell Monitor Manager Only shows 2

I'm lost... I really need to get this working so I would appreciate any thoughts, etc.

P.S. Yes I did reach out to Nvidia and Dell and each one of them blames the OS... but I have no idea how or why.

P.S.S. If I have all the cables plugged in and it only shows 2, if I unplug one of the cables for the monitor that is showing, it goes off  and the one that wasn't on, comes on.



5 Replies

The hardware looks a little old so I wouldn't expect too much.




While I appreciate its older, that doesn’t explain why windows can see the 3 incoming ports (from separate cards) but it will only display on 2 monitors. However if I put in a card that has 3 usable ports on it, i can use 3 monitors. Meaning I don’t use secondary cards or usb GPUs to get a 3rd monitor

2019 did not have this issue. Only 2022 and it’s on completely refreshed, OS only with patches and video drivers.

So I have 2 T420s that have 3 monitors (single card) going and 2 that only have 2.

With the Video card market being crazy prices wise it was cheaper to get 2 Dell Q4000 cards and/or USB video.

I guess I need to hook up the Kernel debugger and attempt to figure it out

You'll likely need to start by installing a supported operating system to figure things out. 




It’s actually a weird situation. If I plug in a vga cable to the server and plug that into one of the monitors that also had the dvi plugged in, then all 3 monitors work. But technically I should be turning off the onboard according to Dell so /shrug.

Always expect the unexpected when you install an unsupported operating system. Might also ask in the dell forums to see if other users have some sort of work-around.