Windows 10 clients does not download 2004 (1909) Upgrade from 2016 WSUS Server

Copper Contributor


On our Network there is a Windows Server 2016 running with the latest updates and WSUS. Our clients can update themself from WSUS, but the bigger upgrade to the new Windows 10 versions like the 1909 or 2004 does not work. It seems that the client downloads the "WindowsUpdateBox.exe", but it can not download the .esd file from the server, just throws an error of 0x80070057. The server does contain the .esd file for the upgrade, but the client can not download it.

As I have read in many forums, the IIS should contain the MIME-TYPE for the .esd files of application/octet-stream, so I was looking for it and my server already had an entry point for that type. Changing it to application/octet-stream did not change the clients behavior.

I have read that these upgrades are quailified as "dynamic updates" and the clients try to download these .esd files from the MS update, not the WSUS server. How could I force them to try the download from our server? All of our clients are behind an authenticated proxy, and it is not an option to let them out to update freely.

The GPO which not let them out to the Windows update online would disable Windows store as well, but we need that function to work too.

What option do I have left, how could I force the clients to upgrade from WSUS?

5 Replies

@ZahalkaBencei have the same problem.

have you found the solutions?



best regards



Have you try steps from the documentation:


Also, on this page you can find details description of the error you have





@buzelac Thank you for showing me the usual WSUS problem solving things, but this one is not anything like in those docs. This problem is specific to the weird mechanism when the client tries to download the update from the server, but only the half of the files does it download from there. The windowsupdatebox.exe is downloaded nicely from it's location, but it tries to download the biggest part (the .esd file with its few GB) from the MS update servers, not from my WSUS server.


Anyway, my clients started to download the esd file as well after a few weeks without changing anything. Maybe one of the other updates did fixed the problem, don't know.

After a few weeks my clients started to download the esd file as well, maybe one of the other updates did the trick, don't know why is it working now.
Thanks to all for the replies.
I have tried all the various solutions found in the forums, but none of them worked.

At this point, i believe the problem is of WSUS, i'll try to wait a few days. But the strange thing is that some clients works perfectly.
O believe I will start using endpoint manager, Microsoft appear to be ditching WSUS.