Windows 10 can't see active directory domain on Windows Server 2016

Copper Contributor

Hi all


I hope you can help.  I am trying to connect my windows 10 pro laptop to my windows server 2016 Active Directory Domain and yet when I try to join the domain, the error message is that the domain doesn't exist.

I have made sure I have the following services running:
DNS Client
SSDP Discovery
UPnP Device

On the server:
IP4:  ***.***.***.51

Subnet mask:

Default gateway: ***.***.***.1 - ip of router

DNS: - I have read conflicting information about the DNS settings!

On the client:
IP4: ***.***.***.07

DNS: ***.***.***.51 - server's IP

My laptop is a named user in Active Directory.  I have checked the domain name.  I  can ping the server, but can't ping the domain.  I disable the firewall on  the domain, just to test it and it hasn't made a difference.


Can anyone help me with this - I know there is probably a simple setting that I overlooked!!


Thanks in advance

21 Replies

I'd check the domain controller and problem member both have the static ip address of DC listed for DNS and no others such as router or public DNS. If problems persist please run;

  • Dcdiag /v /c /d /e /s:DCName >c:\dcdiag.log
    (please replace DCName with your domain controller's netbios name)
  • repadmin /showrepl >C:\repl.txt
  • ipconfig /all > C:\dc1.txt
  • ipconfig /all > C:\dc2.txt
  • ipconfig /all > C:\problemworkstation.txt

then put unzipped text files up on OneDrive and share a link.

@Dave Patrick 


Thanks for replying :)
I changed the DNS on the server to be its fixed IP address and the second DNS to point to  I then changed the second DNS on the client to be


I then ran the DCDiag and got an error 81 saying the host **server could not be resolve to an IP address.  Then it bugged out!

Yes, that's not going to work. All domain members must use domain DNS exclusively. Members use domain DNS so they can find and logon to domain. Internet queries are passed along by default to root hint servers in a top-level-down fashion. You can optionally add public DNS addresses as forwarders.


(please don't forget to mark Best Response if helpful)








@Dave Patrick 

Sorry I misread what you said - should I remove the secondary DNS?  I didn't have them in to start with.

Correct,  domain controller and problem member both have the static ip address of DC listed for DNS and no others such as router or public DNS. If problems persist please the mentioned files up on OneDrive.



@Dave Patrick 


I'd love to send you the files, but - I can't run DCDiag as it bugs out with an 81 error... :(

I've uploaded the server's ipconfig and the workstation's ipconfig and the repadmin.


Very much appreciate your help - thanks :)

Sounds like you didn't run using the NetBIOS name of domain controller. You can find this by running;

echo %computername%



Library is empty (no files on OneDrive)



@Dave Patrick 

Okay maybe this is where I'm getting confused - my computer name is 2016server, my netbios name is 1405server?  The domain I am trying to connect to is the netbios name no?

I moved the files into documents, so you should be able to see them now?

Still no files. Having two names for a domain controller may also be problematic.



@Dave Patrick 

Loaded DCDiag.log by using the computer name - it's in the documents with the other stuff :)

@Dave Patrick 


try this link..!Akl0VFdpvCaKhVxLonh0BIztff3w


I thought when I set up Active Directory I needed a unique name for the domain, rather than the computer name?  Is there a way to edit this in AD to check whether that's the problem?

Sounds good, but there are still no files.



Yes, that worked. I only looked at the ipconfig /all 's There is an active IPv6 DHCP server on the network which must be configured correctly or the easier option (assume router) is to turn off IPv6 DHCP server in router.

If problems persist then put up a new set of files after changes.




What changes am I looking for in the diag files to show me an active versus a non active?

IPv6 DHCP assigned ip address, gateway and DNS



@Dave Patrick 

I've disabled IPv6 on the server, I can't login to my router to disable IPv6!
The diag is hanging on the server now....

best response confirmed by Bill1505 (Copper Contributor)
1 best response

Accepted Solutions
best response confirmed by Bill1505 (Copper Contributor)