VBox: Remote Management / Add Roles & Features: The WS-Management service cannot process the request

Copper Contributor



I have installed Windows Server 2019 in a VirtualBox 6.1 machine.

In the Server Manager I want to activate remote management and install roles like AD DS, but these error messages appear:


Local Server \ Remote Management: "The WS-Management service cannot process the request because the XML is invalid."

Add Roles and Features: "The WS-Management service cannot process the request. The service in configured to not accept any remote shell requests."


I have created the VirtualBox virtual machine as "Windows 2016" and tried several options like EFI, I/O APIC, PAE/NX, nested VT-x, nested paging, NAT, bridged adapter.

In the Local Group Policy Editor (Windows Server virtual machine), I have manually enabled "Allow Remote Shell Access" in Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Remote Shell and run gpupdate /force.

I have also installed Windows Server in VirtualBox on two other computers, but the same problem appears.


I hope anyone can help me solve this problem. What has to be configured to make the WS-Management service work correctly?

3 Replies
The same happens to Windows Server 2019 in VirtualBox, what I have tried out since yesterday. So, this is a general issue of Windows Server in VirtualBox rather than a special insider preview build issue.

Might also try using windows hyper-v or ask this one in virtualbox forums.